Bug 1130156 - pkcheck --help mentions --list-temp but does not implement it
Summary: pkcheck --help mentions --list-temp but does not implement it
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: polkit
Version: 6.5
Hardware: All
OS: Linux
low
low
Target Milestone: rc
: ---
Assignee: Miloslav Trmač
QA Contact: Karel Srot
URL:
Whiteboard:
Depends On:
Blocks: 1194523
TreeView+ depends on / blocked
 
Reported: 2014-08-14 12:54 UTC by Martin Žember
Modified: 2015-07-13 04:14 UTC (History)
3 users (show)

Fixed In Version: polkit-0.96-8.el6
Doc Type: Bug Fix
Doc Text:
Cause: Consequence: The output of pkcheck --help did not match actually supported arguments and their expected form. Fix: The output of pkcheck --help was fixed. Result:
Clone Of:
: 1194523 (view as bug list)
Environment:
Last Closed: 2015-03-17 13:39:15 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:0692 normal SHIPPED_LIVE polkit bug fix update 2015-03-17 17:38:51 UTC
FreeDesktop.org 29936 None None None Never

Description Martin Žember 2014-08-14 12:54:29 UTC
Description of problem:
pkcheck from polkit-0.96-6.el6 displays usage with --list-temp but it does not implement it yet
Man page is OK, it does not mention it

Version-Release number of selected component (if applicable):
polkit-0.96-6.el6

How reproducible:
Always

Steps to Reproduce:
1. Run pkcheck --list-temp

Actual results:
$ pkcheck --list-temp
pkcheck: Subject not specified
$ pkcheck
pkcheck: Subject not specified


Expected results:
List temporary authorizations

Additional info:

Comment 1 Miloslav Trmač 2014-08-14 13:02:37 UTC
Thanks for your report.  This is a bug in the fix of #628862.

Comment 2 Miloslav Trmač 2014-08-27 16:24:11 UTC
Actually most lines in pkcheck --help are wrong; will close this as a duplicate of #628862 and deal with this in the respin.

*** This bug has been marked as a duplicate of bug 628862 ***

Comment 4 Miloslav Trmač 2014-08-27 20:21:27 UTC
Actually, will have to defer this.

Comment 9 errata-xmlrpc 2015-03-17 13:39:15 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-0692.html


Note You need to log in before you can comment on or make changes to this bug.