Bug 1130183 - Make it possible to disable doing tasks async
Summary: Make it possible to disable doing tasks async
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Transitions
Version: Unspecified
Hardware: Unspecified
OS: Unspecified
unspecified
medium vote
Target Milestone: Unspecified
Assignee: Matej Kollar
QA Contact: Lukas Pramuk
URL:
Whiteboard:
Depends On:
Blocks: stargate-GA-tracker
TreeView+ depends on / blocked
 
Reported: 2014-08-14 13:57 UTC by Matej Kollar
Modified: 2014-09-11 12:19 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-09-11 12:19:37 UTC


Attachments (Terms of Use)

Description Matej Kollar 2014-08-14 13:57:24 UTC
Description of problem: When scheduled lots of tasks in async, we occasionally get into "unresponsiveness" issue. To avoid/workaround this, we can not do async things and just wait for the tasks and do things one by one.


How reproducible: nondeterministic

Steps to Reproduce:
1. import multiple larger Red Hat repos

Actual results:
  machine stops responding

Expected results:
  ...

Comment 1 RHEL Product and Program Management 2014-08-14 14:03:05 UTC
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 3 Tomas Lestach 2014-08-14 14:21:16 UTC
By specifying a max. number of parallel tasks, we may reduce the sat6 load. By setting it to '1', the tasks would be run one by one.

Comment 4 Grant Gainey 2014-08-14 14:46:13 UTC
Yeah, that was my thought as well - lets us put it under user-control, too.

Comment 5 Matej Kollar 2014-08-15 17:48:01 UTC
First take at this...
hammer-cli-import.git: 80dde679c2eec586b2114df34c727a966c1c2b9f

Comment 6 Matej Kollar 2014-08-18 14:53:39 UTC
Extend code so it is accessible...
hammer-cli-import.git: ca1889f8d3fbbf54b6889dbf19fc795a1774ea8b

Comment 7 Grant Gainey 2014-08-22 17:41:10 UTC
Need this for GA - running as-asynch-as-possible tends to cause unpredictable behavior in Sat6, customers will need to be able to throttle

Comment 9 Grant Gainey 2014-09-03 17:49:36 UTC
DEVELOPER VERIFIED:

1) start with a Sat6 that has its orgs and manifests, which has not sync'd any Red Hat content yet, and a channels.csv that has multiple Red Hat channels.
2) hammer import repository-enable --synchronize --wait
3) In the UI, go to <sat6>/katello/sync_management and Expand All
4) Note that *all* the repositories have sync-tasks started

Next:

1) start with a Sat6 that has its orgs and manifests, which has not sync'd any Red Hat content yet, and a channels.csv that has multiple Red Hat channels.
2) hammer import repository-enable --synchronize --wait --no-async
3) In the UI, go to <sat6>/katello/sync_management and Expand All
4) Note that at any given moment, only one repository is synchronizing, and that a new one starts when the first finishes.


Verified on rubygem-hammer_cli_import-0.10.4-1.1.el6sat.noarch

Comment 10 Bryan Kearney 2014-09-11 12:19:37 UTC
This was delivered with Satellite 6.0 which was released on 10 September 2014.


Note You need to log in before you can comment on or make changes to this bug.