Bug 1130191 - [abrt] fedora-cert: proxyclient.py:473:send_request:AuthError: Unable to log into server. Invalid authentication tokens. Send new username and password
Summary: [abrt] fedora-cert: proxyclient.py:473:send_request:AuthError: Unable to log ...
Keywords:
Status: CLOSED DUPLICATE of bug 1126918
Alias: None
Product: Fedora
Classification: Fedora
Component: fedora-packager
Version: 22
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Dennis Gilmore
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:05b1d7a07c29068e3b90d8d52d2...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-14 14:03 UTC by Stefan Ringel
Modified: 2016-05-22 10:07 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-05-22 10:07:18 UTC


Attachments (Terms of Use)
File: backtrace (1.71 KB, text/plain)
2014-08-14 14:03 UTC, Stefan Ringel
no flags Details
File: environ (2.57 KB, text/plain)
2014-08-14 14:03 UTC, Stefan Ringel
no flags Details

Description Stefan Ringel 2014-08-14 14:03:22 UTC
Version-Release number of selected component:
fedora-cert-0.5.10.4-2.fc21

Additional info:
reporter:       libreport-2.2.3
cmdline:        /usr/bin/python /usr/bin/fedora-cert -n
dso_list:       python-fedora-0.3.36-1.fc22.noarch
executable:     /usr/bin/fedora-cert
kernel:         3.16.0-1.fc22.x86_64
runlevel:       N 5
type:           Python
uid:            1000

Truncated backtrace:
proxyclient.py:473:send_request:AuthError: Unable to log into server.  Invalid authentication tokens.  Send new username and password

Traceback (most recent call last):
  File "/usr/bin/fedora-cert", line 71, in <module>
    main(opts)
  File "/usr/bin/fedora-cert", line 27, in main
    fedora_cert.create_user_cert(None)
  File "/usr/lib/python2.7/site-packages/fedora_cert/__init__.py", line 96, in create_user_cert
    cert = fas.user_gencert()
  File "/usr/lib/python2.7/site-packages/fedora/client/fas2.py", line 866, in user_gencert
    request = self.send_request('user/dogencert', auth=True)
  File "/usr/lib/python2.7/site-packages/fedora/client/baseclient.py", line 369, in send_request
    auth_params=auth_params, retries=retries, timeout=timeout)
  File "/usr/lib/python2.7/site-packages/fedora/client/proxyclient.py", line 473, in send_request
    'Unable to log into server.  Invalid'
AuthError: Unable to log into server.  Invalid authentication tokens.  Send new username and password

Local variables in innermost frame:
username: 'linuxtv@stefanringel.de'
retries: 0
cookies: <<class 'requests.cookies.RequestsCookieJar'>[]>
req_params: None
timeout: 120.0
url: 'https://admin.fedoraproject.org/accounts/user/dogencert'
session_id: None
self: <fedora.client.fas2.AccountSystem object at 0x7fbbf571f1d0>
auth: None
method: 'user/dogencert'
headers: {'Accept': 'application/json', 'User-agent': 'Fedora Account System Client/0.3.36'}
num_tries: 0
complete_params: {'login': 'Login', 'password': '3x56Q\xc3\xa4', 'user_name': 'linuxtv@stefanringel.de'}
http_status: 403
auth_params: {'username': 'linuxtv@stefanringel.de', 'password': '3x56Q\xc3\xa4'}
file_params: {}
password: '3x56Q\xc3\xa4'
data: None
response: <Response [403]>

Potential duplicate: bug 1111765

Comment 1 Stefan Ringel 2014-08-14 14:03:25 UTC
Created attachment 926817 [details]
File: backtrace

Comment 2 Stefan Ringel 2014-08-14 14:03:26 UTC
Created attachment 926818 [details]
File: environ

Comment 3 Jaroslav Reznik 2015-03-03 16:12:30 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 22 development cycle.
Changing version to '22'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora22

Comment 4 Till Maas 2016-05-22 10:07:18 UTC

*** This bug has been marked as a duplicate of bug 1126918 ***


Note You need to log in before you can comment on or make changes to this bug.