Bug 1130205 - Error encountered while installing rhevm-dwh
Summary: Error encountered while installing rhevm-dwh
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-dwh
Version: 3.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: ---
Assignee: Shirly Radco
QA Contact: Pavel Stehlik
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-14 14:23 UTC by Petr Beňas
Modified: 2015-08-11 19:21 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-14 16:04:12 UTC
oVirt Team: ---


Attachments (Terms of Use)
archived logs (182.39 KB, application/bzip2)
2014-08-14 14:23 UTC, Petr Beňas
no flags Details

Description Petr Beňas 2014-08-14 14:23:24 UTC
Created attachment 926823 [details]
archived logs

Description of problem:
psql: FATAL:  Ident authentication failed for user "engine_history"

Version-Release number of selected component (if applicable):
3.3.4-2.el6ev

How reproducible:
2/2 automated, 0/2 manually

Steps to Reproduce:
not sure
1. run rhevm-dwh-setup with an answerfile thru ssh connection


Actual results:
Creating DB Schema...                                 [ ERROR 

Expected results:
successful installation

Additional info:
2014-08-14 14:27:56::DEBUG::common_utils::972::root:: retcode = 2
2014-08-14 14:27:56::ERROR::decorators::27::root:: Traceback (most recent call last):
  File "/usr/share/ovirt-engine-dwh/decorators.py", line 20, in wrapped_f
    output = f(*args)
  File "/usr/bin/rhevm-dwh-setup", line 162, in createDbSchema
    envDict={'ENGINE_PGPASS': PGPASS_TEMP},
  File "/usr/share/ovirt-engine-dwh/common_utils.py", line 975, in execCmd
    raise Exception(msg)
Exception: Error while trying to create ovirt_engine_history db

2014-08-14 14:27:56::ERROR::rhevm-dwh-setup::703::root:: Exception caught!
2014-08-14 14:27:56::ERROR::rhevm-dwh-setup::704::root:: Traceback (most recent call last):
  File "/usr/bin/rhevm-dwh-setup", line 635, in main
    createDbSchema(db_dict)
  File "/usr/share/ovirt-engine-dwh/decorators.py", line 28, in wrapped_f
    raise Exception(instance)
Exception: Error while trying to create ovirt_engine_history db

Comment 1 Petr Beňas 2014-08-14 16:04:12 UTC
Failed due to workaround in testing code. We were creating the tables and roles and setting the otopi db provisioning option to false. Seems like 3.3 dwh setup (not using otopi) has a problem when the DB and role already exists.


Note You need to log in before you can comment on or make changes to this bug.