Bug 113021 - up2date cannot install packages (fail md5 and signature)
Summary: up2date cannot install packages (fail md5 and signature)
Status: CLOSED DUPLICATE of bug 111601
Alias: None
Product: Fedora
Classification: Fedora
Component: up2date   
(Show other bugs)
Version: 1
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Adrian Likins
QA Contact: Fanny Augustin
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-01-07 14:53 UTC by Don Vanco
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 19:00:36 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Don Vanco 2004-01-07 14:53:17 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)

Description of problem:
up2date cannot complete updating the system - it sits with an 
hourglass after download and does nothing.

If I killl up2date and try to "rpm-U" against /var/spool/up2date all 
the packages fail on both MD5 and signature.  If I try to install 
with --nosignature and / or --nomd5 it still fails (depending on 
which option I list first in the rpm syntax the other will appears as 
the error - eg "rpm --nosignature --nomd5 ..." will return and MD5 
error and "rpm --nomd5 --nosignature ..." will return a signature 
error).

Version-Release number of selected component (if applicable):
4.1.16-1

How reproducible:
Always

Steps to Reproduce:
1. install FC1 (on Compaq DL320)
2. run up2date, installing required key
3. watch it hurl
4. try manually installing rpms, watch it hurl
5. update with "yum update" or "apt-get update" and watch it update 
your system then break Gnome (but that's a whole other bug)
    

Actual Results:  up2date is crippled for no apparent reason

Expected Results:  updates get installed, I get on with my life

Additional info:

Compaq DL320, has been running RHL forever (and will liekly be taken 
back to RHL9).

Comment 1 Michael Young 2004-01-07 20:47:13 UTC
It sounds like the rpms you are downloading are corrupt, which may not
be a problem with up2date. However such corruption is more likly when
the server is busy, so you might have better results pointing up2date
at a mirror.

Comment 2 P Fudd 2004-02-06 08:51:32 UTC
The corruption is just that the file gets cut off halfway.  Resume the
download using something other than up2date; I use 'wget -c'.

The fix may involve up2date and rpm; up2date should download reliably
and rpm should tell you the file is not long enough before it tells
you that someone has messed with the contents.

Comment 3 Jef Spaleta 2004-02-06 15:41:17 UTC

*** This bug has been marked as a duplicate of 111601 ***

Comment 4 Red Hat Bugzilla 2006-02-21 19:00:36 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.