Bug 113024 - installing 2.6.0-1.30.i686 nets bad symlink in /boot
Summary: installing 2.6.0-1.30.i686 nets bad symlink in /boot
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel   
(Show other bugs)
Version: 1
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-01-07 15:36 UTC by raxet
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-01-19 09:49:13 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description raxet 2004-01-07 15:36:21 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20031016

Description of problem:
After installing kernel-source and kernel from rpm a bad symlink is made:

symlink that doesn't exist:  vmlinux-2.6.0-1.30 ->
/usr/lib/debug/lib/modules/2.6.0-1.30/vmlinux

made in /boot

Usually that link is /lib/modules/2.6.0-1.30/build/vmlinux



Version-Release number of selected component (if applicable):
kernel-2.6.0-1.30.i686

How reproducible:
Always

Steps to Reproduce:
1. install kernel-source-2.6.0-1.30
2. install kernel-2.6.0-1.30.i686
3. 
    

Actual Results:  incorrect symlink as:

lrwxrwxrwx  1 root root      45 Jan  7 08:28 vmlinux-2.6.0-1.30 ->
/usr/lib/debug/lib/modules/2.6.0-1.30/vmlinux

Expected Results:  lrwxrwxrwx  1 root root      45 Jan  7 08:28
vmlinux-2.6.0-1.30 -> /lib/modules/2.6.0-1.30/build/vmlinux

Additional info:

Comment 1 Arjan van de Ven 2004-01-07 15:37:58 UTC
the vmlinux is actually there in the kernel-debuginfo package; this is
done because it is rather big and not useful for the vast majority of
people (it's only useful for when you want to debug your kernel) so it
would be a waste of space and bandwidth if it was part of the standard
kernel package and not a subpackage instead.

Comment 2 Arjan van de Ven 2004-01-19 09:49:13 UTC
removed the symlink


Note You need to log in before you can comment on or make changes to this bug.