Bug 1130258 - API docs for lifecycle environments are incorrect
Summary: API docs for lifecycle environments are incorrect
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Docs API Guide
Version: 6.0.3
Hardware: Unspecified
OS: Unspecified
unspecified
medium vote
Target Milestone: Unspecified
Assignee: David O'Brien
QA Contact: jaudet
URL: http://projects.theforeman.org/issues...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-14 16:57 UTC by jaudet
Modified: 2016-04-22 16:41 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-03-17 00:22:42 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Foreman Issue Tracker 8116 None None None 2016-04-22 16:41:23 UTC

Description jaudet 2014-08-14 16:57:26 UTC
Description of problem:
The API docs for "POST /katello/api/environments" state the following about the "prior" parameter:

> Name of an environment that is prior to the new environment in the chain. It has to be either 'Library' or an environment at the end of a chain.

The above is incorrect. The "prior" parameter is an integer value, and it references the ID of some other lifecycle environment.

Version-Release number of selected component (if applicable):
This is true on qetello02.usersys.redhat.com, which is running Satellite 6.0.3. The following software is installed:

* apr-util-ldap-1.3.9-3.el6_0.1.x86_64
* candlepin-0.9.23-1.el6_5.noarch
* candlepin-common-1.0.1-1.el6_5.noarch
* candlepin-scl-1-5.el6_4.noarch
* candlepin-scl-quartz-2.1.5-5.el6_4.noarch
* candlepin-scl-rhino-1.7R3-1.el6_4.noarch
* candlepin-scl-runtime-1-5.el6_4.noarch
* candlepin-selinux-0.9.23-1.el6_5.noarch
* candlepin-tomcat6-0.9.23-1.el6_5.noarch
* elasticsearch-0.90.10-4.el6sat.noarch
* foreman-1.6.0.40-1.el6sat.noarch
* foreman-compute-1.6.0.40-1.el6sat.noarch
* foreman-gce-1.6.0.40-1.el6sat.noarch
* foreman-libvirt-1.6.0.40-1.el6sat.noarch
* foreman-ovirt-1.6.0.40-1.el6sat.noarch
* foreman-postgresql-1.6.0.40-1.el6sat.noarch
* foreman-proxy-1.6.0.27-1.el6sat.noarch
* foreman-selinux-1.6.0.6-1.el6sat.noarch
* foreman-vmware-1.6.0.40-1.el6sat.noarch
* katello-1.5.0-28.el6sat.noarch
* katello-ca-1.0-1.noarch
* katello-certs-tools-1.5.6-1.el6sat.noarch
* katello-installer-0.0.59-1.el6sat.noarch
* openldap-2.4.23-32.el6_4.1.x86_64
* pulp-katello-0.3-3.el6sat.noarch
* pulp-nodes-common-2.4.0-0.30.beta.el6sat.noarch
* pulp-nodes-parent-2.4.0-0.30.beta.el6sat.noarch
* pulp-puppet-plugins-2.4.0-0.30.beta.el6sat.noarch
* pulp-puppet-tools-2.4.0-0.30.beta.el6sat.noarch
* pulp-rpm-plugins-2.4.0-0.30.beta.el6sat.noarch
* pulp-selinux-2.4.0-0.30.beta.el6sat.noarch
* pulp-server-2.4.0-0.30.beta.el6sat.noarch
* python-ldap-2.3.10-1.el6.x86_64
* ruby193-rubygem-net-ldap-0.3.1-3.el6sat.noarch
* ruby193-rubygem-runcible-1.1.0-2.el6sat.noarch

How reproducible:
100%


Steps to Reproduce:
1. Go to http://qetello02.usersys.redhat.com/apidoc/v2/lifecycle_environments.html
2. Click on "POST /katello/api/environments".

Actual results:
> Name of an environment that is prior to the new environment in the chain. It has to be either 'Library' or an environment at the end of a chain.

Expected results:
> Lifecycle environment ID.

Additional info:
n/a

Comment 1 RHEL Product and Program Management 2014-08-14 17:13:12 UTC
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 8 Adam Price 2014-10-27 15:18:19 UTC
Created redmine issue http://projects.theforeman.org/issues/8116 from this bug

Comment 9 Adam Price 2014-10-27 15:43:05 UTC
https://github.com/Katello/katello/pull/4768

Comment 11 Bryan Kearney 2014-10-29 16:04:15 UTC
Moving to POST since upstream bug http://projects.theforeman.org/issues/8116 has been closed
-------------
Anonymous
Applied in changeset commit:katello|4345a25d4f81f200beacebac2b6d2ddff24ee24d.

Comment 12 jaudet 2014-10-29 16:42:48 UTC
Woo! I'll change this to VERIFIED if/when this shows up in QE's nightly Satellite installs.

Comment 18 jaudet 2015-03-16 20:28:04 UTC
Tested against Satellite-6.1.0-RHEL-7-20150311.1 and Satellite-6.1.0-RHEL-6-20150311.1.


Note You need to log in before you can comment on or make changes to this bug.