Bug 1130264 - [abrt][fix available] libreoffice-core-4.0.4.2-13.el6: Process /usr/lib64/libreoffice/program/soffice.bin was killed by signal 11 (SIGSEGV)
Summary: [abrt][fix available] libreoffice-core-4.0.4.2-13.el6: Process /usr/lib64/lib...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: libreoffice
Version: 6.6
Hardware: s390x
OS: Unspecified
medium
high
Target Milestone: rc
: ---
Assignee: Caolan McNamara
QA Contact: Desktop QE
URL:
Whiteboard: abrt_hash:92f53c3ef2c6909fd8491458802...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-14 17:29 UTC by Jiri Koten
Modified: 2014-10-14 04:50 UTC (History)
2 users (show)

Fixed In Version: libreoffice-4.0.4.2-14.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-10-14 04:50:05 UTC
Target Upstream Version:


Attachments (Terms of Use)
File: environ (3.05 KB, text/plain)
2014-08-14 17:29 UTC, Jiri Koten
no flags Details
File: last_occurrence (10 bytes, text/plain)
2014-08-14 17:29 UTC, Jiri Koten
no flags Details
File: event_log (189 bytes, text/plain)
2014-08-14 17:29 UTC, Jiri Koten
no flags Details
File: limits (1.29 KB, text/plain)
2014-08-14 17:29 UTC, Jiri Koten
no flags Details
File: backtrace (57.15 KB, text/plain)
2014-08-14 17:29 UTC, Jiri Koten
no flags Details
File: maps (61.46 KB, text/plain)
2014-08-14 17:29 UTC, Jiri Koten
no flags Details
File: dso_list (22.73 KB, text/plain)
2014-08-14 17:29 UTC, Jiri Koten
no flags Details
File: var_log_messages (541 bytes, text/plain)
2014-08-14 17:29 UTC, Jiri Koten
no flags Details
File: open_fds (799 bytes, text/plain)
2014-08-14 17:29 UTC, Jiri Koten
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1423 normal SHIPPED_LIVE libreoffice bug fix update 2014-10-14 01:28:46 UTC

Description Jiri Koten 2014-08-14 17:29:48 UTC
Description of problem:
Steps to Reproduce:
1. run ooimpress
2. create new presentation via wizard
3. select 'Title and 2 Content' layout
4. insert movie (wav sound in my case) via small icon in content window


Version-Release number of selected component:
libreoffice-core-4.0.4.2-13.el6

Additional info:
libreport version: 2.0.9
abrt_version:   2.0.8
backtrace_rating: 4
cmdline:        /usr/lib64/libreoffice/program/soffice.bin --impress --splash-pipe=6
crash_function: avmedia::gstreamer::pipeline_bus_callback
kernel:         2.6.32-494.el6.s390x

truncated backtrace:
:Thread no. 1 (10 frames)
: #0 avmedia::gstreamer::pipeline_bus_callback at /usr/src/debug/libreoffice-4.0.4.2/avmedia/source/gstreamer/gstplayer.cxx
: #1 gst_bus_source_dispatch at gstbus.c
: #5 g_main_context_iteration at gmain.c
: #6 GtkData::Yield at /usr/src/debug/libreoffice-4.0.4.2/vcl/unx/gtk/app/gtkdata.cxx
: #7 ImplYield at /usr/src/debug/libreoffice-4.0.4.2/vcl/source/app/svapp.cxx
: #8 Application::Yield at /usr/src/debug/libreoffice-4.0.4.2/vcl/source/app/svapp.cxx
: #9 Application::Execute at /usr/src/debug/libreoffice-4.0.4.2/vcl/source/app/svapp.cxx
: #10 desktop::Desktop::Main at /usr/src/debug/libreoffice-4.0.4.2/desktop/source/app/app.cxx
: #11 ImplSVMain at /usr/src/debug/libreoffice-4.0.4.2/vcl/source/app/svmain.cxx
: #12 SVMain at /usr/src/debug/libreoffice-4.0.4.2/vcl/source/app/svmain.cxx

Comment 1 Jiri Koten 2014-08-14 17:29:50 UTC
Created attachment 926863 [details]
File: environ

Comment 2 Jiri Koten 2014-08-14 17:29:50 UTC
Created attachment 926864 [details]
File: last_occurrence

Comment 3 Jiri Koten 2014-08-14 17:29:51 UTC
Created attachment 926865 [details]
File: event_log

Comment 4 Jiri Koten 2014-08-14 17:29:52 UTC
Created attachment 926866 [details]
File: limits

Comment 5 Jiri Koten 2014-08-14 17:29:53 UTC
Created attachment 926867 [details]
File: backtrace

Comment 6 Jiri Koten 2014-08-14 17:29:55 UTC
Created attachment 926868 [details]
File: maps

Comment 7 Jiri Koten 2014-08-14 17:29:56 UTC
Created attachment 926869 [details]
File: dso_list

Comment 8 Jiri Koten 2014-08-14 17:29:57 UTC
Created attachment 926870 [details]
File: var_log_messages

Comment 9 Jiri Koten 2014-08-14 17:29:58 UTC
Created attachment 926871 [details]
File: open_fds

Comment 11 Jiri Koten 2014-08-14 17:31:47 UTC
Not able to reproduce for 100%, but hit it several times during testing, only on s390x.

Comment 12 Caolan McNamara 2014-08-15 13:10:09 UTC
If it only happens on s390x, and only sometimes, that's going to be an exceptionally challenging bug to try and fix.

Comment 13 Caolan McNamara 2014-08-15 15:09:25 UTC
Its plausible that the callback was called sometime after the object referenced in the callback was destroyed, if so then this would fix it:

http://cgit.freedesktop.org/libreoffice/core/commit/?id=eb21b6827e25b2c943025a662cde2049c0454a6b

Comment 14 Caolan McNamara 2014-08-22 07:53:03 UTC
If libreoffice-4.0.4.2-14.el6 doesn't fix this, then if it is only on inserting video on s390x then I suggest we just punt this to the next release as that's a super obscure use case in reality

Comment 17 errata-xmlrpc 2014-10-14 04:50:05 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1423.html


Note You need to log in before you can comment on or make changes to this bug.