Bug 1130315 - Rubygem-Staypuft: After deploying HA neutron, neutron-openvswitch-agent reported failed. pcs resource cleanup <ID> removes it from the failed list.
Summary: Rubygem-Staypuft: After deploying HA neutron, neutron-openvswitch-agent repo...
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-foreman-installer
Version: unspecified
Hardware: x86_64
OS: Linux
high
high
Target Milestone: z1
: Installer
Assignee: John Eckersberg
QA Contact: Leonid Natapov
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-14 20:22 UTC by Alexander Chuzhoy
Modified: 2014-09-15 18:59 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-09-15 18:59:30 UTC


Attachments (Terms of Use)
openvswitch-agent log from one controller. (298.61 KB, text/x-log)
2014-08-14 20:25 UTC, Alexander Chuzhoy
no flags Details

Description Alexander Chuzhoy 2014-08-14 20:22:16 UTC
Rubygem-Staypuft:  After deploying HA neutron, neutron-openvswitch-agent reported failed. pcs resource cleanup <ID> removes it from the failed list.


Environment:
ruby193-rubygem-foreman_openstack_simplify-0.0.6-8.el6ost.noarch
openstack-foreman-installer-2.0.20-1.el6ost.noarch
rhel-osp-installer-0.1.10-2.el6ost.noarch
openstack-puppet-modules-2014.1-20.el6ost.noarch


Steps to reproduce:
1. Deploy HA neutron with Tenant Network Type=VXlan and ceph driver backend for both: glance and cinder.

2. Run pcs status on one controller.


Result:
Failed actions:
    neutron-openvswitch-agent_start_0 on mac047d7b61765c.example.com 'not running' (7): call=196, status=complete, last-rc-change='Thu Aug 14 18:55:23 2014', queued=4ms, exec=2001ms

Note: Runing pcs resource cleanup makes this entry disappear.

Expected result:
No failures.

Comment 1 Alexander Chuzhoy 2014-08-14 20:25:49 UTC
Created attachment 926902 [details]
openvswitch-agent log from one controller.

Comment 2 John Eckersberg 2014-08-14 20:32:44 UTC
I suspect this is another manifestation of the core rabbit messaging issues described in bug 1129242, but I'm not confident enough to mark it a dupe.

Comment 4 Mike Burns 2014-09-15 18:59:30 UTC
Based on Feedback from Eck, this is not reproducible.  Please reopen if you reproduce it.


Note You need to log in before you can comment on or make changes to this bug.