Bug 1130332 - Running liveinst in attempt to save the liveCD to disk didn't work, nor did the "install" option from the grub menu.
Summary: Running liveinst in attempt to save the liveCD to disk didn't work, nor did t...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: rhel-osp-installer LiveCD
Version: unspecified
Hardware: x86_64
OS: Linux
high
high
Target Milestone: z1
: Installer
Assignee: Robbie Harwood
QA Contact: Alexander Chuzhoy
URL:
Whiteboard:
: 1132412 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-14 22:21 UTC by Alexander Chuzhoy
Modified: 2014-10-01 13:26 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Known Issue
Doc Text:
Prior to this update, attempts to save the Red Hat Enterprise Linux OpenStack installer liveCD to disk without NetworkManager running would receive a traceback ending in "dbus.exceptions.DBusException: org.freedesktop.DBus.Error.ServiceUnknown: The name org.freedesktop.NetworkManager was not provided by any .service files". A workaround has been identified to address this issue: Boot using the "boot" menu item in grub (or take the default), then `sudo service NetworkManager start && sudo liveinst` Consequently, the Windowed installer will start as expected.
Clone Of:
Environment:
Last Closed: 2014-10-01 13:26:39 UTC


Attachments (Terms of Use)
warning that pops up during the run of liveinst (112.32 KB, image/png)
2014-08-19 14:16 UTC, Alexander Chuzhoy
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1350 normal SHIPPED_LIVE Red Hat Enterprise Linux OpenStack Platform Bug Fix Advisory 2014-10-01 17:22:34 UTC

Description Alexander Chuzhoy 2014-08-14 22:21:24 UTC
Rubygem-Staypuft:  Running liveinst in attempt to save the liveCD to disk doesn't work.


Environment: rhelosp-installer-live-6.5-20140814.1.iso


How to reproduce:
1. Boot from liveCD.
2. Run "liveinst"

Result:

bash-4.1$ liveinst                                                                                                                                                                                                  
umount: /media/cdtmp.TFANua: not mounted                                                                                                                                                                            
  No volume groups found                                                                                                                                                                                            
localuser:root being added to access control list                                                                                                                                                                   
22:13:00 Starting graphical installation.
Traceback (most recent call last):
  File "/usr/sbin/anaconda", line 1036, in <module>
    anaconda.id = instClass.installDataClass(anaconda, extraModules, opts.display_mode, anaconda.backend)
  File "/usr/lib/anaconda/instdata.py", line 324, in __init__
    self.reset()
  File "/usr/lib/anaconda/instdata.py", line 64, in reset
    self.network = network.Network()
  File "/usr/lib/anaconda/network.py", line 308, in __init__
    self.update()
  File "/usr/lib/anaconda/network.py", line 326, in update
    devhash = isys.getDeviceProperties(dev=None)
  File "/usr/lib/anaconda/isys.py", line 376, in getDeviceProperties
    nm = bus.get_object(NM_SERVICE, NM_MANAGER_PATH)
  File "/usr/lib/python2.6/site-packages/dbus/bus.py", line 244, in get_object
    follow_name_owner_changes=follow_name_owner_changes)
  File "/usr/lib/python2.6/site-packages/dbus/proxies.py", line 241, in __init__
    self._named_service = conn.activate_name_owner(bus_name)
  File "/usr/lib/python2.6/site-packages/dbus/bus.py", line 183, in activate_name_owner
    self.start_service_by_name(bus_name)
  File "/usr/lib/python2.6/site-packages/dbus/bus.py", line 281, in start_service_by_name
    'su', (bus_name, flags)))
  File "/usr/lib/python2.6/site-packages/dbus/connection.py", line 630, in call_blocking
    message, timeout)
dbus.exceptions.DBusException: org.freedesktop.DBus.Error.ServiceUnknown: The name org.freedesktop.NetworkManager was not provided by any .service files

Comment 1 Alexander Chuzhoy 2014-08-14 22:30:52 UTC
Also tried the "install" option from the grub menu. Attempted to boot from disk: was prompted that the disk isn't bootable.

Comment 4 Alexander Chuzhoy 2014-08-15 21:02:41 UTC
Tried - doesn't work.

Get a window with a "next" button. Clicking on "next" throws:

An error occured when attempting to load an installer interface component.
className =  KeyboardWindow

Comment 5 Robbie Harwood 2014-08-18 20:43:53 UTC
The installer error should be fixed in 20140818.3.

Comment 6 Alexander Chuzhoy 2014-08-19 14:15:38 UTC
Still doesn't work with rhelosp-installer-live-6.5-20140818.3.iso


The install option from the grub menu - didn't seem to do anything. Attempted to boot from the hard drive - but the HD wasn't bootable.

Running liveinst starts the installation. Then, during the "Copying live image to hard drive" a warning pops up:
"There was an error installing the bootloader. The system may not be bootable."


The system in fact gets stuck on attempt to boot from the hard drive.

Comment 7 Alexander Chuzhoy 2014-08-19 14:16:38 UTC
Created attachment 928386 [details]
warning that pops up during the run of liveinst

Comment 8 Robbie Harwood 2014-08-19 14:20:45 UTC
The option from the grub menu will not work until NetworkManager is running on boot as per the doc text.  I will look into the failure with liveinst.

Comment 9 Robbie Harwood 2014-08-19 16:32:45 UTC
I've run through the liveinst, and with 20140819.2 (new build) it now produces a bootable image with no warnings for me.

Comment 10 Robbie Harwood 2014-08-21 16:12:52 UTC
*** Bug 1132412 has been marked as a duplicate of this bug. ***

Comment 11 Alexander Chuzhoy 2014-08-27 17:35:37 UTC
version: rhelosp-installer-live-6.5-20140820.1.iso
Running "service NetworkManager start && liveinst" results in successful writing to disk. After that I was able to boot from the HD.

Comment 14 Alexander Chuzhoy 2014-09-15 18:31:04 UTC
Verified: rhelosp-installer-live-6.5-20140912.1.iso


As per the doc:
Must run "sudo service NetworkManager start" followed by "sudo liveinst". This will start a windowed installer. After completing the installer the image will be written to the HD.

Comment 16 errata-xmlrpc 2014-10-01 13:26:39 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1350.html


Note You need to log in before you can comment on or make changes to this bug.