Bug 1130356 - Some texts on the text console are not displayed normally after migration
Summary: Some texts on the text console are not displayed normally after migration
Keywords:
Status: CLOSED DUPLICATE of bug 1235732
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: qemu-kvm-rhev
Version: 7.1
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Dr. David Alan Gilbert
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-15 02:51 UTC by huiqingding
Modified: 2017-03-23 09:06 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-03-23 09:06:53 UTC


Attachments (Terms of Use)
screenshot before migration (11.90 KB, image/png)
2014-08-15 02:52 UTC, huiqingding
no flags Details
screenshot after migration (7.89 KB, image/png)
2014-08-15 02:53 UTC, huiqingding
no flags Details

Description huiqingding 2014-08-15 02:51:29 UTC
Description of problem:
boot a RHEL7.1 guest with text console, do migration, after migration, the text on text console cannot be displayed normally.

Version-Release number of selected component (if applicable):
src host:
qemu-kvm-rhev-2.1.0-1.el7.x86_64
kernel-3.10.0-143.el7.x86_64
dst host:
qemu-kvm-rhev-2.1.0-1.el7.x86_64
kernel-3.10.0-143.el7.x86_64

How reproducible:
100%

Steps to Reproduce:
1. boot a RHEL7.1 guest with text console on src host
# /usr/libexec/qemu-kvm -name virt-tests-vm1 -sandbox off -M pc -nodefaults -spice port=5901,password=redhat-vga,disable-ticketing -vga qxl -global qxl-vga.vram_size=33554432 -device intel-hda -device hda-duplex -chardev socket,id=qmp_id_qmpmonitor1,path=/tmp/monitor-qmpmonitor1-20140110-101500-bAb4rvXq,server,nowait -mon chardev=qmp_id_qmpmonitor1,mode=control -chardev socket,id=serial_id_serial0,path=/tmp/serial-serial0-20140110-101500-bAb4rvXq,server,nowait -device isa-serial,chardev=serial_id_serial0 -device virtio-serial-pci,id=virtio_serial_pci0 -chardev socket,id=devvs,path=/tmp/virtio_port-vs-20140110-101500-bAb4rvXq,server,nowait -device virtserialport,chardev=devvs,name=vs,id=vs,bus=virtio_serial_pci0.0 -chardev socket,id=seabioslog_id_20140110-101500-bAb4rvXq,path=/tmp/seabios-20140110-101500-bAb4rvXq,server,nowait -device isa-debugcon,chardev=seabioslog_id_20140110-101500-bAb4rvXq,iobase=0x402 -device nec-usb-xhci,id=usb1 -device virtio-scsi-pci,id=virtio_scsi_pci0 -drive id=drive_image1,if=none,cache=writethrough,snapshot=off,aio=native,file=/home/rhel7_1.qcow2 -device scsi-hd,id=image1,drive=drive_image1 -device virtio-net-pci,mac=9a:08:09:0a:0b:0c,id=idqiB5iJ,netdev=idlmunRA -netdev tap,id=idlmunRA,vhost=on,script=/etc/qemu-ifup -m 2048 -smp 2,maxcpus=2,cores=1,threads=1,sockets=2 -cpu SandyBridge -device usb-tablet,id=usb-tablet1,bus=usb1.0,port=1 -rtc base=utc,clock=host,driftfix=slew -boot order=cdn,once=d,menu=off -no-kvm-pit-reinjection -no-shutdown -enable-kvm -monitor stdio 

2. boot the guest on dst host:
# /usr/libexec/qemu-kvm -name virt-tests-vm1 -sandbox off -M pc -nodefaults -spice port=5901,password=redhat-vga,disable-ticketing -vga qxl -global qxl-vga.vram_size=33554432 -device intel-hda -device hda-duplex -chardev socket,id=qmp_id_qmpmonitor1,path=/tmp/monitor-qmpmonitor1-20140110-101500-bAb4rvXq,server,nowait -mon chardev=qmp_id_qmpmonitor1,mode=control -chardev socket,id=serial_id_serial0,path=/tmp/serial-serial0-20140110-101500-bAb4rvXq,server,nowait -device isa-serial,chardev=serial_id_serial0 -device virtio-serial-pci,id=virtio_serial_pci0 -chardev socket,id=devvs,path=/tmp/virtio_port-vs-20140110-101500-bAb4rvXq,server,nowait -device virtserialport,chardev=devvs,name=vs,id=vs,bus=virtio_serial_pci0.0 -chardev socket,id=seabioslog_id_20140110-101500-bAb4rvXq,path=/tmp/seabios-20140110-101500-bAb4rvXq,server,nowait -device isa-debugcon,chardev=seabioslog_id_20140110-101500-bAb4rvXq,iobase=0x402 -device nec-usb-xhci,id=usb1 -device virtio-scsi-pci,id=virtio_scsi_pci0 -drive id=drive_image1,if=none,cache=writethrough,snapshot=off,aio=native,file=/mnt/rhel7_1.qcow2 -device scsi-hd,id=image1,drive=drive_image1 -device virtio-net-pci,mac=9a:08:09:0a:0b:0c,id=idqiB5iJ,netdev=idlmunRA -netdev tap,id=idlmunRA,vhost=on,script=/etc/qemu-ifup -m 2048 -smp 2,maxcpus=2,cores=1,threads=1,sockets=2 -cpu SandyBridge -device usb-tablet,id=usb-tablet1,bus=usb1.0,port=1 -rtc base=utc,clock=host,driftfix=slew -boot order=cdn,once=d,menu=off -no-kvm-pit-reinjection -no-shutdown -enable-kvm -monitor stdio -incoming tcp:0:5800

3. do migration
(qemu) migrate -d tcp:10.66.9.152:5800

Actual results:
after migration, some texts on the console are not displayed normally, the screenshot before/after migration are as the attachment files.

Expected results:
after migration, the texts can be displayed normally.

Additional info:

Comment 1 huiqingding 2014-08-15 02:52:59 UTC
Created attachment 926960 [details]
screenshot before migration

Comment 2 huiqingding 2014-08-15 02:53:24 UTC
Created attachment 926961 [details]
screenshot after migration

Comment 3 huiqingding 2014-08-15 02:54:03 UTC
I also test qemu-kvm-rhev-2.1.0-3.el7ev.preview.x86_64, also hit this problem.

Comment 6 Dr. David Alan Gilbert 2015-08-07 15:54:48 UTC
Please retest on 7.2; I know there were some spice fixes that went in; not sure if they are enough to help.

Comment 7 huiqingding 2015-08-12 02:34:05 UTC
I test this issue using the following version, also hit this problem:

SRC host:
qemu-kvm-rhev-2.3.0-16.el7.x86_64
kernel-3.10.0-304.el7.x86_64
DST host:
qemu-kvm-rhev-2.3.0-16.el7.x86_64
kernel-3.10.0-304.el7.x86_64
Guest:
RHEL7.2
kernel-3.10.0-302.el7.x86_64

The commandline is same as comment #0:
/usr/libexec/qemu-kvm -name virt-tests-vm1 -sandbox off -M pc -nodefaults -spice port=5901,password=redhat-vga,disable-ticketing -vga qxl -global qxl-vga.vram_size=33554432 -device intel-hda -device hda-duplex -chardev socket,id=qmp_id_qmpmonitor1,path=/tmp/monitor-qmpmonitor1-20140110-101500-bAb4rvXq,server,nowait -mon chardev=qmp_id_qmpmonitor1,mode=control -chardev socket,id=serial_id_serial0,path=/tmp/serial-serial0-20140110-101500-bAb4rvXq,server,nowait -device isa-serial,chardev=serial_id_serial0 -device virtio-serial-pci,id=virtio_serial_pci0 -chardev socket,id=devvs,path=/tmp/virtio_port-vs-20140110-101500-bAb4rvXq,server,nowait -device virtserialport,chardev=devvs,name=vs,id=vs,bus=virtio_serial_pci0.0 -chardev socket,id=seabioslog_id_20140110-101500-bAb4rvXq,path=/tmp/seabios-20140110-101500-bAb4rvXq,server,nowait -device isa-debugcon,chardev=seabioslog_id_20140110-101500-bAb4rvXq,iobase=0x402 -device nec-usb-xhci,id=usb1 -device virtio-scsi-pci,id=virtio_scsi_pci0 -drive id=drive_image1,if=none,cache=writethrough,snapshot=off,aio=native,file=/mnt/rhel7.2.qcow2 -device scsi-hd,id=image1,drive=drive_image1 -device virtio-net-pci,mac=9a:08:09:0a:0b:0c,id=idqiB5iJ,netdev=idlmunRA -netdev tap,id=idlmunRA,vhost=on,script=/etc/qemu-ifup -m 2048 -smp 2,maxcpus=2,cores=1,threads=1,sockets=2 -cpu SandyBridge -device usb-tablet,id=usb-tablet1,bus=usb1.0,port=1 -rtc base=utc,clock=host,driftfix=slew -boot order=cdn,once=d,menu=off -no-kvm-pit-reinjection -no-shutdown -enable-kvm -monitor stdio

Comment 10 Dr. David Alan Gilbert 2017-03-21 17:13:18 UTC
Hi, please retest as per comment 9, but just using the current 7.3.z to see if it's the same as bz 1235732.

Comment 11 huiqingding 2017-03-23 01:26:41 UTC
(In reply to Dr. David Alan Gilbert from comment #10)
> Hi, please retest as per comment 9, but just using the current 7.3.z to see
> if it's the same as bz 1235732.

I use the command line and steps of comment #0 to test 7.3.z:
kernel-3.10.0-514.18.1.el7.x86_64
qemu-kvm-rhev-2.6.0-28.el7_3.8.x86_64

After migration, not hit this issue and the text is displayed normally.

Comment 12 Dr. David Alan Gilbert 2017-03-23 09:06:53 UTC
Based on comment 11 it seems fixed; the suspicion is that it was the same as bug 1235732

*** This bug has been marked as a duplicate of bug 1235732 ***


Note You need to log in before you can comment on or make changes to this bug.