Bug 1130357 - Battery applet doesn't appear to charge on Acer Aspire M5-581T
Summary: Battery applet doesn't appear to charge on Acer Aspire M5-581T
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 22
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-15 02:51 UTC by austinenglish
Modified: 2015-10-28 21:34 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-10-28 21:34:53 UTC


Attachments (Terms of Use)

Description austinenglish 2014-08-15 02:51:43 UTC
Description of problem:
I've had this bug as long as I've had the laptop, only recently realized that it wasn't reported :).

Assuming the battery is fully charged, I can power the laptop on, boot into Fedora, and the applet will show 100%. If I remove the AC cord, the applet will show the battery discharging, without issue. However, once I plug the cord back in, the applet will not show the battery as charging. Instead, it stays at whatever the last percentage it was when running on battery power.

For instance, right now the applet says:
System is running on battery power
Your battery is discharging (7%)
Estimated time left is 13 minutes

even though it's been charging for over 14 hours at this point. Rebooting the machine will show it as fully charged on next login, until unplugged again.

Version-Release number of selected component (if applicable):
Linux localhost.localdomain 3.16.0-1.fc22.x86_64 #1 SMP Mon Aug 4 10:01:23 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux

How reproducible:
Every time

Steps to Reproduce:
1. Power on fully charged laptop
2. Remove power cord, wait for battery percentage to decrease
3. Plugin power cord back in

Actual results:
Battery does not appear to charge

Expected results:
Battery applet shows the battery as charging/fully charged

Additional info:

Laptop is an Acer Aspire M5-581T - http://www.amazon.com/Acer-Aspire-NX-M2HAA-011-M5-581T-6024-15-6-Inch/dp/B00CU2JTOY

Comment 1 Jaroslav Reznik 2015-03-03 16:12:36 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 22 development cycle.
Changing version to '22'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora22

Comment 2 Justin M. Forbes 2015-10-20 19:29:06 UTC
*********** MASS BUG UPDATE **************

We apologize for the inconvenience.  There is a large number of bugs to go through and several of them have gone stale.  Due to this, we are doing a mass bug update across all of the Fedora 22 kernel bugs.

Fedora 22 has now been rebased to 4.2.3-200.fc22.  Please test this kernel update (or newer) and let us know if you issue has been resolved or if it is still present with the newer kernel.

If you have moved on to Fedora 23, and are still experiencing this issue, please change the version to Fedora 23.

If you experience different issues, please open a new bug report for those.

Comment 3 austinenglish 2015-10-28 21:34:53 UTC
Laptop is currently running 4.1.6, and this issue is fixed.


Note You need to log in before you can comment on or make changes to this bug.