Bug 1130360 - Launch a KVM with 232 virtio disks(multifunction=on) caused QEMU error(unable to map ioeventfd: -28)
Summary: Launch a KVM with 232 virtio disks(multifunction=on) caused QEMU error(unable...
Keywords:
Status: CLOSED DUPLICATE of bug 753692
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: qemu-kvm
Version: 6.5
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: rc
: ---
Assignee: Amos Kong
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-15 03:06 UTC by Sibiao Luo
Modified: 2015-05-25 00:08 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-15 12:39:37 UTC
Target Upstream Version:


Attachments (Terms of Use)
232-virtio-disks-multifunction=on.sh (41.22 KB, text/plain)
2014-08-15 03:08 UTC, Sibiao Luo
no flags Details

Description Sibiao Luo 2014-08-15 03:06:23 UTC
Description of problem:
This issue was fixed by akong in bug 753692 but still hit it with "unable to map ioeventfd: -28" error in rhel6.6 with the same testing.

Version-Release number of selected component (if applicable):
host info:
# uname -r && rpm -q qemu-kvm-rhev
2.6.32-496.el6.x86_64
qemu-kvm-rhev-0.12.1.2-2.437.el6.x86_64
guest info:
en_windows_server_2012_r2_x64.qcow2
virtio-win-prewhql-0.1-89

How reproducible:
100%

Steps to Reproduce:
1.Launch a KVM with 232 virtio disks(multifunction=on).
2.
3.

Actual results:
after step 1, guest boot up correctly, but qemu monitor output error message:
(qemu) qemu-kvm: virtio_pci_set_host_notifier_internal: unable to map ioeventfd: -28
qemu-kvm: virtio_pci_start_ioeventfd: failed. Fallback to a userspace (slower).
qemu-kvm: virtio_pci_set_host_notifier_internal: unable to map ioeventfd: -28
qemu-kvm: virtio_pci_start_ioeventfd: failed. Fallback to a userspace (slower).
qemu-kvm: virtio_pci_set_host_notifier_internal: unable to map ioeventfd: -28
qemu-kvm: virtio_pci_start_ioeventfd: failed. Fallback to a userspace (slower).
qemu-kvm: virtio_pci_set_host_notifier_internal: unable to map ioeventfd: -28
qemu-kvm: virtio_pci_start_ioeventfd: failed. Fallback to a userspace (slower).
qemu-kvm: virtio_pci_set_host_notifier_internal: unable to map ioeventfd: -28
qemu-kvm: virtio_pci_start_ioeventfd: failed. Fallback to a userspace (slower).
......

Expected results:
According to bug 753692#c15.
> Current error message:
qemu-kvm: virtio_pci_set_host_notifier_internal: unable to map ioeventfd: -28
qemu-kvm: virtio_pci_start_ioeventfd: failed. Fallback to a userspace (slower).

> Fixed error message:
qemu-kvm: virtio_pci_set_host_notifier_internal: unable to map ioeventfd: No space left on device
qemu-kvm: virtio_pci_start_ioeventfd: failed. Fallback to a userspace (slower).

Additional info:

Comment 1 Sibiao Luo 2014-08-15 03:08:30 UTC
Created attachment 926963 [details]
232-virtio-disks-multifunction=on.sh

Comment 2 Sibiao Luo 2014-08-15 03:09:00 UTC
# lscpu
Architecture:          x86_64
CPU op-mode(s):        32-bit, 64-bit
Byte Order:            Little Endian
CPU(s):                16
On-line CPU(s) list:   0-15
Thread(s) per core:    2
Core(s) per socket:    4
Socket(s):             2
NUMA node(s):          2
Vendor ID:             AuthenticAMD
CPU family:            21
Model:                 1
Stepping:              2
CPU MHz:               2999.950
BogoMIPS:              5999.11
Virtualization:        AMD-V
L1d cache:             16K
L1i cache:             64K
L2 cache:              2048K
L3 cache:              6144K
NUMA node0 CPU(s):     0-7
NUMA node1 CPU(s):     8-15

Comment 3 Amos Kong 2014-08-15 03:41:00 UTC
Hi Sibiao,

I only fixed bug 753692 in Upstream by changing the error message.
And we didn't backport the trivial patch to qemu-kvm-rhel6.

Do you think it's really necessary?

If not, please duplicate this bug with 753692.

Comment 4 Sibiao Luo 2014-08-15 03:54:57 UTC
(In reply to Amos Kong from comment #3)
> Hi Sibiao,
> 
> I only fixed bug 753692 in Upstream by changing the error message.
> And we didn't backport the trivial patch to qemu-kvm-rhel6.
> 
> Do you think it's really necessary?
> 
> If not, please duplicate this bug with 753692.

I think you could help backport it as we have such test plan/case for scalability feature.

Best Regards,
sluo

Comment 5 Amos Kong 2014-08-15 12:39:37 UTC
(In reply to Sibiao Luo from comment #4)
> (In reply to Amos Kong from comment #3)
> > Hi Sibiao,
> > 
> > I only fixed bug 753692 in Upstream by changing the error message.
> > And we didn't backport the trivial patch to qemu-kvm-rhel6.
> > 
> > Do you think it's really necessary?
> > 
> > If not, please duplicate this bug with 753692.
> 
> I think you could help backport it as we have such test plan/case for
> scalability feature.

It's not a good reason, please update the testplan.

> Best Regards,
> sluo

*** This bug has been marked as a duplicate of bug 753692 ***


Note You need to log in before you can comment on or make changes to this bug.