Bug 1130388 - View Buildlog button retries build
Summary: View Buildlog button retries build
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: lpf
Version: 20
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Alec Leamas
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-15 06:05 UTC by Robin Green
Modified: 2014-10-29 11:02 UTC (History)
1 user (show)

Fixed In Version: lpf-0.1-8.36e5aa0.fc20
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-10-29 11:02:32 UTC


Attachments (Terms of Use)

Description Robin Green 2014-08-15 06:05:32 UTC
Description of problem:
I was trying to install Spotify using lpf and it failed. However, when I clicked the "View buildlog" button, the build log was not displayed.

Version-Release number of selected component (if applicable):
lpf-0.1-6.36e5aa0.fc20.noarch

How reproducible:
Always

Steps to Reproduce:
1. lpf update
2. If necessary, add user to group, logout, log in again and run lpf update again
3. Choose spotify
4. Dialog box appears saying "The package couldn't be built and installed". Click the View Buildlog button in that dialog box.

Actual results:
It seems to retry, and then the same error dialog pops up again.

Expected results:
Either the build should succeed, or if it doesn't, the view buildlog button should open a new window containing the build log.

Additional info:
I installed the KDE spin of Fedora.

In the terminal window from which I ran lpf update, the following appears:
spotify-client: installing build dependencies

Comment 1 Fedora Update System 2014-08-30 08:21:05 UTC
lpf-0.1-8.36e5aa0.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/lpf-0.1-8.36e5aa0.fc20

Comment 2 Alec Leamas 2014-08-30 08:27:04 UTC
Sorry, but this update has no fix for this proble... please stay tuned.

Comment 3 Fedora Update System 2014-09-02 06:47:20 UTC
Package lpf-0.1-8.36e5aa0.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing lpf-0.1-8.36e5aa0.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-10101/lpf-0.1-8.36e5aa0.fc20
then log in and leave karma (feedback).

Comment 4 Fedora Update System 2014-10-29 11:02:32 UTC
lpf-0.1-8.36e5aa0.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.