Bug 1130402 - rhc-list-ports can not work on INT
Summary: rhc-list-ports can not work on INT
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: OpenShift Online
Classification: Red Hat
Component: Containers
Version: 2.x
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: ---
Assignee: Jhon Honce
QA Contact: libra bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-15 06:56 UTC by chunchen
Modified: 2016-09-30 02:15 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-15 17:01:44 UTC


Attachments (Terms of Use)

Description chunchen 2014-08-15 06:56:45 UTC
Description of problem:
rhc-list-ports can not work on INT

Version-Release number of selected component (if applicable):
INT(devenv_5079)

How reproducible:
always

Steps to Reproduce:
1. Create an app with DB cartridge

2. SSH into the app and run rhc-list-ports

Actual results:
[1] For non-scaled app with DB cartridge:
declare -A BASH_ALIASES='()' 
declare -A BASH_CMDS='()'  
/usr/bin/rhc-list-ports: line 28: 127.2.179.2:27017: syntax error: invalid arithmetic operator (error token is ".2.179.2:27017")

[2] For scaled app with DB cartridge:
declare -A BASH_ALIASES='()' 
declare -A BASH_CMDS='()'
/usr/bin/rhc-list-ports: line 28: 53ed7fc76cec0e26dd0006de: value too great for base (error token is "53ed7fc76cec0e26dd0006de")

Expected results:
rhc-list-ports should work well.

Additional info:

Comment 1 Jhon Honce 2014-08-15 17:01:44 UTC
I cannot reproduce the issue.  

1> rhc create-app perl002 perl-5.10 mysql-5.1 --no-git
1> ssh <url>
1> rhc-list-ports
httpd -> 127.3.92.129:8080
mysql -> 127.3.92.130:3306-> 127.2.59.2:3306


2> rhc create-app perl003 perl-5.10 mysql-5.1 --no-git -s
2> ssh <url>
2> rhc-list-ports
haproxy -> 127.7.54.2:8080
haproxy -> 127.7.54.3:8080
httpd -> 127.7.54.1:8080
mysql -> 53ee3ba403ef64e79800106e-honceint.int.rhcloud.com:38441

Comment 2 chunchen 2014-08-18 01:57:25 UTC
Checked on INT(devenv_5083), it works for now, please refer to the following results:

1) rhc create-app cperl perl-5.10 mysql-5.1 --no-git
1) ssh <url>
1) rhc-list-ports
httpd -> 127.10.62.1:8080
mysql -> 127.10.62.2:3306


2) rhc create-app perls perl-5.10 mysql-5.1 --no-git -s
2) ssh <url>
2) rhc-list-ports
haproxy -> 127.5.114.2:8080
haproxy -> 127.5.114.3:8080
httpd -> 127.5.114.1:8080
mysql -> 53f15b2203ef644a2d002bee-ctest.int.rhcloud.com:39326


Note You need to log in before you can comment on or make changes to this bug.