Bug 113042 - [PATCH] RHEL3 ia64 Update 2: compat ioctl support
[PATCH] RHEL3 ia64 Update 2: compat ioctl support
Status: CLOSED DUPLICATE of bug 115337
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel (Show other bugs)
ia64 Linux
high Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
Depends On:
  Show dependency treegraph
Reported: 2004-01-07 14:12 EST by Arun Sharma
Modified: 2007-11-30 17:07 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-02-21 14:00:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
el3-ioctl.patch (124.91 KB, patch)
2004-01-07 14:14 EST, Arun Sharma
no flags Details | Diff

  None (edit)
Description Arun Sharma 2004-01-07 14:12:06 EST
Description of problem:

RHEL3 ia64 doesn't support or incorrectly supports many ioctls for 32
bit applications.

Version-Release number of selected component (if applicable):


How reproducible:

Try to execute ioctls such as: SIOCGIFCONF
Comment 1 Arun Sharma 2004-01-07 14:14:18 EST
Created attachment 96809 [details]

Attached is a largely unmodified backport of the compat ioctl from linux-2.6.
Comment 2 sheryl sage 2004-01-08 17:38:14 EST
VERITAS Software Additional Comment, Sheryl Sage Partner Operations
VERITAS is porting Foundation Suite and Cluster Server (vxfs, vxvm 
and vcs) to Itanium on behalf of several customers, including 
Morgan.  Morgan is eager to move to Itanium with the VERITAS Online 
Product Stack and VERITAS has committed to providing this by April 
2004, ASSUMING that 32-bit emulation is supported 'native emulation' 
works so that the utilities /user level applications do not have to 
be ported to 64-bit.  The ioctls that are fixed in this patch 
submitted by Intel, were found to be show stoppers to VERITAS.  This 
patch will enable VERITAS to continue to move forward with porting to 
Itanium and meet our joint customer's requirements.  
Comment 3 Larry Troan 2004-01-12 09:24:20 EST
Arun, is there an Issue Tracker open on this?
Comment 4 Larry Troan 2004-01-19 09:19:52 EST
Issue Tracker 31438 opened as sev 2
Comment 6 Robert Perkins 2004-02-12 17:44:39 EST
Closing because this has become a RHEL3 U3 feature.

*** This bug has been marked as a duplicate of 115337 ***
Comment 7 Red Hat Bugzilla 2006-02-21 14:00:37 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.