Bug 1130435 - Setting a same scale info on a cartridge makes connection hooks being run
Summary: Setting a same scale info on a cartridge makes connection hooks being run
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: OpenShift Online
Classification: Red Hat
Component: Pod
Version: 2.x
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: ---
: ---
Assignee: Abhishek Gupta
QA Contact: libra bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-15 08:41 UTC by Jianwei Hou
Modified: 2015-05-15 00:29 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-02-18 16:50:39 UTC


Attachments (Terms of Use)

Description Jianwei Hou 2014-08-15 08:41:15 UTC
Description of problem:
This is a regression of https://bugzilla.redhat.com/show_bug.cgi?id=969876
Setting same scale value on a 3rd party cartridge makes the connection hook being run, this should not happen if the scale value does not change.

Version-Release number of selected component (if applicable):
On devenv_5079

How reproducible:
Always

Steps to Reproduce:
1. rhc create-app foo php-5.3 -s
2. rhc add-cartridge "http://cartreflect-claytondev.rhcloud.com/reflect?github=smarterclayton/openshift-redis-cart&commit=6dca180bb06412a261d7211d9d8fe1211afe32d8" -a foo
3. rhc cartridge-scale redis -a foo --min 2
4. ssh into broker, monitor the broker log
tailf /var/www/openshift/broker/development.log
5. rhc cartridge-scale redis -a foo --min 2

Actual results:
After step 5, the 'ExecuteConnectionsOp' showed up in pending_op_group and the publisher hook showed up in development.log

Expected results:
The hook should not be executed because the setting a same value to cartridge scale info a second time is considered a no-op.

Additional info:

Comment 1 Abhishek Gupta 2014-09-22 21:40:04 UTC
https://github.com/openshift/origin-server/pull/5831

Comment 2 Jianwei Hou 2014-09-23 03:16:18 UTC
Verified on devenv_5183
The publisher hook is not triggered on the second time setting a same scale value to a cartridge.


Note You need to log in before you can comment on or make changes to this bug.