Bug 1130437 - wrong alphabetical order of keyboard layouts
Summary: wrong alphabetical order of keyboard layouts
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: anaconda
Version: 7.0
Hardware: x86_64
OS: Linux
unspecified
low
Target Milestone: rc
: ---
Assignee: David Shea
QA Contact: Release Test Team
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-15 08:43 UTC by Marcel Kolaja
Modified: 2015-11-19 09:47 UTC (History)
2 users (show)

Fixed In Version: anaconda-21.48.22.1-1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-11-19 09:47:29 UTC


Attachments (Terms of Use)
screenshot of the problem (136.07 KB, image/png)
2015-01-07 14:42 UTC, Karel Volný
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:2284 normal SHIPPED_LIVE anaconda bug fix and enhancement update 2015-11-19 09:44:49 UTC

Description Marcel Kolaja 2014-08-15 08:43:20 UTC
Description of problem:
Keyboard layouts are sorted in a wrong order. Layouts starting with an accent are at the end of the list. However, when Czech language is chosen for the installation, layouts starting with Č for instance, like Čeština, should be place right after C, not after Z.

Version-Release number of selected component (if applicable):
RHEL-7.0-20140507.0-Server-x86_64-boot.iso

How reproducible:
always

Steps to Reproduce:
1. start the installation
2. select Czech language for the installation
3. look for available keyboard layouts

Actual results:
keyboard layouts are incorrectly sorted

Expected results:
keyboard layouts are correctly sorted

Additional info:
N/A

Comment 2 David Shea 2014-10-30 18:54:39 UTC
Fixed in upstream commit b3dd7e37

Comment 3 Karel Volný 2015-01-07 14:42:19 UTC
Created attachment 977332 [details]
screenshot of the problem

(In reply to David Shea from comment #2)
> Fixed in upstream commit b3dd7e37

I'm a bit confused, the comment is from 2014-10-30 but it didn't get included into 7.1?

- I've just hit the problem with RHEL-7.1-20150107.n.0-Workstation-x86_64-boot.iso

Comment 8 errata-xmlrpc 2015-11-19 09:47:29 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2284.html


Note You need to log in before you can comment on or make changes to this bug.