Bug 113044 - yum crashes with "ValueError: unpack list of wrong size" during "yum upgrade" using redhat.com repository
yum crashes with "ValueError: unpack list of wrong size" during "yum upgrade"...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-01-07 14:23 EST by Jeff MacDonald
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-01-25 22:31:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
yum.conf file from quark (1.24 KB, text/plain)
2004-01-17 12:06 EST, Jeff MacDonald
no flags Details

  None (edit)
Description Jeff MacDonald 2004-01-07 14:23:43 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1)
Gecko/20031114

Description of problem:
I logged in as root to do a 'yum upgrade', and I get the following
traceback:

Gathering header information file(s) from server(s)
Server: Fedora Core 1 - i386 - Base
Traceback (most recent call last):
  File "/usr/bin/yum", line 60, in ?
    yummain.main(sys.argv[1:])
  File "yummain.py", line 188, in main
  File "clientStuff.py", line 766, in get_package_info_from_servers
  File "clientStuff.py", line 103, in HeaderInfoNevralLoad
ValueError: unpack list of wrong size


Version-Release number of selected component (if applicable):
2.0.4-2

How reproducible:
Always

Steps to Reproduce:
1. run 'yum upgrade'
2. wait
3. ka-boom
    

Actual Results:  traceback from python with a ValueError, as noted in
description.


Expected Results:  expected some sort of timeout error, and move on to
next mirror in list.


Additional info:

this problem appears to be triggered while getting headers from the
redhat.com repo. yum crashed before it moved to the mirrors I have
configured /etc/yum.conf with. in my testing, I ran 'yum upgrade' a
2nd time to try to duplicate the problem, and it crashed with the same
traceback after a couple of minutes delay.
Comment 1 Jeff MacDonald 2004-01-07 14:31:55 EST
this appears to be a problem with the redhat.com repo. when I
commented out the appropriate lines in /etc/yum.conf, the upgrade
command runs just fine.
Comment 2 Jeff MacDonald 2004-01-14 18:58:52 EST
I now get this same error when using the 'muohio.edu' repo when using
the 'check-update' command. the 'base' seems to be fine, but the
'updates' is what crashes. same line/function as with the redhat.com repo.



Comment 3 Jeff MacDonald 2004-01-17 12:06:27 EST
Created attachment 97073 [details]
yum.conf file from quark
Comment 4 Theodore C. Belding 2004-01-22 14:21:39 EST
I was also getting this error, using the redhat repository as well as
various mirrors. But the config file from
http://fedora.artoo.net/faq/samples/yum.conf
seems to work fine. See also
http://www.redhat.com/archives/fedora-list/2004-January/msg03379.html
(although the section about adding multiple "baseurl=" statements for
a single repository seems incorrect -- see the yum.conf man page).
Comment 5 Jeff Johnson 2004-01-25 22:31:44 EST
This problem appears to be transient, i.e. network and/or server
related, not the yum client.

Note You need to log in before you can comment on or make changes to this bug.