Bug 1130441 - Failed to start domain with a 'server' type interface
Summary: Failed to start domain with a 'server' type interface
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: libvirt
Version: 6.6
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: rc
: ---
Assignee: Ján Tomko
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-15 08:51 UTC by hongming
Modified: 2015-01-20 12:22 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-01-20 12:22:50 UTC


Attachments (Terms of Use)

Description hongming 2014-08-15 08:51:53 UTC
Description of problem:
Failed to start domain with a tcp type interface , the following error 
occurs
error: Failed to start domain rhel6.5
error: internal error Process exited while reading console log output: char device redirected to /dev/pts/4
2014-08-15T08:49:43.256335Z qemu-kvm: -device rtl8139,netdev=hostnet0,id=net0,mac=52:54:00:31:d9:af,bus=pci.0,addr=0x3: Property 'rtl8139.netdev' can't find value 'hostnet0'

Version-Release number of selected component (if applicable):
libvirt-0.10.2-43.el6.x86_64
qemu-kvm-0.12.1.2-2.427.el6.x86_64

How reproducible:
100%

Steps to Reproduce:

# virsh dumpxml rhel6.5|grep interface -A3
    <interface type='server'>
      <source address='127.0.0.1' port='5558'/>
    </interface>

# virsh start rhel6.5
error: Failed to start domain rhel6.5
error: internal error Process exited while reading console log output: char device redirected to /dev/pts/4
2014-08-15T08:49:43.256335Z qemu-kvm: -device rtl8139,netdev=hostnet0,id=net0,mac=52:54:00:31:d9:af,bus=pci.0,addr=0x3: Property 'rtl8139.netdev' can't find value 'hostnet0'


Actual results:
Failed to start domain with a tcp type interface 

Expected results:
Successfully start the domain 

Additional info:
It works fine in rhel7.From the qemu-kvm manual , it should be supported in rhel6.

man qemu-kvm
......
       -net socket[,vlan=n][,name=name][,fd=h][,listen=[host]:port][,connect=host:port]
        Connect the VLAN n to a remote VLAN in another QEMU virtual machine using a TCP socket connection. If listen is specified, QEMU waits for incoming
connections on port (host is optional). connect is used to connect to another QEMU instance using the listen option. fd=h specifies an already opened TCP socket.

           Example:

                   # launch a first QEMU instance
                   qemu linux.img -net nic,macaddr=52:54:00:12:34:56 \
                   -net socket,listen=:1234
                   # connect the VLAN 0 of this instance to the VLAN 0
                   # of the first instance
                   qemu linux.img -net nic,macaddr=52:54:00:12:34:57 \
                   -net socket,connect=127.0.0.1:1234

Comment 2 Ján Tomko 2015-01-20 12:22:50 UTC
Although -netdev socket is not backported to RHEL6 and only works via -net, libvirt has been formatting it as -netdev at least since RHEL-6.2.

Works upstream and on RHEL-7, closing as WONTFIX.


Note You need to log in before you can comment on or make changes to this bug.