Bug 1130462 - glusterd fails to get the inode size for a brick
Summary: glusterd fails to get the inode size for a brick
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: glusterd
Version: mainline
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: ---
Assignee: Niels de Vos
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 1254421
TreeView+ depends on / blocked
 
Reported: 2014-08-15 10:01 UTC by Niels de Vos
Modified: 2015-08-18 05:29 UTC (History)
1 user (show)

Fixed In Version: glusterfs-3.7.0
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1254421 (view as bug list)
Environment:
Last Closed: 2015-05-14 17:27:09 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Niels de Vos 2014-08-15 10:01:07 UTC
Description of problem:
It seems that the inode size of a brick is never set correctly. The command

   # gluster volume status $PATH_TO_BRICK detail

always fails and sets the "inode size" to N/A.

Version-Release number of selected component (if applicable):
any?

How reproducible:
100%

Steps to Reproduce:
1. gluster volume status $PATH_TO_BRICK detail

Actual results:

Status of volume: bug-1081016
------------------------------------------------------------------------------
Brick                : Brick vm130-111.example.com:/bricks/bug-1081016/data
Port                 : 49152               
Online               : Y                   
Pid                  : 24647               
File System          : xfs                 
Device               : /dev/mapper/vg_bricks-bug--1081016
Mount Options        : rw                  
Inode Size           : N/A                 
Disk Space Free      : 481.5MB             
Total Disk Space     : 507.3MB             
Inode Count          : 524288              
Free Inodes          : 524275 

Expected results:

Status of volume: bug-1081016
------------------------------------------------------------------------------
Brick                : Brick vm130-111.example.com:/bricks/bug-1081016/data
Port                 : 49152               
Online               : Y                   
Pid                  : 24647               
File System          : xfs                 
Device               : /dev/mapper/vg_bricks-bug--1081016
Mount Options        : rw                  
Inode Size           : 256                 
Disk Space Free      : 481.5MB             
Total Disk Space     : 507.3MB             
Inode Count          : 524288              
Free Inodes          : 524275 

Additional info:

Comment 1 Anand Avati 2014-08-15 10:14:33 UTC
REVIEW: http://review.gluster.org/8492 (glusterd: really get the inode size for a brick) posted (#1) for review on master by Niels de Vos (ndevos@redhat.com)

Comment 2 Anand Avati 2014-10-28 05:48:32 UTC
COMMIT: http://review.gluster.org/8492 committed in master by Krishnan Parthasarathi (kparthas@redhat.com) 
------
commit b2ae71dbcf1b932abc16f096eee74d50aa823b04
Author: Niels de Vos <ndevos@redhat.com>
Date:   Fri Aug 15 11:13:46 2014 +0200

    glusterd: really get the inode size for a brick
    
    The device to get the inode size from does not get passed to the tool
    (tune2fs, xfs_info or the like) that is called. This is probably just an
    oversight. While correcting this, cleanup some bits of the function too.
    
    Change-Id: Ida45852cba061631fb304bc7dd5286df1a808010
    BUG: 1130462
    Signed-off-by: Niels de Vos <ndevos@redhat.com>
    Reviewed-on: http://review.gluster.org/8492
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Kaleb KEITHLEY <kkeithle@redhat.com>
    Reviewed-by: Krishnan Parthasarathi <kparthas@redhat.com>
    Tested-by: Krishnan Parthasarathi <kparthas@redhat.com>

Comment 3 Niels de Vos 2015-05-14 17:27:09 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Comment 4 Niels de Vos 2015-05-14 17:35:32 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Comment 5 Niels de Vos 2015-05-14 17:37:54 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Comment 6 Niels de Vos 2015-05-14 17:43:18 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.