Bug 1130465 - IE9: Designer is not fully loaded
Summary: IE9: Designer is not fully loaded
Keywords:
Status: CLOSED DEFERRED
Alias: None
Product: JBoss BPMS Platform 6
Classification: Retired
Component: jBPM Designer
Version: 6.0.2
Hardware: Unspecified
OS: Unspecified
high
urgent
Target Milestone: ER4
: 6.2.0
Assignee: Jeremy Lindop
QA Contact: Kirill Gaevskii
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-15 10:07 UTC by Sona Mala
Modified: 2015-10-15 14:15 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-10-15 14:15:01 UTC
Type: Bug


Attachments (Terms of Use)

Description Sona Mala 2014-08-15 10:07:00 UTC
Description of problem:
I tried jBPM Designer with IE9 and it was not loaded. I was waiting for 5 minutes without any results.

When I tried different browsers (Chrome, Firefox) with same instance of BPMS then the designer works without problems.


Version-Release number of selected component (if applicable):
6.0.2 GA BPMS and 6.1.0 SNAPSHOT BPMS


How reproducible:
every time when you open any process from repository in IE9. It seems that IE10 and IE 11 works.

Actual results:
Designer is gray, loading dialog and partially loaded toolbar are present. 


Expected results:
Fully loaded Designer.


Additional info:
Please, add commits for both product's versions (6.0.2 and 6.1.x).

Comment 3 Tihomir Surdilovic 2014-09-17 16:53:54 UTC
could you please attach any JS errors in the js error console? this would really help with making sure we are fixing the same things. thanks

Comment 4 Sona Mala 2014-09-18 07:45:59 UTC
Hi Tiho,
error from console is:

SCRIPT438: Object doesn't support property or method 'createContextualFragment'
ext-all.js, line 9 character 3354


Path to this js file is:
business-central.war/org.kie.workbench.KIEWebapp/lib/ext-2.0.2/ext-all.js

Comment 5 Kris Verlaenen 2015-02-06 12:52:23 UTC
No longer possible for 6.1, moving to 6.2

Comment 6 Jeremy Lindop 2015-02-24 16:35:05 UTC
I couldn't reproduce the console error reported by smala in Comment 4, but based on this, I found a solution to the incomplete loading of designer in IE9.

master:
https://github.com/droolsjbpm/jbpm-designer/commit/2c6c15ce8f2e1cea59bfe9309f40476d92150dc7

IE9 is not yet fully functional in IE9 - the ShapeRepository (left hand panel) does not allow the user to add tasks to a BP.

Comment 7 Jeremy Lindop 2015-09-24 14:12:08 UTC
Problem was caused by window.btoa and window.atob functions not being supported in IE versions <= IE9. Fixed by using our own implementation for these IE versions.

This fixes the problem using ShapeRepository and Saving BP's in IE9

6.3.x
https://github.com/droolsjbpm/jbpm-designer/commit/01d304745db29b8917db4b381fc58553f8ae2bc0
master
https://github.com/droolsjbpm/jbpm-designer/commit/318616d834c0fead86211e9456bbbafa46e729a9

Comment 8 Lukáš Petrovický 2015-10-15 14:15:01 UTC
We no longer support IE9, this will not be verified.


Note You need to log in before you can comment on or make changes to this bug.