Bug 1130482 - open-vm-tools cannot shutdown Virtual Machine
Summary: open-vm-tools cannot shutdown Virtual Machine
Keywords:
Status: CLOSED DUPLICATE of bug 1090695
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: open-vm-tools
Version: 7.0
Hardware: All
OS: Linux
unspecified
high
Target Milestone: rc
: ---
Assignee: Richard W.M. Jones
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On: 1077320 1090695
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-15 10:50 UTC by Jason Friedrich
Modified: 2014-08-18 08:37 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-18 08:37:28 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
CentOS 0007504 None None None Never

Description Jason Friedrich 2014-08-15 10:50:42 UTC
Description of problem:

It is not possible to shut down ("shut down guest OS") a VM in VMware vSphere 5.5 even though open-vm-tools are installed. When the command is issued, VMware will return "A general system error occurred: Invalid fault" error message and then do nothing.

How reproducible:

* Install CentOS (minimal install)
* Install open-vm-tools
* Try to restart VM from ESXi / vCenter UI ("shut down guest OS")

Actual results:

When the command is issued, VMware will return "A general system error occurred: Invalid fault" error message and then do nothing.

Expected results:

VMware should shut down the VM. 

Additional info:

It looks like open-vm-tools try to use 'ifconfig' which is deprecated and not shipped by default anymore: 

[root@foobar vmware-tools]# ./poweroff-vm-default 
Fri Aug 15 02:23:41 CEST 2014 : Executing './poweroff-vm-default'
Fri Aug 15 02:23:41 CEST 2014 : Executing './scripts/vmware/network'
Aug 15 02:23:41 network: ifconfig not in search path.

After the net-tools package is installed, everything works as expected. The packages open-vm-tools requires new scripts which do not rely on the 'ifconfig' tool.

Comment 2 Richard W.M. Jones 2014-08-15 10:57:45 UTC
This was fixed in Fedora (bug 1077320).

Ravindra - are we going to rebase open-vm-tools?  I can't find the rebase
bug right now.

Comment 3 Ravindra Kumar 2014-08-15 17:36:35 UTC
Richard, rebase will not solve it because dependency is still there. Immediate solution to this dependency was reported under bug 1090695.

Comment 4 Richard W.M. Jones 2014-08-15 18:01:16 UTC
(In reply to Ravindra Kumar from comment #3)
> Richard, rebase will not solve it because dependency is still there.
> Immediate solution to this dependency was reported under bug 1090695.

Ah OK, that was the bug I was looking for.


Note You need to log in before you can comment on or make changes to this bug.