Note: This bug is displayed in read-only format because
the product is no longer active in Red Hat Bugzilla.
RHEL Engineering is moving the tracking of its product development work on RHEL 6 through RHEL 9 to Red Hat Jira (issues.redhat.com). If you're a Red Hat customer, please continue to file support cases via the Red Hat customer portal. If you're not, please head to the "RHEL project" in Red Hat Jira and file new tickets here. Individual Bugzilla bugs in the statuses "NEW", "ASSIGNED", and "POST" are being migrated throughout September 2023. Bugs of Red Hat partners with an assigned Engineering Partner Manager (EPM) are migrated in late September as per pre-agreed dates. Bugs against components "kernel", "kernel-rt", and "kpatch" are only migrated if still in "NEW" or "ASSIGNED". If you cannot log in to RH Jira, please consult article #7032570. That failing, please send an e-mail to the RH Jira admins at rh-issues@redhat.com to troubleshoot your issue as a user management inquiry. The email creates a ServiceNow ticket with Red Hat. Individual Bugzilla bugs that are migrated will be moved to status "CLOSED", resolution "MIGRATED", and set with "MigratedToJIRA" in "Keywords". The link to the successor Jira issue will be found under "Links", have a little "two-footprint" icon next to it, and direct you to the "RHEL project" in Red Hat Jira (issue links are of type "https://issues.redhat.com/browse/RHEL-XXXX", where "X" is a digit). This same link will be available in a blue banner at the top of the page informing you that that bug has been migrated.
DescriptionJason Friedrich
2014-08-15 10:50:42 UTC
Description of problem:
It is not possible to shut down ("shut down guest OS") a VM in VMware vSphere 5.5 even though open-vm-tools are installed. When the command is issued, VMware will return "A general system error occurred: Invalid fault" error message and then do nothing.
How reproducible:
* Install CentOS (minimal install)
* Install open-vm-tools
* Try to restart VM from ESXi / vCenter UI ("shut down guest OS")
Actual results:
When the command is issued, VMware will return "A general system error occurred: Invalid fault" error message and then do nothing.
Expected results:
VMware should shut down the VM.
Additional info:
It looks like open-vm-tools try to use 'ifconfig' which is deprecated and not shipped by default anymore:
[root@foobar vmware-tools]# ./poweroff-vm-default
Fri Aug 15 02:23:41 CEST 2014 : Executing './poweroff-vm-default'
Fri Aug 15 02:23:41 CEST 2014 : Executing './scripts/vmware/network'
Aug 15 02:23:41 network: ifconfig not in search path.
After the net-tools package is installed, everything works as expected. The packages open-vm-tools requires new scripts which do not rely on the 'ifconfig' tool.
Comment 2Richard W.M. Jones
2014-08-15 10:57:45 UTC
This was fixed in Fedora (bug 1077320).
Ravindra - are we going to rebase open-vm-tools? I can't find the rebase
bug right now.
Richard, rebase will not solve it because dependency is still there. Immediate solution to this dependency was reported under bug 1090695.
Comment 4Richard W.M. Jones
2014-08-15 18:01:16 UTC
(In reply to Ravindra Kumar from comment #3)
> Richard, rebase will not solve it because dependency is still there.
> Immediate solution to this dependency was reported under bug 1090695.
Ah OK, that was the bug I was looking for.
Description of problem: It is not possible to shut down ("shut down guest OS") a VM in VMware vSphere 5.5 even though open-vm-tools are installed. When the command is issued, VMware will return "A general system error occurred: Invalid fault" error message and then do nothing. How reproducible: * Install CentOS (minimal install) * Install open-vm-tools * Try to restart VM from ESXi / vCenter UI ("shut down guest OS") Actual results: When the command is issued, VMware will return "A general system error occurred: Invalid fault" error message and then do nothing. Expected results: VMware should shut down the VM. Additional info: It looks like open-vm-tools try to use 'ifconfig' which is deprecated and not shipped by default anymore: [root@foobar vmware-tools]# ./poweroff-vm-default Fri Aug 15 02:23:41 CEST 2014 : Executing './poweroff-vm-default' Fri Aug 15 02:23:41 CEST 2014 : Executing './scripts/vmware/network' Aug 15 02:23:41 network: ifconfig not in search path. After the net-tools package is installed, everything works as expected. The packages open-vm-tools requires new scripts which do not rely on the 'ifconfig' tool.