Bug 1130502 - search domains are not tried out for name resolution with dnssec-trigger
Summary: search domains are not tried out for name resolution with dnssec-trigger
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: dnssec-trigger
Version: 21
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Pavel Šimerda (pavlix)
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1132233 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-15 12:49 UTC by Tomáš Hozza 🤓
Modified: 2015-04-21 18:48 UTC (History)
7 users (show)

Fixed In Version: dnssec-trigger-0.12-20.fc22
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-03-26 22:04:22 UTC


Attachments (Terms of Use)
patch (1.91 KB, patch)
2015-01-22 10:21 UTC, Pavel Šimerda (pavlix)
no flags Details | Diff
patch (1.94 KB, patch)
2015-01-22 21:23 UTC, Pavel Šimerda (pavlix)
no flags Details | Diff

Description Tomáš Hozza 🤓 2014-08-15 12:49:54 UTC
Description of problem:
Recently I realized that using dnssec-trigger causes resolv.conf not to contain search domains. This makes users using one-label names from search domain not to resolve.

Version-Release number of selected component (if applicable):
latest

How reproducible:
always

Steps to Reproduce:
1. turn on dnssec-trigger + unbound
2. connect to a network providing you a search domain
3. try to resolve some host without using the search domain ending

Actual results:
The host name is not resolved. The search domain is not appended and tried out.

Expected results:
The search domain should be tried out.

Additional info:

Comment 1 Paul Wouters 2014-08-15 20:38:21 UTC
dnssec-trigger should honour "domain" and "search" entries. But so should NM. This relates to the long discussion we had on always forwarding everything to the dhcp supplied DNS server. There is disagreement on this.

My position is that nothing should ever change my domain/search entries. Others believe the dhcp/vpn domain should always be put there.

Comment 2 Pavel Šimerda (pavlix) 2014-08-18 08:02:27 UTC
We have been working on dnssec-trigger-script but resolv.conf is written out by dnssec-trigger which isn't aware of NetworkManager configuration at all. This logic probably belongs to just one place so when we're using dnssec-trigger-script to configure unbound, it should also be used to write out /etc/resolv.conf which I'm already doing for bug #1125267. The only problem I see is hotspot sign on where dnssec-trigger rewrites /etc/resolv.conf on purpose.

Comment 3 Pavel Šimerda (pavlix) 2014-08-18 08:09:35 UTC
(In reply to Paul Wouters from comment #1)
> My position is that nothing should ever change my domain/search entries.
> Others believe the dhcp/vpn domain should always be put there.

In my opinion, this should be configurable on the side of the tool that originates then change which is NetworkManager on a typical Fedora installation.

Comment 4 Pavel Šimerda (pavlix) 2015-01-21 16:02:10 UTC
*** Bug 1132233 has been marked as a duplicate of this bug. ***

Comment 5 Pavel Šimerda (pavlix) 2015-01-22 10:21:08 UTC
Created attachment 982666 [details]
patch

Comment 6 Pavel Šimerda (pavlix) 2015-01-22 21:23:49 UTC
Created attachment 983076 [details]
patch

Comment 7 Pavel Šimerda (pavlix) 2015-01-23 10:17:37 UTC
The patch implements the search list with a global configuration knob. In future a more fine grained configuration should be part of NetworkManager.

Comment 8 Pavel Šimerda (pavlix) 2015-01-26 13:14:05 UTC
Implemented but not set by default. I know there were some discussions, any comments on setting it by default are welcome.

Comment 9 Fedora Update System 2015-03-17 11:06:47 UTC
dnssec-trigger-0.12-19.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/FEDORA-2015-3864/dnssec-trigger-0.12-19.fc22

Comment 10 Fedora Update System 2015-03-17 11:07:04 UTC
dnssec-trigger-0.12-19.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/FEDORA-2015-3843/dnssec-trigger-0.12-19.fc21

Comment 11 Fedora Update System 2015-03-26 22:04:22 UTC
dnssec-trigger-0.12-19.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 12 Fedora Update System 2015-04-21 18:48:51 UTC
dnssec-trigger-0.12-20.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.