Bug 1130504 - SELinux is preventing /usr/bin/python2.7 from 'create' accesses on the file .
Summary: SELinux is preventing /usr/bin/python2.7 from 'create' accesses on the file .
Keywords:
Status: CLOSED DUPLICATE of bug 1130509
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 20
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Miroslav Grepl
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:b9774a1e200c8f47066d8aaba51...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-15 12:53 UTC by Moez Roy
Modified: 2014-08-15 15:48 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-15 15:48:49 UTC


Attachments (Terms of Use)

Description Moez Roy 2014-08-15 12:53:21 UTC
Description of problem:
SELinux is preventing /usr/bin/python2.7 from 'create' accesses on the file .

*****  Plugin catchall (100. confidence) suggests   **************************

If you believe that python2.7 should be allowed create access on the  file by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep dnssec-trigger- /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:init_t:s0
Target Context                system_u:object_r:dnssec_trigger_var_run_t:s0
Target Objects                 [ file ]
Source                        dnssec-trigger-
Source Path                   /usr/bin/python2.7
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           python-2.7.5-13.fc20.x86_64
Target RPM Packages           
Policy RPM                    selinux-policy-3.12.1-179.fc20.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Host Name                     (removed)
Platform                      Linux (removed) 3.15.9-200.fc20.x86_64 #1 SMP Sat
                              Aug 9 09:02:55 UTC 2014 x86_64 x86_64
Alert Count                   51
First Seen                    2014-08-15 04:49:15 PDT
Last Seen                     2014-08-15 05:49:47 PDT
Local ID                      eb7125bb-dfd2-4d16-a152-756f0da4ceb9

Raw Audit Messages
type=AVC msg=audit(1408106987.970:1318): avc:  denied  { create } for  pid=6830 comm="dnssec-trigger-" name="localhost.localdomain-a5e2b740.6830" scontext=system_u:system_r:init_t:s0 tcontext=system_u:object_r:dnssec_trigger_var_run_t:s0 tclass=file


type=AVC msg=audit(1408106987.970:1318): avc:  denied  { write } for  pid=6830 comm="dnssec-trigger-" path="/run/dnssec-trigger/localhost.localdomain-a5e2b740.6830" dev="tmpfs" ino=136866 scontext=system_u:system_r:init_t:s0 tcontext=system_u:object_r:dnssec_trigger_var_run_t:s0 tclass=file


type=SYSCALL msg=audit(1408106987.970:1318): arch=x86_64 syscall=open success=yes exit=E2BIG a0=c6daf0 a1=241 a2=1b6 a3=1 items=0 ppid=1 pid=6830 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm=dnssec-trigger- exe=/usr/bin/python2.7 subj=system_u:system_r:init_t:s0 key=(null)

Hash: dnssec-trigger-,init_t,dnssec_trigger_var_run_t,file,create

Additional info:
reporter:       libreport-2.2.3
hashmarkername: setroubleshoot
kernel:         3.15.9-200.fc20.x86_64
type:           libreport

Comment 1 Daniel Walsh 2014-08-15 15:48:49 UTC

*** This bug has been marked as a duplicate of bug 1130509 ***


Note You need to log in before you can comment on or make changes to this bug.