Bug 1130507 - SELinux is preventing /usr/bin/python2.7 from 'write' accesses on the sock_file .
Summary: SELinux is preventing /usr/bin/python2.7 from 'write' accesses on the sock_fi...
Keywords:
Status: CLOSED DUPLICATE of bug 1130509
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 20
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Miroslav Grepl
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:a64566479b818061fc7d5079fb3...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-15 12:54 UTC by Moez Roy
Modified: 2014-08-15 15:48 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-15 15:48:31 UTC


Attachments (Terms of Use)

Description Moez Roy 2014-08-15 12:54:38 UTC
Description of problem:
SELinux is preventing /usr/bin/python2.7 from 'write' accesses on the sock_file .

*****  Plugin catchall (100. confidence) suggests   **************************

If you believe that python2.7 should be allowed write access on the  sock_file by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep dnssec-trigger- /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:initrc_t:s0
Target Context                system_u:object_r:NetworkManager_var_run_t:s0
Target Objects                 [ sock_file ]
Source                        dnssec-trigger-
Source Path                   /usr/bin/python2.7
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           python-2.7.5-13.fc20.x86_64
Target RPM Packages           
Policy RPM                    selinux-policy-3.12.1-179.fc20.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Host Name                     (removed)
Platform                      Linux (removed) 3.15.9-200.fc20.x86_64 #1 SMP Sat
                              Aug 9 09:02:55 UTC 2014 x86_64 x86_64
Alert Count                   15
First Seen                    2014-08-15 04:46:06 PDT
Last Seen                     2014-08-15 05:29:54 PDT
Local ID                      5b4f2643-8025-4995-bb1e-2e5c3f8afbbe

Raw Audit Messages
type=AVC msg=audit(1408105794.762:1080): avc:  denied  { write } for  pid=5652 comm="dnssec-trigger-" name="private" dev="tmpfs" ino=21734 scontext=system_u:system_r:initrc_t:s0 tcontext=system_u:object_r:NetworkManager_var_run_t:s0 tclass=sock_file


type=SYSCALL msg=audit(1408105794.762:1080): arch=x86_64 syscall=connect success=yes exit=0 a0=5 a1=7fff1e7141b0 a2=21 a3=7fff1e713f60 items=0 ppid=5645 pid=5652 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm=dnssec-trigger- exe=/usr/bin/python2.7 subj=system_u:system_r:initrc_t:s0 key=(null)

Hash: dnssec-trigger-,initrc_t,NetworkManager_var_run_t,sock_file,write

Additional info:
reporter:       libreport-2.2.3
hashmarkername: setroubleshoot
kernel:         3.15.9-200.fc20.x86_64
type:           libreport

Comment 1 Daniel Walsh 2014-08-15 15:48:31 UTC

*** This bug has been marked as a duplicate of bug 1130509 ***


Note You need to log in before you can comment on or make changes to this bug.