Bug 1130516 - SELinux is preventing /usr/bin/python2.7 from 'read' accesses on the file .
Summary: SELinux is preventing /usr/bin/python2.7 from 'read' accesses on the file .
Keywords:
Status: CLOSED DUPLICATE of bug 1130509
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 20
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Miroslav Grepl
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:e4e4f66bd7f8547b160a1031e6f...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-15 12:56 UTC by Moez Roy
Modified: 2014-08-15 16:09 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-15 16:09:22 UTC


Attachments (Terms of Use)

Description Moez Roy 2014-08-15 12:56:54 UTC
Description of problem:
SELinux is preventing /usr/bin/python2.7 from 'read' accesses on the file .

*****  Plugin catchall (100. confidence) suggests   **************************

If you believe that python2.7 should be allowed read access on the  file by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep dnssec-trigger- /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:init_t:s0
Target Context                system_u:object_r:NetworkManager_etc_rw_t:s0
Target Objects                 [ file ]
Source                        dnssec-trigger-
Source Path                   /usr/bin/python2.7
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           python-2.7.5-13.fc20.x86_64
Target RPM Packages           
Policy RPM                    selinux-policy-3.12.1-179.fc20.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Host Name                     (removed)
Platform                      Linux (removed) 3.15.9-200.fc20.x86_64 #1 SMP Sat
                              Aug 9 09:02:55 UTC 2014 x86_64 x86_64
Alert Count                   6
First Seen                    2014-08-15 05:21:21 PDT
Last Seen                     2014-08-15 05:47:14 PDT
Local ID                      62752331-585c-4cb7-8989-cef9c2848b08

Raw Audit Messages
type=AVC msg=audit(1408106834.891:1280): avc:  denied  { read } for  pid=6580 comm="dnssec-trigger-" name="NetworkManager.conf" dev="dm-0" ino=797825 scontext=system_u:system_r:init_t:s0 tcontext=system_u:object_r:NetworkManager_etc_rw_t:s0 tclass=file


type=AVC msg=audit(1408106834.891:1280): avc:  denied  { open } for  pid=6580 comm="dnssec-trigger-" path="/etc/NetworkManager/NetworkManager.conf" dev="dm-0" ino=797825 scontext=system_u:system_r:init_t:s0 tcontext=system_u:object_r:NetworkManager_etc_rw_t:s0 tclass=file


type=SYSCALL msg=audit(1408106834.891:1280): arch=x86_64 syscall=open success=yes exit=E2BIG a0=120cfb0 a1=0 a2=1b6 a3=0 items=0 ppid=1 pid=6580 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm=dnssec-trigger- exe=/usr/bin/python2.7 subj=system_u:system_r:init_t:s0 key=(null)

Hash: dnssec-trigger-,init_t,NetworkManager_etc_rw_t,file,read

Additional info:
reporter:       libreport-2.2.3
hashmarkername: setroubleshoot
kernel:         3.15.9-200.fc20.x86_64
type:           libreport

Comment 1 Daniel Walsh 2014-08-15 16:09:22 UTC

*** This bug has been marked as a duplicate of bug 1130509 ***


Note You need to log in before you can comment on or make changes to this bug.