Bug 1130550 - scriptlet error in httrack %pretrans [NEEDINFO]
Summary: scriptlet error in httrack %pretrans
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: httrack
Version: 21
Hardware: x86_64
OS: Unspecified
urgent
urgent
Target Milestone: ---
Assignee: Christopher Meng
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:2caa11e1eb9de7cde397ea1740c...
: 1169021 1178306 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-15 13:57 UTC by Joachim Frieben
Modified: 2016-12-13 07:23 UTC (History)
41 users (show)

Fixed In Version: httrack-3.48.20-2.fc22
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-03-05 12:35:47 UTC
i: needinfo?


Attachments (Terms of Use)
File: anaconda-tb (967.51 KB, text/plain)
2014-08-15 13:57 UTC, Joachim Frieben
no flags Details
File: anaconda.log (51.60 KB, text/plain)
2014-08-15 13:57 UTC, Joachim Frieben
no flags Details
File: environ (459 bytes, text/plain)
2014-08-15 13:57 UTC, Joachim Frieben
no flags Details
File: lsblk_output (2.40 KB, text/plain)
2014-08-15 13:57 UTC, Joachim Frieben
no flags Details
File: nmcli_dev_list (1.55 KB, text/plain)
2014-08-15 13:57 UTC, Joachim Frieben
no flags Details
File: os_info (377 bytes, text/plain)
2014-08-15 13:57 UTC, Joachim Frieben
no flags Details
File: program.log (52.86 KB, text/plain)
2014-08-15 13:57 UTC, Joachim Frieben
no flags Details
File: storage.log (253.68 KB, text/plain)
2014-08-15 13:57 UTC, Joachim Frieben
no flags Details
File: syslog (128.92 KB, text/plain)
2014-08-15 13:57 UTC, Joachim Frieben
no flags Details
File: ifcfg.log (2.09 KB, text/plain)
2014-08-15 13:57 UTC, Joachim Frieben
no flags Details
File: packaging.log (388.30 KB, text/plain)
2014-08-15 13:57 UTC, Joachim Frieben
no flags Details
Failed kickstart install on aarch64. (487.11 KB, text/plain)
2014-11-25 02:27 UTC, Paul Whalen
no flags Details
packaging.log (588.21 KB, text/plain)
2015-02-16 10:49 UTC, Markevych Alexander
no flags Details

Description Joachim Frieben 2014-08-15 13:57:06 UTC
Version-Release number of selected component:
anaconda-21.48.2-1

The following was filed automatically by anaconda:
anaconda 21.48.2-1 exception report
Traceback (most recent call first):
  File "/usr/lib64/python2.7/site-packages/pyanaconda/iutil.py", line 272, in execReadlines
    raise OSError("process '%s' was killed" % argv)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/packaging/yumpayload.py", line 1405, in install
    for line in execReadlines("/usr/libexec/anaconda/anaconda-yum", args):
  File "/usr/lib64/python2.7/site-packages/pyanaconda/install.py", line 204, in doInstall
    payload.install()
  File "/usr/lib64/python2.7/threading.py", line 766, in run
    self.__target(*self.__args, **self.__kwargs)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/threads.py", line 227, in run
    threading.Thread.run(self, *args, **kwargs)
OSError: process '['/usr/libexec/anaconda/anaconda-yum', '--config', '/tmp/anaconda-yum.conf', '--tsfile', '/mnt/sysimage/anaconda-yum.yumtx', '--rpmlog', '/tmp/rpm-script.log', '--installroot', '/mnt/sysimage', '--release', '21', '--arch', 'x86_64', '--macro', '__dbi_htconfig', 'hash nofsync %{__dbi_other} %{__dbi_perms}', '--macro', '__file_context_path', '/etc/selinux/targeted/contexts/files/file_contexts']' was killed

Additional info:
addons:         com_redhat_kdump
cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   BOOT_IMAGE=vmlinuz initrd=initrd.img inst.stage2=hd:LABEL=Fedora-21-x86_64 quiet enforcing=0
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.16.0-1.fc21.x86_64
product:        Fedora
release:        Cannot get release name.
type:           anaconda
version:        21

Comment 1 Joachim Frieben 2014-08-15 13:57:20 UTC
Created attachment 927114 [details]
File: anaconda-tb

Comment 2 Joachim Frieben 2014-08-15 13:57:22 UTC
Created attachment 927115 [details]
File: anaconda.log

Comment 3 Joachim Frieben 2014-08-15 13:57:23 UTC
Created attachment 927116 [details]
File: environ

Comment 4 Joachim Frieben 2014-08-15 13:57:25 UTC
Created attachment 927117 [details]
File: lsblk_output

Comment 5 Joachim Frieben 2014-08-15 13:57:26 UTC
Created attachment 927118 [details]
File: nmcli_dev_list

Comment 6 Joachim Frieben 2014-08-15 13:57:27 UTC
Created attachment 927119 [details]
File: os_info

Comment 7 Joachim Frieben 2014-08-15 13:57:29 UTC
Created attachment 927120 [details]
File: program.log

Comment 8 Joachim Frieben 2014-08-15 13:57:34 UTC
Created attachment 927121 [details]
File: storage.log

Comment 9 Joachim Frieben 2014-08-15 13:57:37 UTC
Created attachment 927122 [details]
File: syslog

Comment 10 Joachim Frieben 2014-08-15 13:57:38 UTC
Created attachment 927123 [details]
File: ifcfg.log

Comment 11 Joachim Frieben 2014-08-15 13:57:44 UTC
Created attachment 927124 [details]
File: packaging.log

Comment 12 Brian Lane 2014-10-22 00:12:48 UTC
Please retry with a newer image, at this point anaconda-21.48.2-1 is pretty old.

For reference:

line: FATAL ERROR: python callback <bound method RPMCallback.callback of <__main__.RPMCallback object at 0x7f0af94fcb50>> failed, aborting!

Something went wrong in anaconda-yum, but I can't tell exactly what.

Comment 13 Joachim Frieben 2014-10-22 05:54:58 UTC
Installation went smooth for a couple of weeks now, thanks!

Comment 14 Leslie Satenstein 2014-11-17 17:49:18 UTC
Another user experienced a similar problem:

Running anaconda with a net-install version 

addons:         com_redhat_kdump
cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   BOOT_IMAGE=vmlinuz initrd=initrd.img inst.stage2=hd:LABEL=RFRemix-WS-21-B-x86_64 rd.live.check quiet
hashmarkername: anaconda
kernel:         3.17.2-300.fc21.x86_64
package:        anaconda-21.48.14-1
product:        Fedora"
reason:         OSError: process '['/usr/libexec/anaconda/anaconda-yum', '--config', '/tmp/anaconda-yum.conf', '--tsfile', '/mnt/sysimage/anaconda-yum.yumtx', '--rpmlog', '/tmp/rpm-script.log', '--installroot', '/mnt/sysimage', '--release', '21', '--arch', 'x86_64', '--macro', '__dbi_htconfig', 'hash nofsync %{__dbi_other} %{__dbi_perms}', '--macro', '__file_context_path', '/etc/selinux/targeted/contexts/files/file_contexts']' was killed
release:        Fedora release 21 (Twenty One)
version:        Fedora

Comment 15 Leslie Satenstein 2014-11-18 15:35:11 UTC
Another user experienced a similar problem:

running server  net install  with large choice. Script error with httrack 
Please refer to attached file, if I can provide an attachment

addons:         com_redhat_kdump
cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   BOOT_IMAGE=vmlinuz initrd=initrd.img inst.stage2=hd:LABEL=Fedora-S-21_B-x86_64 quiet
hashmarkername: anaconda
kernel:         3.17.1-302.fc21.x86_64
package:        anaconda-21.48.13-1
product:        Fedora"
reason:         OSError: process '['/usr/libexec/anaconda/anaconda-yum', '--config', '/tmp/anaconda-yum.conf', '--tsfile', '/mnt/sysimage/anaconda-yum.yumtx', '--rpmlog', '/tmp/rpm-script.log', '--installroot', '/mnt/sysimage', '--release', '21', '--arch', 'x86_64', '--macro', '__dbi_htconfig', 'hash nofsync %{__dbi_other} %{__dbi_perms}', '--macro', '__file_context_path', '/etc/selinux/targeted/contexts/files/file_contexts']' was killed
release:        Cannot get release name.
version:        Fedora

Comment 16 Sergey Ivanov 2014-11-18 17:16:59 UTC
Another user experienced a similar problem:

Wanted to install Fedora-21 on SSD disk with manual partitioning.

cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   BOOT_IMAGE=/vmlinuz-3.17.2-300.fc21.x86_64 root=/dev/mapper/fedora00-root ro rd.lvm.lv=fedora00/swap rd.lvm.lv=fedora00/root rhgb quiet LANG=en_US.UTF-8
hashmarkername: anaconda
kernel:         3.17.2-300.fc21.x86_64
other involved packages: python-libs-2.7.8-7.fc21.x86_64
package:        anaconda-core-21.48.13-1.fc21.x86_64
product:        Fedora"
reason:         OSError: process '['/usr/libexec/anaconda/anaconda-yum', '--config', '/tmp/anaconda-yum.conf', '--tsfile', '/mnt/sysimage/anaconda-yum.yumtx', '--rpmlog', '/tmp/rpm-script.log', '--installroot', '/mnt/sysimage', '--release', 'rawhide', '--arch', 'x86_64', '--macro', '__dbi_htconfig', 'hash nofsync %{__dbi_other} %{__dbi_perms}', '--macro', '__file_context_path', '/etc/selinux/targeted/contexts/files/file_contexts']' was killed
release:        Fedora release 21 (Twenty One)
version:        Fedora

Comment 17 Langdon White 2014-11-22 15:48:31 UTC
Another user experienced a similar problem:

net install off of usb using efi

addons:         com_redhat_kdump
cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   BOOT_IMAGE=/images/pxeboot/vmlinuz inst.stage2=hd:LABEL=Fedora-S-21_B-x86_64 quiet
hashmarkername: anaconda
kernel:         3.17.1-302.fc21.x86_64
package:        anaconda-21.48.13-1
product:        Fedora"
reason:         OSError: process '['/usr/libexec/anaconda/anaconda-yum', '--config', '/tmp/anaconda-yum.conf', '--tsfile', '/mnt/sysimage/anaconda-yum.yumtx', '--rpmlog', '/tmp/rpm-script.log', '--installroot', '/mnt/sysimage', '--release', '21', '--arch', 'x86_64', '--macro', '__dbi_htconfig', 'hash nofsync %{__dbi_other} %{__dbi_perms}', '--macro', '__file_context_path', '/etc/selinux/targeted/contexts/files/file_contexts']' was killed
release:        Cannot get release name.
version:        Fedora

Comment 18 Paul Whalen 2014-11-24 18:11:57 UTC
Another user experienced a similar problem:

Install of Fedora 21 TC1 with defaults.

cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   BOOT_IMAGE=/fedora/aarch64/21_TC1/vmlinuz inst.repo=http://rhel/fedora/fedora-release/aarch64/21_TC1/ ro console=ttyS0,115200n8
hashmarkername: anaconda
kernel:         3.17.3-300.fc21.aarch64
package:        anaconda-21.48.14-1
product:        Fedora"
reason:         OSError: process '['/usr/libexec/anaconda/anaconda-yum', '--config', '/tmp/anaconda-yum.conf', '--tsfile', '/mnt/sysimage/anaconda-yum.yumtx', '--rpmlog', '/tmp/rpm-script.log', '--installroot', '/mnt/sysimage', '--release', '21', '--arch', 'aarch64', '--macro', '__dbi_htconfig', 'hash nofsync %{__dbi_other} %{__dbi_perms}', '--macro', '__file_context_path', '/etc/selinux/targeted/contexts/files/file_contexts']' was killed
release:        Cannot get release name.
version:        Fedora

Comment 19 Paul Whalen 2014-11-24 18:45:23 UTC
Still happening on aarch64 F21 TC1 (anaconda-21.48.14-1), reopening.

Comment 20 Brian Lane 2014-11-25 02:01:35 UTC
Someone (or everyone) is going to have to attach their logs (anaconda-tb-* if possible). Something is killing off the anaconda-yum process and it's really hard to tell what's happening since I can't reproduce it.

Comment 21 Fedora Blocker Bugs Application 2014-11-25 02:02:53 UTC
Proposed as a Blocker for 21-final by Fedora user bcl using the blocker tracking app because:

 Not being able to install break the criteria requiring the install media to be able to be installed :) Gathering more details on this, but there are a number of users who have hit it using different anaconda versions and different kernels.

Comment 22 Paul Whalen 2014-11-25 02:27:57 UTC
Created attachment 960993 [details]
Failed kickstart install on aarch64.

Fails when installing grub2-tools.

Comment 23 Brian Lane 2014-11-25 17:13:55 UTC
(In reply to Paul Whalen from comment #22)
> Created attachment 960993 [details]
> Failed kickstart install on aarch64.
> 
> Fails when installing grub2-tools.

Thanks Paul. I think your failure is due to a package problem, I see this in the logs:

02:11:19,349 ERR packaging:  unpack error with package grub2-tools
02:11:19,457 INFO packaging: error: unpacking of archive failed on file /usr/bin/grub2-fstest;5473e455: cpio: read

But I'm not sure why the process is getting killed instead of it returning an error for anaconda to display.

Looking at the original logs again I see this:

08:57:55,894 ERR packaging:  getPackage error after 10 retries: failure: Packages/l/libgomp-4.9.1-6.fc21.x86_64.rpm from anaconda: [Errno 256] No more mirrors to try.

So I think this is a failure to cleanly handle errors in anaconda-yum vs. some mysterious thing that is killing it and I'm less inclined to call it a blocker unless someone has logs that DON'T show any errors.

Comment 24 Paul Whalen 2014-11-25 17:55:39 UTC
Apologies bcl, the package is indeed corrupt in the compose. Many Thanks!

Comment 25 Scott Suehle 2014-11-26 19:31:34 UTC
Discussed in 2014-11-26 Blocker Review Meeting [1]. Voted as an RejectedBlocker. Based on the information provided within this bug, this bug isn't an issue with anaconda and is not considered blocking.
 
[1] http://meetbot.fedoraproject.org/fedora-blocker-review/2014-11-26/

Comment 26 Martin Kolman 2014-12-01 13:23:33 UTC
*** Bug 1169021 has been marked as a duplicate of this bug. ***

Comment 27 David Shea 2014-12-01 18:45:04 UTC
(In reply to bcl@redhat.com from comment #23)

> But I'm not sure why the process is getting killed instead of it returning
> an error for anaconda to display.

To clear this part up, the error message is wrong. The process is returning "1" and execReadlines is interpreting that as exiting on signal, because of the insanity between subprocess return codes and exec/wait return codes. This is correct on master.

Comment 28 Gene Czarcinski 2014-12-02 15:17:30 UTC
My report BZ# 1169021 was closed as a dup of this but it is occuring with anaconda-21.48.18-1 (RC1) and is very repeatable.  Simply select the Creative Workstation (nonproduct) and Security Lab ... this produces traceback.  Do you need my logs too?

Comment 29 David Shea 2014-12-02 15:22:51 UTC
(In reply to Gene Czarcinski from comment #28)
> My report BZ# 1169021 was closed as a dup of this but it is occuring with
> anaconda-21.48.18-1 (RC1) and is very repeatable.  Simply select the
> Creative Workstation (nonproduct) and Security Lab ... this produces
> traceback.  Do you need my logs too?

Nah. It's the same issue, a script error in httrack.

20:27:59,530 INFO packaging: ==== start rpm scriptlet logs ====
20:27:59,530 INFO packaging: warning: filesystem-3.2-27.fc21.x86_64: Header V3 RSA/SHA256 Signature, key ID 95a43f54: NOKEY

20:27:59,530 INFO packaging: error: %pretrans(httrack-3.48.19-3.fc21.x86_64) scriptlet failed, exit status 127

20:27:59,531 INFO packaging: ==== end rpm scriptlet logs ====

Comment 30 Brian Lane 2014-12-02 23:10:06 UTC
Closing per comment 27.

Comment 31 Alexander Bokovoy 2014-12-04 18:08:08 UTC
Another user experienced a similar problem:

Attempted to install using boot.iso. Didn't choose to create any user and Anaconda raised an exception at the package install claiming 'invalid user name' (in Russian as I chose to install in Russian).

addons:         com_redhat_kdump
cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   BOOT_IMAGE=/images/pxeboot/vmlinuz inst.stage2=hd:LABEL=Fedora-21-x86_64 quiet
hashmarkername: anaconda
kernel:         3.17.4-301.fc21.x86_64
package:        anaconda-21.48.16-1
product:        Fedora"
reason:         OSError: process '['/usr/libexec/anaconda/anaconda-yum', '--config', '/tmp/anaconda-yum.conf', '--tsfile', '/mnt/sysimage/anaconda-yum.yumtx', '--rpmlog', '/tmp/rpm-script.log', '--installroot', '/mnt/sysimage', '--release', '21', '--arch', 'x86_64', '--macro', '__dbi_htconfig', 'hash nofsync %{__dbi_other} %{__dbi_perms}', '--macro', '__file_context_path', '/etc/selinux/targeted/contexts/files/file_contexts']' was killed
release:        Cannot get release name.
version:        Fedora

Comment 32 Gabriel Somlo 2014-12-13 19:20:51 UTC
Another user experienced a similar problem:

I am trying to perform a network install using a custom kickstart file.
Whenever the %packages section of my kickstart file includes @security-lab
(or, more narrowly, httrack), the installer crashes.

Strangely, once I successfully build the machine by leaving out httrack
or @security-lab from the kickstart file, I can "yum install httrack" with
no further trouble whatsoever.

addons:         com_redhat_kdump
cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   initrd=initrd.img ks=http://mirror.ini.cmu.edu/ks/test21.ks BOOT_IMAGE=vmlinuz 
hashmarkername: anaconda
kernel:         3.17.4-301.fc21.x86_64
package:        anaconda-21.48.21-1
product:        Fedora"
reason:         OSError: process '['/usr/libexec/anaconda/anaconda-yum', '--config', '/tmp/anaconda-yum.conf', '--tsfile', '/mnt/sysimage/anaconda-yum.yumtx', '--rpmlog', '/tmp/rpm-script.log', '--installroot', '/mnt/sysimage', '--release', '21', '--arch', 'x86_64', '--macro', '__dbi_htconfig', 'hash nofsync %{__dbi_other} %{__dbi_perms}', '--macro', '__file_context_path', '/etc/selinux/targeted/contexts/files/file_contexts']' was killed
release:        Cannot get release name.
version:        Fedora

Comment 33 Jim Lewis 2014-12-13 21:54:48 UTC
Another user experienced a similar problem:

During install of Fedora 21 Server (Fedora-Server-netinst-x86_64-21.iso).  CD was verified. Laptop is a Lenovo T500 and runs previous version of Fedora just fine, including the Mate-Compiz spin. My DVD drive works fine. 

addons:         com_redhat_kdump
cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   BOOT_IMAGE=vmlinuz initrd=initrd.img inst.stage2=hd:LABEL=Fedora-S-21-x86_64 rd.live.check quiet
hashmarkername: anaconda
kernel:         3.17.4-301.fc21.x86_64
package:        anaconda-21.48.21-1
product:        Fedora"
reason:         OSError: process '['/usr/libexec/anaconda/anaconda-yum', '--config', '/tmp/anaconda-yum.conf', '--tsfile', '/mnt/sysimage/anaconda-yum.yumtx', '--rpmlog', '/tmp/rpm-script.log', '--installroot', '/mnt/sysimage', '--release', '21', '--arch', 'x86_64', '--macro', '__dbi_htconfig', 'hash nofsync %{__dbi_other} %{__dbi_perms}', '--macro', '__file_context_path', '/etc/selinux/targeted/contexts/files/file_contexts']' was killed
release:        Cannot get release name.
version:        Fedora

Comment 34 Jim Lewis 2014-12-13 22:12:47 UTC
Does anyone have a solution for this yet? Note that I had successfully installed the Mate-Compiz Spin on this machine. I thought using the Server inst image would result in more applications, and less items to manually install. I guess that was a bad idea.

Comment 35 Gabriel Somlo 2014-12-13 22:40:19 UTC
As far as I was able to narrow it down, this anaconda bug is triggered
by including httrack (or @security-lab) during install (e.g. from the
%package section of a kickstart file). Also, see comment 29.

Comments 27 and 30 seem to suggest that the anaconda bug itself is
fixed, although those comments were made on Dec. 02, before the release
of F21 final. How come the anaconda bug is still present in F21 final
release is a bit of a mystery to me.

Please re-close if I misunderstood, and the anaconda bug is known to
be fixed but there just wasn't enough time for the fix to make it into
F21 final.

Comment 36 Jim Lewis 2014-12-14 00:04:21 UTC
Here's some more info: I did not select as many Add-ons this time and attempted the install again (I'm pretty sure I did not include the Security add-on this time). The installation went a whole lot farther, and was probably almost done. However, when I cam back to check on it the screen was black with just the Caps Lock light flashing. Nothing would wake it up, it would not ping, no hard drive or LAN access. Dead. 

So, thinking this might be a problem with my DVD drive or image I re-installed the Mate-Compbiz spin. Went just fine, as it did before. 

If I can be of further help on this just let me know.

Comment 37 David Shea 2014-12-14 22:23:54 UTC
(In reply to Gabriel Somlo from comment #35)
> As far as I was able to narrow it down, this anaconda bug is triggered
> by including httrack (or @security-lab) during install (e.g. from the
> %package section of a kickstart file). Also, see comment 29.

That is correct. It could be another package with a script error, but httrack seems to be the one that everyone is hitting. And given that httrack hasn't done anything, how about we reassign the bug there. Looking at the spec file, my guess is it's this part of %pretrans:

        [ ! -h %{_datadir}/%{name}/html -a -d %{_datadir}/%{name}/html ] && \
                rm -rf %{_datadir}/%{name}/html

Since if the directories don't exist (which of course they won't, it's a new install), then the exit of that command will be 1. There's an exit 0 right after it, but maybe rpm scripts are run with -e? I'm not sure. It looks like trouble.

> Comments 27 and 30 seem to suggest that the anaconda bug itself is
> fixed, although those comments were made on Dec. 02, before the release
> of F21 final. How come the anaconda bug is still present in F21 final
> release is a bit of a mystery to me.

The bug is fixed in the sense that the inaccurate "was killed" error message has been corrected. Scriptlet errors will still halt installation since scriptlet errors are considered fatal to the rpm transaction.

The change in rawhide happened post-freeze for Fedora 21, and, especially since the fix was a side-effect of reworking a lot of anaconda's child process management, it was not backported to Fedora 21.

Comment 38 Gabriel Somlo 2014-12-14 23:48:14 UTC
(In reply to David Shea from comment #37, re. anaconda bug)
> The bug is fixed in the sense that the inaccurate "was killed" error message
> has been corrected. Scriptlet errors will still halt installation since
> scriptlet errors are considered fatal to the rpm transaction.
> 
> The change in rawhide happened post-freeze for Fedora 21, and, especially
> since the fix was a side-effect of reworking a lot of anaconda's child
> process management, it was not backported to Fedora 21.

Just to clarify: will the fixed Anaconda name and shame the package which
caused the installation to halt ?

My main problem here was not so much the inability to install httrack during
kickstart, but rather the difficulty of figuring out just *which* package was
causing the problem. Maybe ctrl-alt-<some-function-key> would have taken me
to the log screen which maybe would have had httrack mentioned by name (among
a whole bunch of other "visual noise"), but what I ended up doing was basically
to "bisect" my %packages list, which took quite a while :) Having anaconda point
out httrack by name would have saved me all that trouble...

Comment 39 David Shea 2015-01-05 15:12:01 UTC
*** Bug 1178306 has been marked as a duplicate of this bug. ***

Comment 40 Alex Smirnoff 2015-01-12 13:34:38 UTC
Another user experienced a similar problem:

fresh install

addons:         com_redhat_kdump
cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   BOOT_IMAGE=vmlinuz initrd=initrd.img inst.stage2=hd:LABEL=RFRemix-WS-21-x86_64 rd.live.check quiet
hashmarkername: anaconda
kernel:         3.17.4-301.fc21.x86_64
package:        anaconda-21.48.21-1
product:        Fedora"
reason:         OSError: process '['/usr/libexec/anaconda/anaconda-yum', '--config', '/tmp/anaconda-yum.conf', '--tsfile', '/mnt/sysimage/anaconda-yum.yumtx', '--rpmlog', '/tmp/rpm-script.log', '--installroot', '/mnt/sysimage', '--release', '21', '--arch', 'x86_64', '--macro', '__dbi_htconfig', 'hash nofsync %{__dbi_other} %{__dbi_perms}', '--macro', '__file_context_path', '/etc/selinux/targeted/contexts/files/file_contexts']' was killed
release:        Fedora release 21 (Twenty One)
version:        Fedora

Comment 41 Jason VanHooser 2015-01-24 20:47:50 UTC
Another user experienced a similar problem:

Installing Fedora server 21 on Dell Poweredge 2900

addons:         com_redhat_kdump
cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   initrd=initrd.img inst.stage2=hd:LABEL=LIVE quiet BOOT_IMAGE=vmlinuz 
hashmarkername: anaconda
kernel:         3.17.4-301.fc21.x86_64
package:        anaconda-21.48.21-1
product:        Fedora"
reason:         OSError: process '['/usr/libexec/anaconda/anaconda-yum', '--config', '/tmp/anaconda-yum.conf', '--tsfile', '/mnt/sysimage/anaconda-yum.yumtx', '--rpmlog', '/tmp/rpm-script.log', '--installroot', '/mnt/sysimage', '--release', '21', '--arch', 'x86_64', '--macro', '__dbi_htconfig', 'hash nofsync %{__dbi_other} %{__dbi_perms}', '--macro', '__file_context_path', '/etc/selinux/targeted/contexts/files/file_contexts']' was killed
release:        Cannot get release name.
version:        Fedora

Comment 42 Kyle Brooks 2015-01-25 18:14:11 UTC
Another user experienced a similar problem:

Installing Fedora 21 network install over wifi (currently conencted)
Using custom partitioning with BTRFS, system hung at starting package installation after creating root password and an admin user.

addons:         com_redhat_kdump
cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   BOOT_IMAGE=vmlinuz initrd=initrd.img inst.stage2=hd:LABEL=Fedora-S-21-x86_64 quiet
hashmarkername: anaconda
kernel:         3.17.4-301.fc21.x86_64
package:        anaconda-21.48.21-1
product:        Fedora"
reason:         OSError: process '['/usr/libexec/anaconda/anaconda-yum', '--config', '/tmp/anaconda-yum.conf', '--tsfile', '/mnt/sysimage/anaconda-yum.yumtx', '--rpmlog', '/tmp/rpm-script.log', '--installroot', '/mnt/sysimage', '--release', '21', '--arch', 'x86_64', '--macro', '__dbi_htconfig', 'hash nofsync %{__dbi_other} %{__dbi_perms}', '--macro', '__file_context_path', '/etc/selinux/targeted/contexts/files/file_contexts']' was killed
release:        Cannot get release name.
version:        Fedora

Comment 43 Clayton Dobbs 2015-01-30 14:19:11 UTC
Another user experienced a similar problem:

Was performing fedora21 netinstall for Cinnamon Desktop and added bundles for software development and document publication, with the security and admin tools.

addons:         com_redhat_kdump
cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   BOOT_IMAGE=vmlinuz initrd=initrd.img inst.stage2=hd:LABEL=Fedora-S-21-x86_64 rd.live.check quiet
hashmarkername: anaconda
kernel:         3.17.4-301.fc21.x86_64
package:        anaconda-21.48.21-1
product:        Fedora"
reason:         OSError: process '['/usr/libexec/anaconda/anaconda-yum', '--config', '/tmp/anaconda-yum.conf', '--tsfile', '/mnt/sysimage/anaconda-yum.yumtx', '--rpmlog', '/tmp/rpm-script.log', '--installroot', '/mnt/sysimage', '--release', '21', '--arch', 'x86_64', '--macro', '__dbi_htconfig', 'hash nofsync %{__dbi_other} %{__dbi_perms}', '--macro', '__file_context_path', '/etc/selinux/targeted/contexts/files/file_contexts']' was killed
release:        Cannot get release name.
version:        Fedora

Comment 44 Brian J. Rogers 2015-02-04 16:18:04 UTC
Another user experienced a similar problem:

Installing on a Dell Optiplex GX520, selected MariaDB and PostgreSQL to install along with basic server after manually specifying a mirror. Also selected to review partioning, deleted all old partitions from the drive and told installer to reclaim space.

addons:         com_redhat_kdump
cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   BOOT_IMAGE=vmlinuz initrd=initrd.img inst.stage2=hd:LABEL=LIVE quiet
hashmarkername: anaconda
kernel:         3.17.4-301.fc21.x86_64
package:        anaconda-21.48.21-1
product:        Fedora"
reason:         OSError: process '['/usr/libexec/anaconda/anaconda-yum', '--config', '/tmp/anaconda-yum.conf', '--tsfile', '/mnt/sysimage/anaconda-yum.yumtx', '--rpmlog', '/tmp/rpm-script.log', '--installroot', '/mnt/sysimage', '--release', '21', '--arch', 'x86_64', '--macro', '__dbi_htconfig', 'hash nofsync %{__dbi_other} %{__dbi_perms}', '--macro', '__file_context_path', '/etc/selinux/targeted/contexts/files/file_contexts']' was killed
release:        Cannot get release name.
version:        Fedora

Comment 45 Mike Ruckman 2015-02-10 21:44:36 UTC
Another user experienced a similar problem:

Attempted to build a cloud image following the notes here: http://worknotes.rtfd.org inside a rawhide VM. Build crashes after starting installation.

addons:         com_redhat_kdump
cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   method=http://dl.fedoraproject.org/pub/alt/stage/21_Beta_RC2/Cloud/x86_64/os/ ks=file:/ks.cfg
hashmarkername: anaconda
kernel:         3.17.1-302.fc21.x86_64
package:        anaconda-21.48.13-1
product:        Fedora"
reason:         OSError: process '['/usr/libexec/anaconda/anaconda-yum', '--config', '/tmp/anaconda-yum.conf', '--tsfile', '/mnt/sysimage/anaconda-yum.yumtx', '--rpmlog', '/tmp/rpm-script.log', '--installroot', '/mnt/sysimage', '--release', '21', '--arch', 'x86_64', '--macro', '__dbi_htconfig', 'hash nofsync %{__dbi_other} %{__dbi_perms}', '--macro', '_install_langs', 'en', '--macro', '__file_context_path', '/etc/selinux/targeted/contexts/files/file_contexts']' was killed
release:        Cannot get release name.
version:        Fedora

Comment 46 Markevych Alexander 2015-02-12 10:28:44 UTC
Another user experienced a similar problem:

1) Download Fedora-Server-netinst-x86_64-21.iso
2) Create VirtualBox new machine on my Windows 7 x64 host
3) Begin instalation and choose packages. Fedora Cloud role, and some others packages from right panel.
4) And this bug was shown on the begin packages installation

addons:         com_redhat_kdump
cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   BOOT_IMAGE=vmlinuz initrd=initrd.img inst.stage2=hd:LABEL=Fedora-S-21-x86_64 rd.live.check quiet
hashmarkername: anaconda
kernel:         3.17.4-301.fc21.x86_64
package:        anaconda-21.48.21-1
product:        Fedora"
reason:         OSError: process '['/usr/libexec/anaconda/anaconda-yum', '--config', '/tmp/anaconda-yum.conf', '--tsfile', '/mnt/sysimage/anaconda-yum.yumtx', '--rpmlog', '/tmp/rpm-script.log', '--installroot', '/mnt/sysimage', '--release', '21', '--arch', 'x86_64', '--macro', '__dbi_htconfig', 'hash nofsync %{__dbi_other} %{__dbi_perms}', '--macro', '__file_context_path', '/etc/selinux/targeted/contexts/files/file_contexts']' was killed
release:        Cannot get release name.
version:        Fedora

Comment 47 Kashyap Chamarthy 2015-02-13 12:20:15 UTC
Another instance here (when Anaconda failed to find a certain package, GCC in this case, from one of the configured repositories):

[. . .]
10:42:03,823 DEBUG anaconda: running handleException
10:42:03,825 CRIT anaconda: Traceback (most recent call last):

  File "/usr/lib64/python2.7/site-packages/pyanaconda/threads.py", line 227, in run
    threading.Thread.run(self, *args, **kwargs)

  File "/usr/lib64/python2.7/threading.py", line 766, in run
    self.__target(*self.__args, **self.__kwargs)

  File "/usr/lib64/python2.7/site-packages/pyanaconda/install.py", line 224, in doInstall
    payload.install()

  File "/usr/lib64/python2.7/site-packages/pyanaconda/packaging/yumpayload.py", line 1421, in install
    for line in execReadlines("/usr/libexec/anaconda/anaconda-yum", args):

  File "/usr/lib64/python2.7/site-packages/pyanaconda/iutil.py", line 272, in execReadlines
    raise OSError("process '%s' was killed" % argv)

OSError: process '['/usr/libexec/anaconda/anaconda-yum', '--config', '/tmp/anaconda-yum.conf', '--tsfile', '/mnt/sysimage/anaconda-yum.yumtx', '--rpmlog', '/tmp/rpm-script.log', '--installroot', '/mnt/sysimage', '--release', '21', '--arch', 'aarch64', '--macro', '__dbi_htconfig', 'hash nofsync %{__dbi_other} %{__dbi_perms}', '--macro', '__file_context_path', '/etc/selinux/targeted/contexts/files/file_contexts']' was killed
[. . .]

Comment 48 Kay Schüffler 2015-02-14 17:58:28 UTC
Another user experienced a similar problem:

Installation in Hyper-V on a Windows 8.1 x64

addons:         com_redhat_kdump
cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   BOOT_IMAGE=/images/pxeboot/vmlinuz inst.stage2=hd:LABEL=Fedora-S-21-x86_64 rd.live.check quiet
hashmarkername: anaconda
kernel:         3.17.4-301.fc21.x86_64
package:        anaconda-21.48.21-1
product:        Fedora"
reason:         OSError: process '['/usr/libexec/anaconda/anaconda-yum', '--config', '/tmp/anaconda-yum.conf', '--tsfile', '/mnt/sysimage/anaconda-yum.yumtx', '--rpmlog', '/tmp/rpm-script.log', '--installroot', '/mnt/sysimage', '--release', '21', '--arch', 'x86_64', '--macro', '__dbi_htconfig', 'hash nofsync %{__dbi_other} %{__dbi_perms}', '--macro', '__file_context_path', '/etc/selinux/targeted/contexts/files/file_contexts']' was killed
release:        Cannot get release name.
version:        Fedora

Comment 49 Markevych Alexander 2015-02-16 10:49:13 UTC
Created attachment 992111 [details]
packaging.log

Maybe it's can help. anaconda-yum running on another thread failed when trying to install httrack package. This package consists on one of software category. I don't know wich category. If any know this - please help, I will try to rerun anaconda instalation process without this software group.

Comment 50 Alexey Pakseykin 2015-02-19 14:59:56 UTC
Another user experienced a similar problem:

Just install Fedora Server 21 x86_64 using "Minimal Install" from "netinstall" ISO disk.

Minimum tweaks to filesystem:
It has a 1 TiB storage used by two partitions: one for `/boot` = 1024 MiB ext4 and the other one for LVM with  `/` = 64 GiB ext4, `swap` = 1024 MiB ext4. The rest is unallocated (to be used later).

addons:         com_redhat_kdump
cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   BOOT_IMAGE=vmlinuz initrd=initrd.img inst.stage2=hd:LABEL=Fedora-S-21-x86_64 rd.live.check quiet
hashmarkername: anaconda
kernel:         3.17.4-301.fc21.x86_64
package:        anaconda-21.48.21-1
product:        Fedora"
reason:         OSError: process '['/usr/libexec/anaconda/anaconda-yum', '--config', '/tmp/anaconda-yum.conf', '--tsfile', '/mnt/sysimage/anaconda-yum.yumtx', '--rpmlog', '/tmp/rpm-script.log', '--installroot', '/mnt/sysimage', '--release', '21', '--arch', 'x86_64', '--macro', '__dbi_htconfig', 'hash nofsync %{__dbi_other} %{__dbi_perms}', '--macro', '__file_context_path', '/etc/selinux/targeted/contexts/files/file_contexts']' was killed
release:        Cannot get release name.
version:        Fedora

Comment 51 Dale Snell 2015-02-22 04:34:24 UTC
Another user experienced a similar problem:

This is completely reproducible; it happens every time I try to do a network installation of Fedora 21.  It doesn't matter if I do a proper Server installation, or a Desktop installation.  This one happened to be an XFCE Desktop install.  Please note that this only occurs during a network installation; installing straight from the DVD works fine.

1. Follow the instructions step-by-step. 
2. Set up partitioning on an SSD: /boot, swap, LVM for OS files (/, /var), LVM for data files (/home, /opt, /usr/opt).
3. Start the installation and set up the root password and one user (as administrator).
4. After a good five minutes of "Starting package installation process", the spinner stops spinning.  Thiirty seconds or so later, and the error window pops up ("An unknown error has occurred").

addons:         com_redhat_kdump
cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   BOOT_IMAGE=vmlinuz initrd=initrd.img inst.stage2=hd:LABEL=Fedora-S-21-x86_64 quiet
hashmarkername: anaconda
kernel:         3.17.4-301.fc21.x86_64
package:        anaconda-21.48.21-1
product:        Fedora"
reason:         OSError: process '['/usr/libexec/anaconda/anaconda-yum', '--config', '/tmp/anaconda-yum.conf', '--tsfile', '/mnt/sysimage/anaconda-yum.yumtx', '--rpmlog', '/tmp/rpm-script.log', '--installroot', '/mnt/sysimage', '--release', '21', '--arch', 'x86_64', '--macro', '__dbi_htconfig', 'hash nofsync %{__dbi_other} %{__dbi_perms}', '--macro', '__file_context_path', '/etc/selinux/targeted/contexts/files/file_contexts']' was killed
release:        Cannot get release name.
version:        Fedora

Comment 52 Todd Thomas 2015-02-23 21:00:09 UTC
Another user experienced a similar problem:

F21 Server install failed on an HP Compaq dc5800 Microtower. F21 disk was downloaded a over a month ago and has been used successfully on multiple (other) dissimilar harware.

addons:         com_redhat_kdump
cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   BOOT_IMAGE=vmlinuz initrd=initrd.img inst.stage2=hd:LABEL=Fedora-S-21-x86_64 rd.live.check quiet
hashmarkername: anaconda
kernel:         3.17.4-301.fc21.x86_64
package:        anaconda-21.48.21-1
product:        Fedora"
reason:         OSError: process '['/usr/libexec/anaconda/anaconda-yum', '--config', '/tmp/anaconda-yum.conf', '--tsfile', '/mnt/sysimage/anaconda-yum.yumtx', '--rpmlog', '/tmp/rpm-script.log', '--installroot', '/mnt/sysimage', '--release', '21', '--arch', 'x86_64', '--macro', '__dbi_htconfig', 'hash nofsync %{__dbi_other} %{__dbi_perms}', '--macro', '__file_context_path', '/etc/selinux/targeted/contexts/files/file_contexts']' was killed
release:        Cannot get release name.
version:        Fedora

Comment 53 Christopher Meng 2015-02-24 09:21:16 UTC
(In reply to David Shea from comment #37)
> (In reply to Gabriel Somlo from comment #35)
> > As far as I was able to narrow it down, this anaconda bug is triggered
> > by including httrack (or @security-lab) during install (e.g. from the
> > %package section of a kickstart file). Also, see comment 29.
> 
> That is correct. It could be another package with a script error, but
> httrack seems to be the one that everyone is hitting. And given that httrack
> hasn't done anything, how about we reassign the bug there. Looking at the
> spec file, my guess is it's this part of %pretrans:
> 
>         [ ! -h %{_datadir}/%{name}/html -a -d %{_datadir}/%{name}/html ] && \
>                 rm -rf %{_datadir}/%{name}/html
> 
> Since if the directories don't exist (which of course they won't, it's a new
> install), then the exit of that command will be 1. There's an exit 0 right
> after it, but maybe rpm scripts are run with -e? I'm not sure. It looks like
> trouble.

David, your guess is correct. But it's not caused by the script itself, but the usage.

The crux is the script doesn't run in fresh installation environment, instead only lua scripts are executed successfully. 

I will port the script.

Comment 54 Fedora Update System 2015-02-27 10:02:21 UTC
httrack-3.48.20-1.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/httrack-3.48.20-1.fc21

Comment 55 Fedora Update System 2015-02-27 10:02:29 UTC
httrack-3.48.20-1.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/httrack-3.48.20-1.fc22

Comment 56 Fedora Update System 2015-02-27 19:44:06 UTC
Package httrack-3.48.20-1.fc22:
* should fix your issue,
* was pushed to the Fedora 22 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing httrack-3.48.20-1.fc22'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-2787/httrack-3.48.20-1.fc22
then log in and leave karma (feedback).

Comment 57 Kyle Cheung 2015-02-28 20:14:47 UTC
Another user experienced a similar problem:

Using the graphical netinst image to install the Cinnamon version (the same error occurred when using the X install option). Root and user creation was not set. Computer was booted with UEFI and was auto partitioned (unallocated space was made via the Disk management tool in Windows). with an existing windows 7 and reFind installation. The partitions are GPT.

addons:         com_redhat_kdump
cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   BOOT_IMAGE=/images/pxeboot/vmlinuz inst.stage2=hd:LABEL=Fedora-S-21-x86_64 quiet
hashmarkername: anaconda
kernel:         3.17.4-301.fc21.x86_64
package:        anaconda-21.48.21-1
product:        Fedora"
reason:         OSError: process '['/usr/libexec/anaconda/anaconda-yum', '--config', '/tmp/anaconda-yum.conf', '--tsfile', '/mnt/sysimage/anaconda-yum.yumtx', '--rpmlog', '/tmp/rpm-script.log', '--installroot', '/mnt/sysimage', '--release', '21', '--arch', 'x86_64', '--macro', '__dbi_htconfig', 'hash nofsync %{__dbi_other} %{__dbi_perms}', '--macro', '__file_context_path', '/etc/selinux/targeted/contexts/files/file_contexts']' was killed
release:        Cannot get release name.
version:        Fedora

Comment 58 Arnaud 2015-03-01 09:54:46 UTC
I have a problem with: httrack-3.48.20-1.fc21.x86_64

I am getting this when I try to update httrack:
file /usr/share/doc/httrack/html from install of httrack-3.48.20-1.fc21.x86_64 conflicts with file from package httrack-3.48.19-3.fc21.x86_64

I then ran yum-complete-transaction --exclude=httrack , but it has remnoved httrack completly and did n0t just exclude it.

Comment 59 Arnaud 2015-03-01 10:01:17 UTC
sorry for the typo, I forgot to mention that I ran yum-complete-transaction because yum told me the transaction couldn't start, before telling this conflict, and yum stopped.

Comment 60 Christopher Meng 2015-03-01 11:58:40 UTC
(In reply to Heldwin from comment #58)
> I have a problem with: httrack-3.48.20-1.fc21.x86_64
> 
> I am getting this when I try to update httrack:
> file /usr/share/doc/httrack/html from install of
> httrack-3.48.20-1.fc21.x86_64 conflicts with file from package
> httrack-3.48.19-3.fc21.x86_64

Weird, I tested this with f19 rpm and it worked, looks like something is really bad inside.

Inspecting.

Comment 61 Michael Schwendt 2015-03-01 12:21:25 UTC
The package scriptlet does not handle transition of /usr/share/doc/httrack/html from "symlink to directory" yet. It only handles /usr/share/httrack/html.

# rpmls -p httrack-3.48.19-3.fc21.x86_64.rpm|grep -v ^-
rpm: no arguments given for query
lrwxrwxrwx  /usr/lib64/libhtsjava.so.2
lrwxrwxrwx  /usr/lib64/libhttrack.so.2
drwxr-xr-x  /usr/share/doc/httrack
lrwxrwxrwx  /usr/share/doc/httrack/html
drwxr-xr-x  /usr/share/doc/httrack/templates
drwxr-xr-x  /usr/share/httrack
lrwxrwxrwx  /usr/share/httrack/html
drwxr-xr-x  /usr/share/httrack/lang

# rpmls -p httrack-3.48.20-1.fc21.x86_64.rpm |grep -v ^-
rpm: no arguments given for query
lrwxrwxrwx  /usr/lib64/libhtsjava.so.2
lrwxrwxrwx  /usr/lib64/libhttrack.so.2
drwxr-xr-x  /usr/share/doc/httrack
drwxr-xr-x  /usr/share/doc/httrack/html
drwxr-xr-x  /usr/share/doc/httrack/html/div
drwxr-xr-x  /usr/share/doc/httrack/html/images
drwxr-xr-x  /usr/share/doc/httrack/html/img
drwxr-xr-x  /usr/share/doc/httrack/html/server
drwxr-xr-x  /usr/share/doc/httrack/html/server/images
drwxr-xr-x  /usr/share/doc/httrack/html/server/sfx
drwxr-xr-x  /usr/share/doc/httrack/templates
drwxr-xr-x  /usr/share/httrack
lrwxrwxrwx  /usr/share/httrack/html
drwxr-xr-x  /usr/share/httrack/lang
drwxr-xr-x  /usr/share/licenses/httrack


$ rpm -qlvp httrack-3.48.19-3.fc21.x86_64.rpm |grep -v ^-
lrwxrwxrwx    1 root    root                       20 Aug 17  2014 /usr/lib64/libhtsjava.so.2 -> libhtsjava.so.2.0.48
lrwxrwxrwx    1 root    root                       20 Aug 17  2014 /usr/lib64/libhttrack.so.2 -> libhttrack.so.2.0.48
drwxr-xr-x    2 root    root                        0 Aug 17  2014 /usr/share/doc/httrack
lrwxrwxrwx    1 root    root                       22 Aug 17  2014 /usr/share/doc/httrack/html -> /usr/share/doc/httrack
drwxr-xr-x    2 root    root                        0 Aug 17  2014 /usr/share/doc/httrack/templates
drwxr-xr-x    2 root    root                        0 Aug 17  2014 /usr/share/httrack
lrwxrwxrwx    1 root    root                       22 Aug 17  2014 /usr/share/httrack/html -> /usr/share/doc/httrack
drwxr-xr-x    2 root    root                        0 Aug 17  2014 /usr/share/httrack/lang

$ rpm -qlvp httrack-3.48.20-1.fc21.x86_64.rpm |grep -v ^-
lrwxrwxrwx    1 root    root                       20 Feb 27 10:55 /usr/lib64/libhtsjava.so.2 -> libhtsjava.so.2.0.48
lrwxrwxrwx    1 root    root                       20 Feb 27 10:55 /usr/lib64/libhttrack.so.2 -> libhttrack.so.2.0.48
drwxr-xr-x    2 root    root                        0 Feb 27 10:55 /usr/share/doc/httrack
drwxr-xr-x    2 root    root                        0 Feb 27 10:55 /usr/share/doc/httrack/html
drwxr-xr-x    2 root    root                        0 Feb 27 10:55 /usr/share/doc/httrack/html/div
drwxr-xr-x    2 root    root                        0 Feb 27 10:55 /usr/share/doc/httrack/html/images
drwxr-xr-x    2 root    root                        0 Feb 27 10:55 /usr/share/doc/httrack/html/img
drwxr-xr-x    2 root    root                        0 Feb 27 10:55 /usr/share/doc/httrack/html/server
drwxr-xr-x    2 root    root                        0 Feb 27 10:55 /usr/share/doc/httrack/html/server/images
drwxr-xr-x    2 root    root                        0 Feb 27 10:55 /usr/share/doc/httrack/html/server/sfx
drwxr-xr-x    2 root    root                        0 Feb 27 10:55 /usr/share/doc/httrack/templates
drwxr-xr-x    2 root    root                        0 Feb 27 10:55 /usr/share/httrack
lrwxrwxrwx    1 root    root                       14 Feb 27 10:55 /usr/share/httrack/html -> ../doc/httrack
drwxr-xr-x    2 root    root                        0 Feb 27 10:55 /usr/share/httrack/lang
drwxr-xr-x    2 root    root                        0 Feb 27 10:55 /usr/share/licenses/httrack

Comment 62 Fedora Update System 2015-03-02 13:45:19 UTC
httrack-3.48.20-2.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/httrack-3.48.20-2.fc22

Comment 63 Fedora Update System 2015-03-02 13:45:26 UTC
httrack-3.48.20-2.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/httrack-3.48.20-2.fc21

Comment 64 Arnaud 2015-03-02 18:30:13 UTC
thanks, updating from httrack-3.48.19-3.fc21.x86_64 to httrack-3.48.20-2.fc21.x86_64 works now.

Comment 65 Christopher Meng 2015-03-03 00:14:22 UTC
Collecting feedback she from others, please test again if possible.

Comment 66 Fedora Update System 2015-03-05 12:35:47 UTC
httrack-3.48.20-2.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 67 Fedora Update System 2015-03-13 17:01:02 UTC
httrack-3.48.20-2.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 68 kalus.mario 2015-04-21 09:59:38 UTC
Another user experienced a similar problem:

STR:
1. Install Fedora from BFO
2. Change source repository: .../Server/... to .../Everything/...
3. Pick LXDE and Security (seems irrelevant to this case)

AR:
Insaller failed with unknown error (I am to lazy to read logs now)

ER:
Should be working properly.

Side note:
It was done in VMWare workstation

addons:         com_redhat_kdump
cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   repo=http://download.fedoraproject.org/pub/fedora/linux/releases/21/Server/x86_64/os/ initrd=http://download.fedoraproject.org/pub/fedora/linux/releases/21/Server/x86_64/os/images/pxeboot/initrd.img BOOT_IMAGE=http://download.fedoraproject.org/pub/fedora/linux/releases/21/Server/x86_64/os/images/pxeboot/vmlinuz 
hashmarkername: anaconda
kernel:         3.17.4-301.fc21.x86_64
package:        anaconda-21.48.21-1
product:        Fedora"
reason:         OSError: process '['/usr/libexec/anaconda/anaconda-yum', '--config', '/tmp/anaconda-yum.conf', '--tsfile', '/mnt/sysimage/anaconda-yum.yumtx', '--rpmlog', '/tmp/rpm-script.log', '--installroot', '/mnt/sysimage', '--release', '21', '--arch', 'x86_64', '--macro', '__dbi_htconfig', 'hash nofsync %{__dbi_other} %{__dbi_perms}', '--macro', '__file_context_path', '/etc/selinux/targeted/contexts/files/file_contexts']' was killed
release:        Cannot get release name.
version:        Fedora


Note You need to log in before you can comment on or make changes to this bug.