Bug 1130558 - repositories not available after they should be synced
Summary: repositories not available after they should be synced
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Transitions
Version: 6.0.4
Hardware: Unspecified
OS: Unspecified
unspecified
medium vote
Target Milestone: Unspecified
Assignee: Matej Kollar
QA Contact: Lukas Pramuk
URL:
Whiteboard:
Depends On:
Blocks: stargate-GA-tracker
TreeView+ depends on / blocked
 
Reported: 2014-08-15 14:22 UTC by Tomas Lestach
Modified: 2014-09-11 12:23 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-09-11 12:23:25 UTC


Attachments (Terms of Use)
whole command output (3.93 KB, text/plain)
2014-08-15 14:22 UTC, Tomas Lestach
no flags Details

Description Tomas Lestach 2014-08-15 14:22:23 UTC
Created attachment 927133 [details]
whole command output

Description of problem:


Version-Release number of selected component (if applicable):
Satellite-6.0.4-RHEL-6-20140813.2-Satellite-x86_64

Steps to Reproduce:
1. cd hammer-cli-import/tests
2. ./simple.sh --create

Actual results:
...
env RUBYOPT=-I../lib hammer import repository --csv-file=data/repositories.csv --synchronize --wait --verbose
Importing from data/repositories.csv
Creating new product: GALAXY.COM
Creating new repository: Tatooine
Registering tasks for uuids: ["fa3d64e5-0a6d-45aa-987e-9234c2f9f760"].
Starting thread for async tasks
Skipping Alderaan repository import, invalid source_url.
Creating new product: REDHAT.COM
Creating new repository: Spacewalk Client
Condition ["fa3d64e5-0a6d-45aa-987e-9234c2f9f760"] met
Asynchronous tasks: 1 of 1 done (~100.00%)
Registering tasks for uuids: ["fbca9a1f-cec9-4455-b8cf-2d8fdf61cda2"].
Product [100REDHAT.COM->4] already imported.
Creating new repository: Spacewalk 2.2 Client
Registering tasks for uuids: ["8c60cd9e-4923-4a05-bb35-8c857ed585b7"].
Asynchronous tasks: 1 of 3 done (~15.77%)
Asynchronous tasks: 1 of 3 done (~31.56%)
Asynchronous tasks: 1 of 3 done (~31.56%)
Asynchronous tasks: 1 of 3 done (~31.56%)
Asynchronous tasks: 1 of 3 done (~62.50%)
Asynchronous tasks: 1 of 3 done (~62.50%)
Asynchronous tasks: 1 of 3 done (~62.50%)
Asynchronous tasks: 1 of 3 done (~62.50%)
Asynchronous tasks: 1 of 3 done (~67.19%)
Asynchronous tasks: 1 of 3 done (~79.69%)
Condition ["fbca9a1f-cec9-4455-b8cf-2d8fdf61cda2"] met
Condition ["8c60cd9e-4923-4a05-bb35-8c857ed585b7"] met
Asynchronous tasks: 3 of 3 done (~100.00%)
Exiting thread (exit requested, all tasks done).
Summary
  Found 1 product.
  Skipped 1 repository.
  Created 3 repositories.
  Created 2 products.
env RUBYOPT=-I../lib hammer import content-view --csv-file=/tmp/tmp.LccdnP5ZPW/export.csv --synchronize --wait --verbose
Importing from /tmp/tmp.LccdnP5ZPW/export.csv
Repository Spacewalk_Client is not (fully) synchronized. Retry once synchronization has completed.
Repository Spacewalk_2_2_Client is not (fully) synchronized. Retry once synchronization has completed.
Summary
  Skipped 2 content_views.
...

Expected results:
When importing repositories with --synchronize --wait options, I expect the content views will be created immediately without messages to retry.

Additional info:
I did not see this with any older sat6 compose.
Whole log attached.

Comment 1 Tomas Lestach 2014-08-15 14:23:30 UTC
We need to investigate, whether it is transition tooling or sat6 issue.

Comment 3 Matej Kollar 2014-08-20 11:45:05 UTC
After some investigation, narrowed down problem to Bug 1131954.

Comment 4 Matej Kollar 2014-08-20 12:15:48 UTC
As a temporary workaround (till 1131954 gets fixed) I have changed behaviour so that we say that repo is synched whenever state == 'finished', regardless of 'updated_at' and 'last_sync'.

hammer-cli-import.git: 0aa9d7ac3c0dfc9d13b9e93852c47cf77efe051e

Comment 5 Grant Gainey 2014-08-21 17:47:29 UTC
Moving to POST to make sure this gets into GA release

Comment 6 Matej Kollar 2014-08-25 09:48:52 UTC
Why no longer depends on 1131954?

Comment 7 Grant Gainey 2014-08-25 19:19:36 UTC
Removed the depends-on because we have a workaround (as noted above) for import, and '1954 is not going to be addressed for GA.  If we want to Do Something when '1954 is fixed, we should prob create a new BZ, mark '1954 as blocking, and flag the new BZ as 6.1.0

Comment 9 Grant Gainey 2014-09-07 21:43:09 UTC
DEVELOPER VERIFIED:

===
(master) ~/hammer-cli-import/tests/data $ hammer import organization --csv-file ~/hammer-cli-import/tests/data/users.csv --verbose
Importing from /root/hammer-cli-import/tests/data/users.csv
Creating new organization: Galactic Empire
Summary
  Created 1 organization.
(master) ~/hammer-cli-import/tests/data $ hammer import repository  --csv-file ~/hammer-cli-import/tests/data/repositories.csv --verbose --synchronize --wait
Importing from /root/hammer-cli-import/tests/data/repositories.csv
Creating new product: GALAXY.COM
Creating new repository: Tatooine
Registering tasks for uuids: ["1047310a-226c-4239-b95b-093330ff9e3d"].
Starting thread for async tasks
Skipping Alderaan repository import, invalid source_url.
Creating new product: REDHAT.COM
Creating new repository: Spacewalk Client
Condition ["1047310a-226c-4239-b95b-093330ff9e3d"] met
Asynchronous tasks: 1 of 1 done (~100.00%)
Registering tasks for uuids: ["8aea8291-0aa5-4a8d-9af8-2d1d0e09d931"].
Product [100REDHAT.COM->2] already imported.
Creating new repository: Spacewalk 2.2 Client
Registering tasks for uuids: ["7bf8c88b-6f99-4368-a7f3-b374cc372d16"].
Asynchronous tasks: 1 of 3 done (~15.95%)
Asynchronous tasks: 1 of 3 done (~38.15%)
Asynchronous tasks: 1 of 3 done (~58.82%)
Asynchronous tasks: 1 of 3 done (~76.47%)
Condition ["8aea8291-0aa5-4a8d-9af8-2d1d0e09d931"] met
Asynchronous tasks: 2 of 3 done (~79.41%)
Asynchronous tasks: 2 of 3 done (~67.65%)
Condition ["7bf8c88b-6f99-4368-a7f3-b374cc372d16"] met
Asynchronous tasks: 3 of 3 done (~100.00%)
Exiting thread (exit requested, all tasks done).
Summary
  Found 1 product.
  Skipped 1 repository.
  Created 3 repositories.
  Created 2 products.
(master) ~/hammer-cli-import/tests/data $ hammer import content-view --csv-file ~/hammer-cli-import/tests/data/export.csv --synchronize --wait --verbose
Importing from /root/hammer-cli-import/tests/data/export.csv
Creating new content view: Spacewalk nightly client
Creating new content view: Spacewalk 2.2 client
Summary
  Created 2 content_views.
(master) ~/hammer-cli-import/tests/data $ rpm -q rubygem-hammer_cli_import
rubygem-hammer_cli_import-0.10.4-1.el6.noarch
(master) ~/hammer-cli-import/tests/data $
===

Comment 10 Bryan Kearney 2014-09-11 12:23:25 UTC
This was delivered with Satellite 6.0 which was released on 10 September 2014.


Note You need to log in before you can comment on or make changes to this bug.