Bug 1130579 - rhel-osp-installer fails due to DNS lookup failure during yum install
Summary: rhel-osp-installer fails due to DNS lookup failure during yum install
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Quickstart Cloud Installer
Classification: Red Hat
Component: Installation - RHELOSP
Version: 1.0
Hardware: Unspecified
OS: Linux
unspecified
high
Target Milestone: ---
: ---
Assignee: james labocki
QA Contact:
Dan Macpherson
URL:
Whiteboard:
Depends On:
Blocks: 1108193
TreeView+ depends on / blocked
 
Reported: 2014-08-15 15:10 UTC by Chris Dearborn
Modified: 2016-06-03 17:56 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-06-03 17:56:28 UTC


Attachments (Terms of Use)
Foreman installer log (70.35 KB, application/x-gzip)
2014-08-15 15:10 UTC, Chris Dearborn
no flags Details

Description Chris Dearborn 2014-08-15 15:10:41 UTC
Created attachment 927141 [details]
Foreman installer log

Description of problem:
When running rhel-osp-installer, the installation fails with:

Execution of '/usr/bin/yum -d 0 -e 0 -y install ruby193-rubygem-passenger-native'
returned 1: There was an error communicating with RHN.

At that point, I tried "nslookup <satellite_server_FQDN>", and it failed.
I then restarted the DNS client service with "service named restart".
I tried the nslookup again, and it worked.

To work around, I added an entry for the satellite server to the /etc/hosts file, and reran rhel-osp-installer, and it installed successfully.

Version-Release number of selected component (if applicable):
1.0

How reproducible:
Run rhel-osp-installer.

Steps to Reproduce:
See above.

Actual results:
rhel-osp-installer fails

Expected results:
rhel-osp-installer should successfully install OSP

Additional info:
See attached for /var/log/foreman-installer/foreman-installer.log

Comment 1 Chris Dearborn 2014-08-18 12:43:21 UTC
Tried to reproduce this on 8/15/2014, with newer bits from the satellite server, and could not reproduce.  Not sure if this is worth spending time on at this point.

Comment 2 John Matthews 2016-06-03 17:56:28 UTC
Closing as this BZ does not reflect components in the Quickstart Cloud Installer.
Please reopen if you feel this was closed in error.


Note You need to log in before you can comment on or make changes to this bug.