Bug 1130590 - Products created through the API do not show up at /products in the webui
Summary: Products created through the API do not show up at /products in the webui
Keywords:
Status: CLOSED DUPLICATE of bug 1131524
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: WebUI
Version: 6.0.4
Hardware: Unspecified
OS: Unspecified
unspecified
high vote
Target Milestone: Unspecified
Assignee: Katello Bug Bin
QA Contact: Katello QA List
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-15 15:32 UTC by Grant Gainey
Modified: 2017-02-23 21:05 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-19 15:01:16 UTC


Attachments (Terms of Use)

Description Grant Gainey 2014-08-15 15:32:15 UTC
Description of problem:

hammer-cli-import creates Products for matching Sat5 channels and config-channels. When we do so, the new products no longer show up in the list at /products for a (or any) selected Organization.

Version-Release number of selected component (if applicable):

6.0.4 Snap6

How reproducible:

Create a Product using 'hammer product create' (or any other API-creation-method, like 'hammer import repository' or 'hammer import config-file')

Steps to Reproduce:
1. hammer> product create --name "hammer-created-product" --label "hammer-created-product"  --organization <org-on-your-system>
2. https://<your-sat6-machine/products
3. Choose <org-on-your-system>

Actual results:

"hammer-created-product" does not appear in the list

Expected results:

It does appear in the list

Additional info:

This worked until today - I just updated my Sat6 system to latest-code.

Task-list shows create succeeded:

{"product"=>
  {"id"=>194,
   "name"=>"hammer-created-product",
   "label"=>"hammer-created-product",
   "cp_id"=>nil},
 "provider"=>{"id"=>5, "name"=>"Anonymous"},
 "organization"=>{"id"=>4, "name"=>"SOE-ORG", "label"=>"SOE-ORG"},
 "cp_id"=>"1408130082631",
 "locale"=>"en"}

Going to the created-id in the UI, works 

https://beast-sat6.usersys.redhat.com/products/194/info

Comment 1 RHEL Product and Program Management 2014-08-15 15:43:11 UTC
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 3 Grant Gainey 2014-08-15 15:46:31 UTC
This is a blocker for the transition-tooling - it menas you never see the newly-created products for Sat5 custom/cloned channels or config-channels.

Comment 4 Grant Gainey 2014-08-15 19:05:56 UTC
Additional weirdness, ending in success:

* katello-service stop; katello-service start => *NO* products showing in list anywhere

* curl http://localhost:9200/_cluster/health?pretty=true => "status" : "red"

* Issued the following:

===
# service elasticsearch stop
# rm -rf /var/lib/elasticsearch/elasticsearch/nodes/*
# service elasticsearch start
# foreman-rake katello:reindex
===

'products' page is happy again.

Having a workaround removes this as a blocker for transition - but, ow.

Comment 5 Grant Gainey 2014-08-15 19:31:28 UTC
One last debugging-note: 

Prior to this weirdness, I did 

# katello-installer --foreman-admin-username admin --foreman-admin-password changeme --reset" 

on the machine.

NOTE: usually I only do a --reset after a katello-service stop.  Looking at my command-history, in this instance --reset was issued with Sat6 still running.  No idea if that has anything to do with the results, just offering it as a datapoint.

Comment 6 Justin Sherrill 2014-08-19 15:01:16 UTC
We're pretty sure this was caused by https://bugzilla.redhat.com/show_bug.cgi?id=1131524

Closing as a dup for now

*** This bug has been marked as a duplicate of bug 1131524 ***


Note You need to log in before you can comment on or make changes to this bug.