Bug 1130611 - Non-fatal POSTIN scriptlet failure in rpm package katello-agent-1.5.3-4.el5sat.noarch
Summary: Non-fatal POSTIN scriptlet failure in rpm package katello-agent-1.5.3-4.el5sa...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Content Management
Version: 6.0.4
Hardware: Unspecified
OS: Unspecified
unspecified
low vote
Target Milestone: Unspecified
Assignee: Stephen Benjamin
QA Contact: Chris Duryee
URL: http://projects.theforeman.org/issues...
Whiteboard:
: 1133062 1235327 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-15 16:23 UTC by Og Maciel
Modified: 2019-04-01 20:27 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-27 11:15:34 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Foreman Issue Tracker 14054 None None None 2016-04-22 14:57:25 UTC

Description Og Maciel 2014-08-15 16:23:00 UTC
Description of problem:

While provisioning a RHEL 5Server x86_64 host I noticed the following error message show up while installing katello-agent:

Non-fatal POSTIN scriptlet failure in rpm package katello-agent-1.5.3-4.el5sat.noarch

Once the system was rebooted I was able to successfully use the web ui to install packages so I believe this is non-fatal but am filing it anyhow.

Attached you will find the install.post.log and /var/log/messages files.

Version-Release number of selected component (if applicable):

Build:
------
* Satellite-6.0.4-RHEL-6-20140813.2

Packages:
---------
* candlepin-0.9.23-1.el7.noarch
* candlepin-common-1.0.1-1.el7.noarch
* candlepin-guice-3.0-2_redhat_1.el7.noarch
* candlepin-scl-1-5.el7.noarch
* candlepin-scl-quartz-2.1.5-6.el7.noarch
* candlepin-scl-rhino-1.7R3-3.el7.noarch
* candlepin-scl-runtime-1-5.el7.noarch
* candlepin-selinux-0.9.23-1.el7.noarch
* candlepin-tomcat-0.9.23-1.el7.noarch
* elasticsearch-0.90.10-4.el7sat.noarch
* foreman-1.6.0.40-1.el7sat.noarch
* foreman-compute-1.6.0.40-1.el7sat.noarch
* foreman-gce-1.6.0.40-1.el7sat.noarch
* foreman-libvirt-1.6.0.40-1.el7sat.noarch
* foreman-ovirt-1.6.0.40-1.el7sat.noarch
* foreman-postgresql-1.6.0.40-1.el7sat.noarch
* foreman-proxy-1.6.0.27-1.el7sat.noarch
* foreman-selinux-1.6.0.6-1.el7sat.noarch
* foreman-vmware-1.6.0.40-1.el7sat.noarch
* katello-1.5.0-28.el7sat.noarch
* katello-ca-1.0-1.noarch
* katello-certs-tools-1.5.6-1.el7sat.noarch
* katello-installer-0.0.59-1.el7sat.noarch
* openldap-2.4.39-3.el7.x86_64
* pulp-katello-0.3-3.el7sat.noarch
* pulp-nodes-common-2.4.0-0.30.beta.el7sat.noarch
* pulp-nodes-parent-2.4.0-0.30.beta.el7sat.noarch
* pulp-puppet-plugins-2.4.0-0.30.beta.el7sat.noarch
* pulp-puppet-tools-2.4.0-0.30.beta.el7sat.noarch
* pulp-rpm-plugins-2.4.0-0.30.beta.el7sat.noarch
* pulp-selinux-2.4.0-0.30.beta.el7sat.noarch
* pulp-server-2.4.0-0.30.beta.el7sat.noarch
* python-ldap-2.4.6-6.el7.x86_64
* ruby193-rubygem-net-ldap-0.3.1-3.el7sat.noarch
* ruby193-rubygem-runcible-1.1.0-2.el7sat.noarch
* rubygem-hammer_cli-0.1.1-11.el7sat.noarch
* rubygem-hammer_cli_foreman-0.1.1-15.el7sat.noarch
* rubygem-hammer_cli_foreman_tasks-0.0.3-3.el7sat.noarch
* rubygem-hammer_cli_katello-0.0.4-12.el7sat.noarch

How reproducible:


Steps to Reproduce:
1. Install the katello-agent onto a RHEL 5Server x86_64 via Satellite 6 provisioning method
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 RHEL Product and Program Management 2014-08-15 16:23:04 UTC
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 5 Bryan Kearney 2015-08-07 15:20:42 UTC
*** Bug 1235327 has been marked as a duplicate of this bug. ***

Comment 6 Stephen Benjamin 2016-03-04 15:57:51 UTC
Created redmine issue http://projects.theforeman.org/issues/14054 from this bug

Comment 7 Bryan Kearney 2016-03-04 17:04:00 UTC
Upstream bug component is Content Management

Comment 8 Bryan Kearney 2016-03-14 18:04:06 UTC
Moving to POST since upstream bug http://projects.theforeman.org/issues/14054 has been closed
-------------
Anonymous
Applied in changeset commit:katello-packaging|bc07eccfc87368a889699ed81fd22be5ac505949.

Comment 9 Justin Sherrill 2016-03-16 19:02:29 UTC
*** Bug 1133062 has been marked as a duplicate of this bug. ***

Comment 10 Chris Duryee 2016-07-07 20:10:26 UTC
verified on snap 19, katello-agent-2.5.0-5.el5.noarch.rpm

test:

 * install katello-agent, no errors appear during %post even though I intentionally set up gofer incorrectly
 * uninstall, confirm no errors during %postun

additional test: I broke the init.d script to ensure it outputs stuff, then installed/uninstalled. Still no errors from %post or %postun.

moving to VERIFIED.

Comment 11 Bryan Kearney 2016-07-27 11:15:34 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1501


Note You need to log in before you can comment on or make changes to this bug.