Bug 1130625 - RHEL7 Network Manager IPV6 Disabled with Solarflare Network Card
Summary: RHEL7 Network Manager IPV6 Disabled with Solarflare Network Card
Keywords:
Status: CLOSED DUPLICATE of bug 1098319
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: NetworkManager
Version: 7.0
Hardware: x86_64
OS: Linux
unspecified
low
Target Milestone: rc
: ---
Assignee: Rashid Khan
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-15 17:09 UTC by Peter Dunning
Modified: 2014-09-05 03:06 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-09-05 03:05:30 UTC


Attachments (Terms of Use)

Description Peter Dunning 2014-08-15 17:09:43 UTC
Description of problem:
We have a script to boot RHEL7 and set up Solarflare network drivers on it, write ifcfg files for Solarflare interfaces, set NM_CONTROLLED="no" and assign IP addresses to them. At some point in this process /proc/sys/net/ipv6/conf/<interface>/disable_ipv6 is set to 1. This causes a problem when an IPv6 address is asigned. Our solution is to change it just before the address is assigned. diable_ipv6 is not changed if Network Manager is disabled. This is only a problem on RHEL7, not RHEL6.5 or less.

Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
1. Boot fresh install of RHEL7
2. Set up Solarflare network drivers using script
3. 

Actual results:
Script fails to assign IPv6 address so stops

Expected results:
Script assigns IPv6 address and network interface works.

Additional info:

Comment 2 Dan Williams 2014-09-05 03:05:30 UTC
It sounds like NM is not correctly ignoring the interfaces actually.  But in the end, the disable_ipv6 issue actually already has a fix in the works, so I'm going to dupe this bug to that one.  Apologies if you're not able to see the bug due to permissions...

If you'd like to test out the fix, you can grab the RPMs from here:

http://people.redhat.com/dcbw/NetworkManager/rh1083133/

You'll need at least:

NetworkManager-0.9.9.1-29.git20140326.4dba720.el7.4.x86_64.rpm
kernel-3.10.0-145.el7.x86_64.rpm
libnl3-3.2.21-7.el7.x86_64.rpm

*** This bug has been marked as a duplicate of bug 1098319 ***

Comment 3 Dan Williams 2014-09-05 03:06:21 UTC
(and yeah, I know the bug in the URL is different that the duped bug, but that other bug is also actually the same bug...)


Note You need to log in before you can comment on or make changes to this bug.