Bug 1130663 - Installer: Inconsistent requirements in installer vs add-user.sh
Summary: Installer: Inconsistent requirements in installer vs add-user.sh
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss Data Virtualization 6
Classification: JBoss
Component: Installer
Version: 6.1.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ER2
: 6.1.0
Assignee: Thomas Hauser
QA Contact: Len DiMaggio
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-15 20:50 UTC by Thomas Hauser
Modified: 2016-02-10 08:55 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
The installer has been made more consistent with JBoss EAP's add-user.sh script. This means speacial characters are now allowed in user names.
Clone Of:
Environment:
Last Closed: 2016-02-10 08:55:38 UTC
Type: Bug


Attachments (Terms of Use)

Description Thomas Hauser 2014-08-15 20:50:51 UTC
Description of problem:
The add-user.sh script has been updated in EAP. The installer validation is no longer consistent with the restrictions of add-user.sh.

In particular, the add-user.sh allows the following special characters in the username: , . / = @ \ 

While the installer does not. 

After this inconsistency is fixed, a new check to ensure that the username != password must be introduced.


How reproducible:
Always


Steps to Reproduce:
1. Attempt to create a user named hi@hi

Actual results:
Installation cannot continue with such a user name.

Expected results:
Installation proceeds.

Comment 2 Ahmed Abu Lawi 2014-08-20 21:00:01 UTC
I modified the regular expression to allow the new characters, , . / = @ \. Previously the regular expression validator was allowing usernames to contain '_', as well but this has since been changed.

In addition a new validator is used to prevent the password and username from matching.


Note You need to log in before you can comment on or make changes to this bug.