Bug 113069 - cannot allocate partition to fill disk from disk druid
cannot allocate partition to fill disk from disk druid
Status: CLOSED RAWHIDE
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: anaconda (Show other bugs)
2.1
ia64 Linux
low Severity low
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-01-07 18:34 EST by Tim Chambers
Modified: 2007-11-30 17:06 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-24 14:10:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tim Chambers 2004-01-07 18:34:59 EST
Description of problem:
I'm installing on an Everest from CD via console GUI. I tried to
create a partition by highlighting the Free space on the disk and
clicking Edit. I get the Add Partition dialog. The numbers look fine
by default. I choose /xtra as the Mount Point. When I click OK I get
Error Partitioning: "Could not allocate requested partitions: Unable
to create partition which extends beyond the end of the disk.. [sic]"

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. install from CD via console GUI
2. select auto partition to /dev/sda (I have a 34,733 Mb disk)
3. edit the root partition to be 8000 Mb
4. highlight Free space, noting its size, start and end cylinders (my
size was 16439)
5. click Edit
6. in the Add Partition dialog, choose mount point /xtra, note that
the start and end cylinders (mine are 18295 and 34733) by default are
ok and that the size is 1 Mb less than the free size (mine says 16438)
7. click OK and note the error
8. note that clicking the down arrow once on End Cylinder results in a
decrease of 2 cylinders (mine says 34731)
9. click OK and note that the partition is created with 2 Mb free


Actual Results:  see above

Expected Results:  1. defaults should work (maybe that means the
defaults should be set differently -- I don't know what you want)
2. clicking down arrow once should only decrement the End Cylinder by
1, not 2


Additional info:
found on machine named haiti
Comment 1 Tim Chambers 2004-01-07 18:47:44 EST
Here's more detail on my disk configuration. Results are weirder than
I thought.

Immediately after disk auto partition:
/dev/sda3 swap 2000 1 2001
Free Free space 6193 2001 8194
/dev/sda2 /boot/efi vfat 101 8194 8295
/dev/sda1 / ext3 26439 8295 34733

After resizing /:
Free Free space 8193 1 8194
/dev/sda2 /boot/efi vfat 101 8194 8295
/dev/sda1 / ext3 8000 8295 16295
/dev/sda3 swap 2000 16295 18295
Free Free space 16439 18295 34733

After creating /xtra:
/dev/sda4 swap 2000 1 2001
Free Free space 6193 2001 8194
/dev/sda2 /boot/efi vfat 101 8194 8295
/dev/sda3 / ext3 8000 8295 16295
Free Free space 2000 16295 18294
/dev/sda1 /xtra ext3 16437 18295 34731
Free Free space 2 34732 34733

So maybe you'll just tell me not to edit free space. When I tried New
instead of Edit with / sized to 8000 I got exactly what I expected:
Free Free space 8193 1 8194
/dev/sda2 /boot/efi vfat 101 8194 8295
/dev/sda1 / ext3 8000 8295 16295
/dev/sda3 swap 2000 16295 18295
/dev/sda4 /xtra ext3 16439 18295 34733

If you want to go that way, then it doesn't seem to me that Disk Druid
should allow me to edit free space.
Comment 2 Jeremy Katz 2004-02-12 16:32:53 EST
New is always the preferred way.  Editing free space is only there for
people who have far too much interesting in micro managing their
partition layout :-)

This has been this way forever (and is caused by parted's handling of
adding partitions extending to the last cylinder of the disk).  On the
"to fix at some point" list, but not a high priority, especially with
the easy workarounds.
Comment 3 Jeremy Katz 2004-12-01 10:02:31 EST
This should be fixed in RHEL4.
Comment 4 Jeremy Katz 2006-04-24 14:10:44 EDT
Mass-closing lots of old bugs which are in MODIFIED (and thus presumed to be
fixed).  If any of these are still a problem, please reopen or file a new bug
against the release which they're occurring in so they can be properly tracked.

Note You need to log in before you can comment on or make changes to this bug.