Bug 1130721 - [abrt] yum: visit_decref(): python2.7 killed by SIGSEGV
Summary: [abrt] yum: visit_decref(): python2.7 killed by SIGSEGV
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: yum
Version: 20
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Packaging Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:2b5c84996e0c0b16c981e02b14b...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-17 00:39 UTC by Jim
Modified: 2014-10-06 13:14 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-10-06 13:14:09 UTC


Attachments (Terms of Use)
File: backtrace (49.43 KB, text/plain)
2014-08-17 00:39 UTC, Jim
no flags Details
File: cgroup (180 bytes, text/plain)
2014-08-17 00:39 UTC, Jim
no flags Details
File: core_backtrace (13.46 KB, text/plain)
2014-08-17 00:39 UTC, Jim
no flags Details
File: dso_list (9.95 KB, text/plain)
2014-08-17 00:39 UTC, Jim
no flags Details
File: environ (4.76 KB, text/plain)
2014-08-17 00:39 UTC, Jim
no flags Details
File: limits (1.29 KB, text/plain)
2014-08-17 00:39 UTC, Jim
no flags Details
File: maps (44.66 KB, text/plain)
2014-08-17 00:39 UTC, Jim
no flags Details
File: open_fds (2.49 KB, text/plain)
2014-08-17 00:39 UTC, Jim
no flags Details
File: proc_pid_status (910 bytes, text/plain)
2014-08-17 00:39 UTC, Jim
no flags Details
File: var_log_messages (549 bytes, text/plain)
2014-08-17 00:39 UTC, Jim
no flags Details

Description Jim 2014-08-17 00:39:32 UTC
Version-Release number of selected component:
yum-3.4.3-152.fc20

Additional info:
reporter:       libreport-2.2.3
backtrace_rating: 4
cmdline:        /usr/bin/python /usr/bin/yum update
crash_function: visit_decref
executable:     /usr/bin/python2.7
kernel:         3.15.8-200.fc20.x86_64
runlevel:       N 5
type:           CCpp
uid:            0

Truncated backtrace:
Thread no. 1 (10 frames)
 #0 visit_decref at /usr/src/debug/Python-2.7.5/Modules/gcmodule.c:429
 #1 tupletraverse at /usr/src/debug/Python-2.7.5/Objects/tupleobject.c:580
 #2 subtract_refs at /usr/src/debug/Python-2.7.5/Modules/gcmodule.c:456
 #3 collect at /usr/src/debug/Python-2.7.5/Modules/gcmodule.c:999
 #4 collect_generations at /usr/src/debug/Python-2.7.5/Modules/gcmodule.c:1124
 #5 _PyObject_GC_Malloc at /usr/src/debug/Python-2.7.5/Modules/gcmodule.c:1585
 #6 _PyObject_GC_New at /usr/src/debug/Python-2.7.5/Modules/gcmodule.c:1595
 #7 dictiter_new at /usr/src/debug/Python-2.7.5/Objects/dictobject.c:2481
 #8 call_function at /usr/src/debug/Python-2.7.5/Python/ceval.c:4082
 #9 PyEval_EvalFrameEx at /usr/src/debug/Python-2.7.5/Python/ceval.c:2740

Comment 1 Jim 2014-08-17 00:39:35 UTC
Created attachment 927390 [details]
File: backtrace

Comment 2 Jim 2014-08-17 00:39:36 UTC
Created attachment 927391 [details]
File: cgroup

Comment 3 Jim 2014-08-17 00:39:37 UTC
Created attachment 927392 [details]
File: core_backtrace

Comment 4 Jim 2014-08-17 00:39:39 UTC
Created attachment 927393 [details]
File: dso_list

Comment 5 Jim 2014-08-17 00:39:40 UTC
Created attachment 927394 [details]
File: environ

Comment 6 Jim 2014-08-17 00:39:41 UTC
Created attachment 927395 [details]
File: limits

Comment 7 Jim 2014-08-17 00:39:42 UTC
Created attachment 927396 [details]
File: maps

Comment 8 Jim 2014-08-17 00:39:44 UTC
Created attachment 927397 [details]
File: open_fds

Comment 9 Jim 2014-08-17 00:39:45 UTC
Created attachment 927398 [details]
File: proc_pid_status

Comment 10 Jim 2014-08-17 00:39:46 UTC
Created attachment 927399 [details]
File: var_log_messages

Comment 11 Valentina Mukhamedzhanova 2014-10-06 13:14:09 UTC
This is not a bug in yum.


Note You need to log in before you can comment on or make changes to this bug.