Bug 1130800 - Broken symlink to /usr/share/javazi-1.8/tzdb.dat
Summary: Broken symlink to /usr/share/javazi-1.8/tzdb.dat
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: java-1.8.0-openjdk
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: jiri vanek
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-17 21:24 UTC by Richard W.M. Jones
Modified: 2014-09-04 19:21 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-09-02 06:35:20 UTC


Attachments (Terms of Use)

Description Richard W.M. Jones 2014-08-17 21:24:10 UTC
Description of problem:

Upgrading openjdk 1.7 -> 1.8 leaves a broken symlink:

$ ll /usr/lib/jvm/java-1.8.0-openjdk-1.8.0.11-15.b12.fc22.x86_64/jre/lib/tzdb.dat
lrwxrwxrwx. 1 root root 30 Aug 17 22:12 /usr/lib/jvm/java-1.8.0-openjdk-1.8.0.11-15.b12.fc22.x86_64/jre/lib/tzdb.dat -> /usr/share/javazi-1.8/tzdb.dat

The target file (/usr/share/javazi-1.8/tzdb.dat) does not exist.

You have to manually install tzdata-java in order to get this file.

This suggests that openjdk needs a versioned Requires, something like:

Requires: tzdata-java >= 2014f-1

or perhaps more directly:

Requires: /usr/share/javazi-1.8/tzdb.dat

Version-Release number of selected component (if applicable):

java-1.8.0-openjdk-1.8.0.11-15.b12.fc22.x86_64

How reproducible:

100%

Steps to Reproduce:
1. Have openjdk 1.7 installed.
2. Upgrade using yum to 1.8.

Comment 1 Richard W.M. Jones 2014-08-17 21:25:47 UTC
(In reply to Richard W.M. Jones from comment #0)
> Description of problem:
[...]
> You have to manually install tzdata-java in order to get this file.

I mean, of course, manually *upgrade*.

tzdata-java is already installed and satisfies the dependency,
but because it's the old version it doesn't have this file.

Comment 2 jiri vanek 2014-08-18 10:58:35 UTC
Ok that gave sense.

Comment 3 jiri vanek 2014-08-19 12:19:36 UTC
just note - this adds circular dependence on 
 jdk requires tzdata-java and vice versa.

Comment 4 Richard W.M. Jones 2014-08-19 12:49:25 UTC
(In reply to jiri vanek from comment #3)
> just note - this adds circular dependence on 
>  jdk requires tzdata-java and vice versa.

I'm pretty sure this is fine.  It just means that jdk &
tzdata-java cannot be installed without each other.  yum will
do the right thing.

Comment 5 Orion Poplawski 2014-08-29 15:08:09 UTC
Please use:

Requires: tzdata-java >= 2014f-1

as the file dependency forces a download of the very large filelists metadata.

Comment 6 jiri vanek 2014-09-02 06:35:20 UTC
pushed to f21 and f22.

Comment 7 Richard W.M. Jones 2014-09-04 19:21:23 UTC
Possibly broken in RHEL 7 too:
https://bugzilla.redhat.com/show_bug.cgi?id=1138436


Note You need to log in before you can comment on or make changes to this bug.