Bug 1130862 - java-1.8.0-openjdk-headless: alternatives refer to incorrect symlink
Summary: java-1.8.0-openjdk-headless: alternatives refer to incorrect symlink
Keywords:
Status: CLOSED DUPLICATE of bug 1130247
Alias: None
Product: Fedora
Classification: Fedora
Component: java-1.8.0-openjdk
Version: 21
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Deepak Bhole
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-18 05:06 UTC by Michel Alexandre Salim
Modified: 2014-08-18 10:59 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-18 10:59:00 UTC


Attachments (Terms of Use)

Description Michel Alexandre Salim 2014-08-18 05:06:07 UTC
Description of problem:
The alternatives link installed by java-1.8.0-openjdk-headless point to /usr/lib/jvm/jre-1.8.0-openjdk.x86_64, but only /usr/lib/jvm/jre-1.8.0-openjdk (without .x86_64 suffix) is present.

Creating that directory by hand resolves the problem of /etc/alternatives/java not resolving to an existing file.

Also, no package owns /usr/lib/jvm/jre-1.8.0-openjdk and /usr/lib/jvm/jre-1.8.0-openjdk

Version-Release number of selected component (if applicable):
java-1.8.0-openjdk-headless-1.8.0.11-15.b12.fc21.x86_64

How reproducible:
Always

Steps to Reproduce:
1. rpm -e --nodeps java-1.8.0-openjdk-headless
2. yum install java-1.8.0-openjdk-headless
3. alternatives --list | grep jre_1.8.0
4. ls -l /usr/lib/jvm | grep jre-1.8.0

Actual results:
Alternatives output:
jre_1.8.0_openjdk	auto	/usr/lib/jvm/jre-1.8.0-openjdk-1.8.0.11-15.b12.fc21.x86_64
jre_1.8.0	auto	/usr/lib/jvm/jre-1.8.0-openjdk.x86_64

but only /usr/lib/jvm/jre-1.8.0-openjdk and /usr/lib/jvm/jre-1.8.0-openjdk-1.8.0.11-15.b12.fc21.x86_64 exist

Expected results:
There shouldn't be a mismatch. Also, note that the openjdk link doesn't have an arch suffix.

Additional info:

Comment 1 jiri vanek 2014-08-18 10:59:00 UTC

*** This bug has been marked as a duplicate of bug 1130247 ***


Note You need to log in before you can comment on or make changes to this bug.