Bug 1130866 (CVE-2014-5274) - CVE-2014-5274 phpMyAdmin: cross-site scripting flaw on view operations page (PMASA-2014-9)
Summary: CVE-2014-5274 phpMyAdmin: cross-site scripting flaw on view operations page (...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: CVE-2014-5274
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard: impact=moderate,public=20140806,repor...
Depends On: 1130867 1130868 1130876
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-18 05:58 UTC by Murray McAllister
Modified: 2019-06-08 20:09 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-11-19 07:00:45 UTC


Attachments (Terms of Use)

Description Murray McAllister 2014-08-18 05:58:22 UTC
A cross-site scripting flaw was found in phpMyAdmin's view operations page. This issue was fixed in versions 4.1.14.3 and 4.2.7.1. Individual patches are available from the original advisory:

http://www.phpmyadmin.net/home_page/security/PMASA-2014-9.php

Comment 1 Murray McAllister 2014-08-18 05:59:55 UTC
Created phpMyAdmin tracking bugs for this issue:

Affects: fedora-all [bug 1130867]
Affects: epel-7 [bug 1130868]

Comment 3 Murray McAllister 2014-08-18 06:09:10 UTC
I do not know if the older versions in EPEL 5 and 6 are affected.

Comment 4 Robert Scheck 2014-08-18 16:33:47 UTC
EPEL 6 should be not affected (not mentioned by upstream while done on the
other CVE).

Comment 5 Fedora Update System 2014-08-24 02:55:49 UTC
phpMyAdmin-4.2.7.1-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 6 Fedora Update System 2014-08-28 15:35:15 UTC
phpMyAdmin-4.2.7.1-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 7 Fedora Update System 2014-09-02 03:55:41 UTC
phpMyAdmin-4.0.10.2-1.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 8 Kurt Seifried 2014-11-19 07:00:45 UTC
OpenShift currently ships phpMyAdmin-4.0.10.5 which fixes PMASA-2014-12 and all earlier issues.

http://www.phpmyadmin.net/home_page/security/


Note You need to log in before you can comment on or make changes to this bug.