Bug 1130892 - Marking pending xattrs for new entry creations
Summary: Marking pending xattrs for new entry creations
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: replicate
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Anuradha
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 1141787
TreeView+ depends on / blocked
 
Reported: 2014-08-18 07:17 UTC by Anuradha
Modified: 2016-09-20 02:00 UTC (History)
3 users (show)

Fixed In Version: glusterfs-3.7.0
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1141787 (view as bug list)
Environment:
Last Closed: 2015-05-14 17:27:11 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Anuradha 2014-08-18 07:17:34 UTC
Description of problem:
Pending changelogs (xattrs) are not being set on lookup of new entry creations.

Version-Release number of selected component (if applicable):

How reproducible:
Often

Steps to Reproduce:
1. In a 1X2 replicate setup, create a dir tree like one/two/three
2. Simualate disk-replacement for one brick.
3. force start the volume
3. ls on "one", to trigger lookup

Actual results:
pending xattrs on dir "one" are not marked

Expected results:
pending xattrs on dir "one" should be marked leading to further self-heal of its children.

Additional info:

Comment 1 Anand Avati 2014-08-27 11:09:05 UTC
REVIEW: http://review.gluster.org/8555 (cluster/afr : Mark pending changelog xattrs for new creations) posted (#1) for review on master by Anuradha Talur (atalur@redhat.com)

Comment 2 Anand Avati 2014-09-01 13:51:08 UTC
REVIEW: http://review.gluster.org/8555 (cluster/afr : Mark pending changelog xattrs for new creations) posted (#2) for review on master by Anuradha Talur (atalur@redhat.com)

Comment 3 Anand Avati 2014-09-02 10:26:31 UTC
REVIEW: http://review.gluster.org/8555 (cluster/afr : Mark pending changelog xattrs for new creations) posted (#3) for review on master by Anuradha Talur (atalur@redhat.com)

Comment 4 Anand Avati 2014-09-02 13:12:24 UTC
REVIEW: http://review.gluster.org/8555 (cluster/afr : Mark pending changelog xattrs for new creations) posted (#4) for review on master by Anuradha Talur (atalur@redhat.com)

Comment 5 Anand Avati 2014-09-03 13:38:56 UTC
REVIEW: http://review.gluster.org/8555 (cluster/afr : Mark pending changelog xattrs for new creations) posted (#5) for review on master by Anuradha Talur (atalur@redhat.com)

Comment 6 Anand Avati 2014-09-03 13:40:49 UTC
REVIEW: http://review.gluster.org/8555 (cluster/afr : Mark pending changelog xattrs for new creations) posted (#6) for review on master by Anuradha Talur (atalur@redhat.com)

Comment 7 Anand Avati 2014-09-03 17:30:31 UTC
COMMIT: http://review.gluster.org/8555 committed in master by Pranith Kumar Karampuri (pkarampu@redhat.com) 
------
commit 6064c220844e8c4963e22ec48c8f7da9da57fc2f
Author: Anuradha <atalur@redhat.com>
Date:   Wed Sep 3 19:04:02 2014 +0530

    cluster/afr : Mark pending changelog xattrs for new creations
    
    Based on type of file, set appropriate pending changelogs
    for new entries.
    
    Change-Id: Ifd124bf9bc54b996ce83ab9f39d03b3ccca7eb3c
    BUG: 1130892
    Signed-off-by: Anuradha <atalur@redhat.com>
    Reviewed-on: http://review.gluster.org/8555
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Pranith Kumar Karampuri <pkarampu@redhat.com>
    Tested-by: Pranith Kumar Karampuri <pkarampu@redhat.com>

Comment 8 Niels de Vos 2015-05-14 17:27:11 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Comment 9 Niels de Vos 2015-05-14 17:35:32 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Comment 10 Niels de Vos 2015-05-14 17:37:54 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Comment 11 Niels de Vos 2015-05-14 17:43:18 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.