Bug 1130991 - [RFE][Disaster recovery] Import an export domain with dirty pool metadata to a different setup
Summary: [RFE][Disaster recovery] Import an export domain with dirty pool metadata to ...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: RFEs
Version: ---
Hardware: Unspecified
OS: Unspecified
unspecified
medium vote
Target Milestone: ---
: ---
Assignee: Maor
QA Contact: Raz Tamir
URL:
Whiteboard:
: 1129115 1183995 (view as bug list)
Depends On:
Blocks: 1004316
TreeView+ depends on / blocked
 
Reported: 2014-08-18 11:03 UTC by Ori Gofen
Modified: 2019-04-28 14:24 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-11-26 13:34:24 UTC
oVirt Team: Storage
ylavi: ovirt-future?
ylavi: planning_ack?
ylavi: devel_ack?
ylavi: testing_ack?


Attachments (Terms of Use)
vdsm+engine logs (1.03 MB, application/gzip)
2014-08-18 11:03 UTC, Ori Gofen
no flags Details

Description Ori Gofen 2014-08-18 11:03:48 UTC
Created attachment 927811 [details]
vdsm+engine logs

Description of problem:
When trying to recover a destroyed export domain via import domain feature to a different and initialized Setup,operation fails with a gui message: 
"Failed to attach Storage Domain exx to Data Center Default. (User: admin)"

engine errors:
2014-08-18 13:44:34,166 ERROR [org.ovirt.engine.core.vdsbroker.irsbroker.AttachStorageDomainVDSCommand] (ajp--127.0.0.1-8702-11) [750c2144] Command AttachStorageDomainVDSCommand( storagePoolId = 00000002-0002-0002-0002-0000000000da, ignoreFailoverLimit = false, storageDomainId = bd3ca6a3-e1bd-4932-80f6-4e69391380f5) execution failed. Exception: IrsOperationFailedNoFailoverException: IRSGenericException: IRSErrorException: Storage domain already attached to pool: u'domain=bd3ca6a3-e1bd-4932-80f6-4e69391380f5, pool=701cb545-625d-4444-a07f-8d020eee830b'
2014-08-18 13:44:34,176 INFO  [org.ovirt.engine.core.vdsbroker.irsbroker.AttachStorageDomainVDSCommand] (ajp--127.0.0.1-8702-11) [750c2144] FINISH, AttachStorageDomainVDSCommand, log id: 6562bf51
2014-08-18 13:44:34,180 ERROR [org.ovirt.engine.core.bll.storage.AttachStorageDomainToPoolCommand] (ajp--127.0.0.1-8702-11) [750c2144] Command org.ovirt.engine.core.bll.storage.AttachStorageDomainToPoolCommand throw Vdc Bll exception. With error message VdcBLLException: org.ovirt.engine.core.vdsbroker.irsbroker.IrsOperationFailedNoFailoverException: IRSGenericException: IRSErrorException: Storage domain already attached to pool: u'domain=bd3ca6a3-e1bd-4932-80f6-4e69391380f5, pool=701cb545-625d-4444-a07f-8d020eee830b' (Failed with error StorageDomainAlreadyAttached and code 380)
2014-08-18 13:44:34,194 INFO  [org.ovirt.engine.core.bll.storage.AttachStorageDomainToPoolCommand] (ajp--127.0.0.1-8702-11) [750c2144] Command [id=037f54fd-78f1-4a25-9e11-dac33c4232fd]: Compensating NEW_ENTITY_ID of org.ovirt.engine.core.common.businessentities.StoragePoolIsoMap; snapshot: storagePoolId = 00000002-0002-0002-0002-0000000000da, storageId = bd3ca6a3-e1bd-4932-80f6-4e69391380f5.
2014-08-18 13:44:34,209 ERROR [org.ovirt.engine.core.dal.dbbroker.auditloghandling.AuditLogDirector] (ajp--127.0.0.1-8702-11) [750c2144] Correlation ID: 750c2144, Job ID: 55e60555-f6ed-43a2-a2be-591861e2e993, Call Stack: null, Custom Event ID: -1, Message: Failed to attach Storage Domain exx to Data Center Default. (User: admin)
2014-08-18 13:45:07,961 INFO  [org.ovirt.engine.core.bll.OvfDataUpdater] (DefaultQuartzScheduler_Worker-64) Attempting to update VMs/Templates Ovf.
2014-08-18 13:46:07,982 INFO  [org.ovirt.engine.core.bll.OvfDataUpdater] (DefaultQuartzScheduler_Worker-6) Attempting to update VMs/Templates Ovf.
2014-08-18 13:47:08,004 INFO  [org.ovirt.engine.core.bll.OvfDataUpdater] (DefaultQuartzScheduler_Worker-14) Attempting to update VMs/Templates Ovf.
2014-08-18 13:47:34,727 INFO  [org.ovirt.engine.core.bll.storage.ForceRemoveStorageDomainCommand] (ajp--127.0.0.1-8702-9) [45207535] Lock Acquired to object EngineLock [exclusiveLocks= key: bd3ca6a3-e1bd-4932-80f6-4e69391380f5 value: STORAGE
, sharedLocks= ]

vdsm also throw an ERROR message and traceback:

Thread-46::ERROR::2014-08-18 13:44:35,117::task::866::Storage.TaskManager.Task::(_setError) Task=`6ef23e47-e45a-44c4-91e4-1f44236fab28`::Unexpected error
Traceback (most recent call last):
  File "/usr/share/vdsm/storage/task.py", line 873, in _run
    return fn(*args, **kargs)
  File "/usr/share/vdsm/logUtils.py", line 45, in wrapper
    res = f(*args, **kwargs)
  File "/usr/share/vdsm/storage/hsm.py", line 1193, in attachStorageDomain
    pool.attachSD(sdUUID)
  File "/usr/share/vdsm/storage/securable.py", line 77, in wrapper
    return method(self, *args, **kwargs)
  File "/usr/share/vdsm/storage/sp.py", line 913, in attachSD
    dom.attach(self.spUUID)
  File "/usr/share/vdsm/storage/sd.py", line 523, in attach
    raise se.StorageDomainAlreadyAttached(pools[0], self.sdUUID)
StorageDomainAlreadyAttached: Storage domain already attached to pool: u'domain=bd3ca6a3-e1bd-4932-80f6-4e69391380f5, pool=701cb545-625d-4444-a07f-8d020eee830b'
 


Version-Release number of selected component (if applicable):
rc1

How reproducible:
100%

Steps to Reproduce:
Setup:have two initialized Setups (setup_1,setup_2) and one export domain(state up) on setup_1

1.maintain the export domain,and destroy it
2.import the export domain to setup_2

Actual results:
operation fails

Expected results:
operation should be successful 

Additional info:

Comment 1 Maor 2014-09-03 15:15:19 UTC
Currently DR of export domain is not in the scope of Import Storage Domain feature.
Moving this to 3.6

Comment 2 Allon Mureinik 2014-09-07 14:50:01 UTC
*** Bug 1129115 has been marked as a duplicate of this bug. ***

Comment 4 Yaniv Lavi 2016-12-06 09:22:04 UTC
*** Bug 1183995 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.