Bug 1131018 - installed VM still booting from CD although first boot device is HDD
Summary: installed VM still booting from CD although first boot device is HDD
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: oVirt
Classification: Retired
Component: ovirt-engine-core
Version: 3.5
Hardware: x86_64
OS: Linux
unspecified
urgent
Target Milestone: ---
: 3.5.0
Assignee: Omer Frenkel
QA Contact: Petr Kubica
URL:
Whiteboard: virt
Depends On: 1149637
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-18 11:53 UTC by Netbulae
Modified: 2016-02-10 19:47 UTC (History)
7 users (show)

Fixed In Version: ovirt-3.5.0_rc2
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-10-17 12:35:21 UTC
oVirt Team: Virt


Attachments (Terms of Use)
screenhost boot options (42.54 KB, image/png)
2014-08-18 11:53 UTC, Netbulae
no flags Details


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 31723 master MERGED core: Add disk device after disk is added Never
oVirt gerrit 31867 ovirt-engine-3.5 MERGED core: Add disk device after disk is added Never

Description Netbulae 2014-08-18 11:53:19 UTC
Created attachment 927825 [details]
screenhost boot options

Description of problem:
Installing a VM with the Second Boot device CDROM. After installation, I choose reboot in the VM and the installer of the CDROM appears again even though I have the HDD as first boot device.

When I power down the VM, don't change anything, and power it up again. It does start from the local HDD

Comment 1 Omer Frenkel 2014-08-20 15:13:10 UTC
the issue is in add disk that cause the boot order to be wrong (order is calculated before the disk is added).

looks like this affects vms created from blank (or other diskless) template and the disk is added afterwards.

a workaround is to first create the vm and the disk,
and only after that, edit the vm and choose the wanted boot options, this will cause the boot order to be re-calculated, taking into account also the disk.

Comment 2 Petr Kubica 2014-10-16 10:59:00 UTC
Verified in 3.5.0.1-0.0.master.20141009085636.el6

Comment 3 Sandro Bonazzola 2014-10-17 12:35:21 UTC
oVirt 3.5 has been released and should include the fix for this issue.


Note You need to log in before you can comment on or make changes to this bug.