Bug 113104 - rc.sysinit does not clean /var/lock/samba properly
rc.sysinit does not clean /var/lock/samba properly
Status: CLOSED NEXTRELEASE
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: initscripts (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
: 97575 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-01-08 10:34 EST by Bernd Bartmann
Modified: 2014-03-16 22:41 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-03-16 21:49:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bernd Bartmann 2004-01-08 10:34:14 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1)
Gecko/20031114

Description of problem:
While booting my RHES3 system I saw a message on the console telling
something like:

cannot removed /var/lock/samba/printing because it's a directory.

/etc/rc.d/rc.sysinit cleans up the /var/lock/ directory structure
during the boot process. The problem is that it doesn't remove
subdirectories. It only removes files. So the contents of the dir
/var/lock/samba/printing is not removed.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. service smb start
2. reboot
3. watch at the boot messages
    

Additional info:
Comment 1 Bill Nottingham 2004-03-16 21:49:18 EST
Fixed in 7.47-1; will be in future RHEL releases.
Comment 2 Bill Nottingham 2005-09-30 15:02:17 EDT
*** Bug 97575 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.