Bug 1131095 - [RFE] Unable to sort tasks on state or result
Summary: [RFE] Unable to sort tasks on state or result
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Infrastructure
Version: 6.0.3
Hardware: Unspecified
OS: Unspecified
unspecified
high vote
Target Milestone: Unspecified
Assignee: Ondřej Pražák
QA Contact: Og Maciel
David O'Brien
URL:
Whiteboard:
Depends On:
Blocks: 1122832
TreeView+ depends on / blocked
 
Reported: 2014-08-18 13:04 UTC by Peter Vreman
Modified: 2019-06-13 21:25 UTC (History)
12 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-10-15 18:19:48 UTC
Target Upstream Version:


Attachments (Terms of Use)
Running tasks (95.81 KB, image/png)
2015-10-05 18:31 UTC, Og Maciel
no flags Details
Failed tasks (98.29 KB, image/png)
2015-10-05 18:32 UTC, Og Maciel
no flags Details
Custom bookmarked search (262.08 KB, image/png)
2015-10-05 18:34 UTC, Og Maciel
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:1911 0 normal SHIPPED_LIVE Satellite 6.1.3 bug fix update 2015-10-15 22:19:19 UTC

Description Peter Vreman 2014-08-18 13:04:20 UTC
Description of problem:
When there is a task that has paused in an error state it is hard to find. A manual search filter can be used. It would be quicker to sort the table on State or status. At the moment this is not possible, only on the Started At column.

Also an additional column Ended At in the table makes it better to spot overlapping tasks and to help with analysis.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:
Sorting is enabled on all columns
Ended At column is visible


Additional info:

Comment 1 RHEL Program Management 2014-08-18 13:13:16 UTC
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 5 Ivan Necas 2015-03-16 11:32:23 UTC
I don't think the sorting is the right answer for fixing the issue, but rather predefined filters on the state/result. The issue with sorting is, what sorting should be used (and the fact, that the paused is before running and stopped is just a happy coincidence, not talking about the situation, that one would use other locatization.

So, I'm suggesting to have the predefined filters there to filter the paused tasks and then combining with https://bugzilla.redhat.com/show_bug.cgi?id=1201660
to resume it.

Comment 6 Ivan Necas 2015-09-09 15:29:43 UTC
Proposed fix for adding bookmarks merged https://github.com/theforeman/foreman-tasks/pull/133

Comment 7 Peter Vreman 2015-09-10 08:34:03 UTC
I can confirm that filters on tasks work fine.
Additional i have a filter "Last 24h" to limit the output: 'started_at > "24 hours ago"'. Maybe that can be also be added to the default bookmarks.

Comment 8 Ondřej Pražák 2015-09-11 08:19:25 UTC
The PR has been already merged, please submit a feature request for any additional bookmarks.

Comment 11 Tazim Kolhar 2015-10-05 14:49:48 UTC
Hi,

   please provide verification steps
   thanks

Thanks and Regards,
Tazim

Comment 12 Peter Vreman 2015-10-05 14:58:37 UTC
1. Default Satellite installation
2. Start some background tasks, e.g. Repo Syncs
3. Goto Tasks
4a. Able to easily Filter Tasks on running tasks using a Bookmark
4b. Able to easily Filter Tasks on paused tasks using a Bookmark
4c. Able to easily Filter Tasks started in the last 24 hours using a Bookmark

Comment 13 Og Maciel 2015-10-05 18:31:27 UTC
Created attachment 1080019 [details]
Running tasks

Screenshot shows the bookmarked results for running tasks

Comment 14 Og Maciel 2015-10-05 18:32:27 UTC
Created attachment 1080020 [details]
Failed tasks

Screenshot shows the results from the Failed tasks bookmarked search

Comment 15 Og Maciel 2015-10-05 18:34:37 UTC
Created attachment 1080021 [details]
Custom bookmarked search

Screenshot shows the results from a custom bookmarked search returning state = stopped and result = success search

Comment 16 Og Maciel 2015-10-05 18:37:14 UTC
Verified on the latest Satellite-6.1.0-RHEL-7-20151002.0 compose

You can now use pre-defined bookmarked searches to find failed or running tasks, as well as create your own.

Comment 18 errata-xmlrpc 2015-10-15 18:19:48 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2015:1911


Note You need to log in before you can comment on or make changes to this bug.