Bug 113137 - up2date re-installs kernel already installed.
up2date re-installs kernel already installed.
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: up2date (Show other bugs)
3.0
i686 Linux
high Severity high
: ---
: ---
Assigned To: Adrian Likins
Fanny Augustin
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-01-08 15:41 EST by Joy Almacen
Modified: 2007-11-30 17:07 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-14 15:09:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joy Almacen 2004-01-08 15:41:59 EST
Description of problem:

up2date re-installs kernel already installed.


Version-Release number of selected component (if applicable):
4.0.1-1


How reproducible:

Everytime


Steps to Reproduce:
1.Install 3ES
2.Register server and run up2date -u
3.Install latest kernel-2.4.21-4.0.2.EL.i686.rpm  kernel-source-
2.4.21-4.0.2.EL.i386.rpm
4. Reboot and run up2date -u again.


  
Actual results:

[root@rh3es root]# up2date -u

Fetching package list for channel: rhel-i386-es-3...
########################################

Fetching Obsoletes list for channel: rhel-i386-es-3...

Fetching rpm headers...
########################################

Name                                    Version        Rel
----------------------------------------------------------
kernel                                  2.4.21         
4.0.2.EL            i686
kernel-source                           2.4.21         
4.0.2.EL            i386


Testing package set / solving RPM inter-dependencies...
########################################
RPM package conflict error.  The message was:
Test install failed because of package conflicts:
package kernel-source-2.4.21-4.0.2.EL is already installed
package kernel-2.4.21-4.0.2.EL is already installed



Expected results:

All packages should be updated, including the kernel.


Additional info:


root@rh3es root]# up2date --configure
0.  debug              No
1.  rhnuuid            4853ef7c-41eb-11d8-8578-d06b40fa4884
2.  isatty             Yes
3.  showAvailablePacka No
4.  networkSetup       Yes
5.  retrieveOnly       Yes
6.  enableRollbacks    Yes
7.  noSSLServerURL     http://xmlrpc.rhn.redhat.com/XMLRPC
8.  pkgSkipList        []
9.  storageDir         /var/spool/up2date
10. adminAddress       ['admin@edgeprojects.com']
11. noBootLoader       No
12. serverURL          https://xmlrpc.rhn.redhat.com/XMLRPC
13. fileSkipList       []
14. versionOverride
15. sslCACert          /usr/share/rhn/RHNS-CA-CERT
16. noReplaceConfig    Yes
17. useNoSSLForPackage No
18. systemIdPath       /etc/sysconfig/rhn/systemid
19. enableProxyAuth    No
20. retrieveSource     Yes
21. disallowConfChange 
['noReboot', 'sslCACert', 'useNoSSLForPackages', 'noSSLSe
22. headerFetchCount   10
23. networkRetries     5
24. pkgsToInstallNotUp ['kernel', 'kernel-modules']
25. enableProxy        No
26. proxyPassword
27. updateUp2date      Yes
28. keepAfterInstall   No
29. proxyUser
30. removeSkipList     ['kernel*']
31. useGPG             Yes
32. gpgKeyRing         /etc/sysconfig/rhn/up2date-keyring.gpg
33. httpProxy
34. headerCacheSize    40
35. forceInstall       No
36. noReboot           No
Comment 1 Joy Almacen 2004-01-15 12:08:12 EST
After days of waiting for RedHat to fix the kernel RPMS, I finally 
took upon myself to find a work-around. up2date wouldn't even proceed 
with other packages. It bombs out on the kernel RPMS. 

Hopefully, this weird re-install thing is limited only to kernel 
packages version kernel-2.4.21-4.0.2.EL.i686.rpm  kernel-source-
2.4.21-4.0.2.EL.i386.rpm.

The work-around is to do up2date --configure and then edit this line:

8.  pkgSkipList        ['kernel*']

Just skip the kernel and up2date will go on happily installing other 
packages.

I still don't know what's causing up2date to die on kernel upgrades :-
<





  

Note You need to log in before you can comment on or make changes to this bug.