Bug 113138 - Can't export file systems nfs mount on solarisI
Can't export file systems nfs mount on solarisI
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: nfs-utils (Show other bugs)
3.0
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Steve Dickson
Ben Levenson
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-01-08 15:46 EST by Need Real Name
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-19 15:31:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2004-01-08 15:46:16 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20031007

Description of problem:
I cannot seem to nfs mount filesystems from this machine on my solaris
5.8 machine.  I get the following error message:

  nfs mount: cvs.raddns.net: : RPC: Unable to receive
  nfs mount: retrying: /mnt/cvs/hdd1/release

After this happens, it seems that mountd has died because when I do:

  service nfs restart

it says "failed" when trying to stop mountd



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.export file systems from EI linux
2.attempt to mount on sunos
3.
    

Additional info:
Comment 1 Need Real Name 2004-01-08 16:38:49 EST
Turns out there was a bogus reverse map (ip->name) in dns for the
client.  Adding the correct mapping in the server's host file made
things work.  But mountd shouldn't die in this circumstance.
Comment 2 Suzanne Hillman 2004-01-09 16:19:08 EST
All it means when it fails to stop mountd is that it was not started;
not that the start failed. It may simply not have ever managed to
start. Closing, since you tracked down the problem.
Comment 3 Need Real Name 2004-01-23 12:05:57 EST
There really still is a problem.  After a client with a bogus reverse
IP map tries to mount a filesystem from the server, the server get
wedged and won't export to any client, even one with a valid
map/reverse map.
service nfs restart unwedges until the next such request.

1. NFS server should be able to survive even if it doesn't grant the
   remove mount request.

2. There should be a way to tell it to go ahead and grant such requests.
Comment 4 Red Hat Bugzilla 2007-02-05 13:58:24 EST
REOPENED status has been deprecated. ASSIGNED with keyword of Reopened is preferred.
Comment 5 RHEL Product and Program Management 2007-10-19 15:31:33 EDT
This bug is filed against RHEL 3, which is in maintenance phase.
During the maintenance phase, only security errata and select mission
critical bug fixes will be released for enterprise products. Since
this bug does not meet that criteria, it is now being closed.
 
For more information of the RHEL errata support policy, please visit:
http://www.redhat.com/security/updates/errata/
 
If you feel this bug is indeed mission critical, please contact your
support representative. You may be asked to provide detailed
information on how this bug is affecting you.

Note You need to log in before you can comment on or make changes to this bug.