Bug 113150 - mkfs.ext3 with -T largefile gets Floating point exception
mkfs.ext3 with -T largefile gets Floating point exception
Product: Fedora
Classification: Fedora
Component: e2fsprogs (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Florian La Roche
Depends On:
  Show dependency treegraph
Reported: 2004-01-08 17:13 EST by Gregory Gulik
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2004-01-12 08:01:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Gregory Gulik 2004-01-08 17:13:18 EST
Description of problem:

Attempting to create a file system on a large drive with a lrage block
size causes newfs.ext3 to fail with a Floating point exception.
I've tried both -T largefile4  and -T largefile and both result in the
failure.  It works fine if you leave off the -T option.

The drive in question is in a 200G drive in a USB 2.0 enclosure.
The same thing happens with a 250G drive in the same enclosure.

Version-Release number of selected component (if applicable):

mke2fs 1.34 (25-Jul-2003)

How reproducible:


Steps to Reproduce:
1. Attach drive to system.
2. Verify drive atatched with "fdisk -l /dev/sda"
3. Create file system "mkfs.ext3 -j -T largefile /dev/sda2"

Actual results:

[root@penguin greg]# mkfs.ext3 -j -m 0 -T largefile /dev/sda2
mke2fs 1.34 (25-Jul-2003)
Floating point exception

Expected results:

File system should be created without error.

Additional info:

System is a AMD Athlon XP 2500+ system, motherboard is ASUS A7V8X-X,
enclosure is an ADS USB 2.0/1394 device but only using USB 2.0 at this
time.  I've tried both built-in USB ports as well as with an extra
card.  Same results using both USB ports so it's unlikely to be a USB
problem.  In addition the file system works fine (for the most part)
if the -T largefile option is not used.
Comment 1 Florian La Roche 2004-01-09 02:12:17 EST
Can you please check if the current rpm from the development tree
is also causing the same problem:
http://download.fedora.redhat.com/*    fedora/development/SRPMS/e2fspro*

Thanks a lot for your report,

Florian La Roche
Comment 2 Florian La Roche 2004-01-12 08:01:42 EST
As confirmed in private email, the newest rpm is fixing this problem.

Florian La Roche

Note You need to log in before you can comment on or make changes to this bug.