Bug 113152 - RH-CFG-network cannot detect U.S. Robotics 56k Voice Faxmodem Pro in USB mode, does not set port speed
RH-CFG-network cannot detect U.S. Robotics 56k Voice Faxmodem Pro in USB mode...
Status: CLOSED INSUFFICIENT_DATA
Product: Fedora
Classification: Fedora
Component: system-config-network (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
David Lawrence
bzcl34nup
:
Depends On:
Blocks: rcn-modem
  Show dependency treegraph
 
Reported: 2004-01-08 17:49 EST by William M. Quarles
Modified: 2008-05-06 19:57 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-06 19:57:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description William M. Quarles 2004-01-08 17:49:25 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1)
Gecko/20031008

Description of problem:
This is a multi-problem report.  When referring to GUI elements in
RH-CFG-Network, I am mainly talking about the interface that comes up
the the "System Settings"/"Network" option.  

1. The program does not try to autodetect a modem when setting up new
hardware on the "Hardware" tab.

2. The program does try to autodetect a modem when setting up a new
"Device" when a modem has not been on the "Hardware" tab.

3. The title pane of the "Add New Device Type" wizard window reads
"Add New Device Type" the entire time.  The title page should change
after picking the type of connection that you want to add, but it
keeps saying "Add New Device Type" throughout the wizard.  If it is
going to stay the same, it should probably read "Add New Device"
instead of "Add New Device Type."

3. "Devices" is a really confusing name for this tab, because the name
implies basically the same thing as "Hardware."  "Connections" would
be a better name for this tab (I think).

4. While creating a new "Device" without a modem set up on the
"Hardware" tab, the program does not detect the U.S. Robotics 56k
Voice Faxmodem Pro in usb mode.  The kernel uses the Communication
Device Class (CDC) Abstract Control Model (ACM) kernel module driver
for this modem (this driver is part of the standard kernel).  I could
manually select the device node (/dev/input/ttyACM0) and select the
port speed (460800).  After setting up the phone number to dial and
such and finishing up the wizard, yay, there is a new connection/"Device."

But not all is hunky dory.  When I activate the connection, the port
speed remains set at 9600, instead of going all the way up to 460800
like I set it to be.  So the modem connection is only 9.6 kbps instead
of the circa 50 kbps that is expected and desired.



Version-Release number of selected component (if applicable):
redhat-config-network-1.2.15-1

How reproducible:
Always

Steps to Reproduce:
1. I kind of already said it all
2.
3.


Actual Results:  9600 bps modem connection

Expected Results:  circa 50 kbps modem connection

Additional info:

Now, I understand perfectly well that this program is just a front
end, and some terminal based programs are actually doing the footwork
of carrying out these tasks.  So I tried messing around with some
other programs to find a workaround for the port speed issue, which is
the most troubling.

One of these programs is WvDial.  I ran that and verified that the
connection was only 9600.  I tried modifying some of the init lines to
no success in changing the connection speed.

SetSerial does not seem to work on the ACM device node, and I haven't
found a workaround to get SetSerial to work on it.

I did find a fix to get the port speed up, and that was to use
minicom.  However, I was only able to get it up to 230400 instead of
the zippier 460800, since minicom's limit is different than the
modem's limit.  However, there was still a hitch here.  I had to make
a soft link from /dev/input/ttyACM0 to /dev/ttyS32, otherwise minicom
wouldn't recognize the modem correctly.

After the minicom configuration, in order to get the port speed up, I
had to start minicom, exit minicom, then start the connection using
WvDial or the RH-CFG-Network program.

I had a lot of these issues with detection and port speed settings
going back to Red Hat Linux 7.3.  I had to use this same workaround
then.  I wish I reported them then, unfortunately all of the
old-school Linux users are going to lose out if this get's fixed.
Comment 1 Bug Zapper 2008-04-03 11:31:29 EDT
Based on the date this bug was created, it appears to have been reported
against rawhide during the development of a Fedora release that is no
longer maintained. In order to refocus our efforts as a project we are
flagging all of the open bugs for releases which are no longer
maintained. If this bug remains in NEEDINFO thirty (30) days from now,
we will automatically close it.

If you can reproduce this bug in a maintained Fedora version (7, 8, or
rawhide), please change this bug to the respective version and change
the status to ASSIGNED. (If you're unable to change the bug's version
or status, add a comment to the bug and someone will change it for you.)

Thanks for your help, and we apologize again that we haven't handled
these issues to this point.

The process we're following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.
Comment 2 Bug Zapper 2008-05-06 19:57:40 EDT
This bug has been in NEEDINFO for more than 30 days since feedback was
first requested. As a result we are closing it.

If you can reproduce this bug in the future against a maintained Fedora
version please feel free to reopen it against that version.

The process we're following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp

Note You need to log in before you can comment on or make changes to this bug.