Bug 1131558 - set default value for smime-CA-directory
Summary: set default value for smime-CA-directory
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: emacs
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jan Synacek
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords: Reopened
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-19 14:48 UTC by Tom Tromey
Modified: 2016-02-15 09:51 UTC (History)
3 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2016-02-15 09:51:36 UTC


Attachments (Terms of Use)

Description Tom Tromey 2014-08-19 14:48:59 UTC
I had to set smime-CA-directory in my .gnus.
I did this:

(setq smime-CA-directory "/etc/ssl/certs/ca-bundle.crt")

However, it seems to me that this is something that
should probably be done by default by the Fedora packaging.

Comment 1 Jaroslav Reznik 2015-03-03 16:13:26 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 22 development cycle.
Changing version to '22'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora22

Comment 2 Fedora Admin XMLRPC Client 2015-12-15 11:27:15 UTC
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.

Comment 4 Glenn Morris 2016-02-05 22:55:11 UTC
I don't understand this report (which by the way was forwarded to
http://debbugs.gnu.org/20960 ).

On RHEL7 at least, /etc/ssl/certs/ca-bundle.crt is a (symlink to a) file, not a directory. So I can't see that the applied patch makes any sense.

Maybe there was a typo in the original report?
Perhaps "smime-CA-file" was intended?

Comment 5 Jan Synacek 2016-02-08 08:25:15 UTC
My mistake... On Fedora, this should be (setq smime-CA-directory "/etc/ssl/certs/"). I'm not even sure why this was proposed to be "fixed" upstream, it looks like a downstream "configuration" to me. Thanks for pointing this out!


Note You need to log in before you can comment on or make changes to this bug.