Bug 11316 - ypbind doesn't...
Summary: ypbind doesn't...
Status: CLOSED DUPLICATE of bug 11235
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: ypbind (Show other bugs)
(Show other bugs)
Version: 6.1
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Florian La Roche
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-05-08 23:49 UTC by martin
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-05-22 15:54:33 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description martin 2000-05-08 23:49:53 UTC
If there is no name server available at boot time (i.e. because the
ypclient in question is the name server, and BIND starts after ypbind)
ypbind will fail to bind if the server is specified in /etc/yp.conf a la:

  domain ypdomain server ypserver.mydomain.com

Or, to be more specific, ypbind WILL NOT use /etc/hosts to determine the
hostname of the server specified in /etc/yp.conf and therefore if there is
no dns server available, the ypbind will fail.

One workaround is to change the start order of named to preceed ypbind.
IIRC, I was able to use the server's IP address in place of its name, and
that did work, but I don't remember for certain now.

This is ypbind-3.3-24, which ships with RH6.1 -- I did not see any updates
for this package in the updates directory.

Comment 1 Cristian Gafton 2000-05-22 15:54:59 UTC
assigned to laroche

Comment 2 Preston Brown 2000-10-16 19:20:39 UTC

*** This bug has been marked as a duplicate of 11235 ***


Note You need to log in before you can comment on or make changes to this bug.